No color gradient on Application title bar when Firefox is maximized with tabs on title bar

RESOLVED DUPLICATE of bug 624292

Status

()

Firefox
Theme
RESOLVED DUPLICATE of bug 624292
8 years ago
8 years ago

People

(Reporter: Biju, Unassigned)

Tracking

({regression})

unspecified
x86
Windows XP
regression
Points:
---

Firefox Tracking Flags

(blocking2.0 -)

Details

Attachments

(2 attachments)

(Reporter)

Description

8 years ago
Created attachment 504306 [details]
fx_3.6_vs_4.0_n2.png

When there is tabs on Firefox Application title bar, ie is when Firefox is maximized, the color gradient on Application title bar does not appear on Windows standard/classic theme.

See attachment fx_3.6_vs_4.0_n2.png
(Reporter)

Updated

8 years ago
blocking2.0: --- → ?
was it that way before tabs in the titlebar?

Comment 2

8 years ago
(In reply to comment #1)
> was it that way before tabs in the titlebar?

No. I have had the same problem, and it has gotten like this since the upgrade to 4.0b9. If I put the tabs back under the address bar, the titlebar gradient comes back, fullscreen or not.

Comment 3

8 years ago
I have the same problem in windows server 2003 with the classic theme. The fading of the title bar disappears when maximized.
Bug, but not a blocker.
blocking2.0: ? → -
(In reply to comment #2)
> (In reply to comment #1)
> > was it that way before tabs in the titlebar?
> 
> No. I have had the same problem, and it has gotten like this since the upgrade
> to 4.0b9. If I put the tabs back under the address bar, the titlebar gradient
> comes back, fullscreen or not.

I was asking for regression info, did it occur in nightly builds before the tabs in the titlebar landed in nightlies, not the beta.

Comment 6

8 years ago
(In reply to comment #5)
> (In reply to comment #2)
> > (In reply to comment #1)
> > > was it that way before tabs in the titlebar?
> > 
> > No. I have had the same problem, and it has gotten like this since the upgrade
> > to 4.0b9. If I put the tabs back under the address bar, the titlebar gradient
> > comes back, fullscreen or not.
> 
> I was asking for regression info, did it occur in nightly builds before the
> tabs in the titlebar landed in nightlies, not the beta.

Ah. I do not know about that, I don't use the nightlies. The only info I have is that in 4.0b8, it was fine. 4.0b8 didn't have tabs in the titlebar though, which is where my assumption came from.
(Reporter)

Comment 7

8 years ago
(In reply to comment #5)
> I was asking for regression info, did it occur in nightly builds before the
> tabs in the titlebar landed in nightlies, not the beta.
No

Comment 8

8 years ago
On Mozilla/5.0 (Windows NT 6.0; rv:2.0b10pre) Gecko/20110118 Firefox/4.0b10pre ID:20110118030327 the gradient comes back if "Tabs on Top" is disabled.

Comment 9

8 years ago
Perhaps I'm wrong, but this seems like a necessary evil due to the new interface layout. With the controls now in the far right (directly to the left of the Window controls) for the tab list and Panorama, I believe they intentionally place a solid background behind them in order to make sure that they're properly visible. Depending on the theme being used (for example, I use Watercolor/Luna), there might be something other than even a gradient behind the buttons otherwise, making them extremely difficult to see properly. Perhaps ONLY on the Classic theme this could be considered an issue. With anything beyond that though, it becomes far too unpredictable. I'm attaching an example of what I mean in regards to the Watercolor theme. Also change this to Windows XP (it's anything using the Classic theme...which is what the original poster's screenshot was of), since all versions above that are affected.
OS: Windows Vista → Windows XP

Comment 10

8 years ago
Created attachment 504739 [details]
Watercolor theme example

Example of the issue that might crop up in anything beyond the Classic view with regards to the background of the titlebar being preserved. The graphic in the Watercolor theme would certainly cause issues with the buttons placed on top of them. Side note: this isn't a matter of parity with any other browsers either. All existing browsers that have a "Tabs in titlebar" setup, seem to appear to take the same stance, with a completely solid background for the bar itself.

Comment 11

8 years ago
(In reply to comment #10)
> All existing browsers that have a "Tabs in titlebar" setup, seem to
> appear to take the same stance, with a completely solid background for the bar
> itself.

Maybe my eyes are failing me, but I do see a gradient on the original mockup from bug 572160 at https://bug572160.bugzilla.mozilla.org/attachment.cgi?id=451674

Comment 12

8 years ago
Looks like a dupe of bug 624292
(Reporter)

Comment 13

8 years ago
(In reply to comment #12)
> Looks like a dupe of bug 624292
Correct, and your work around (bug 624292 Comment 3) works almost great
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 624292
(Reporter)

Updated

8 years ago
No longer blocks: 572160
You need to log in before you can comment on or make changes to this bug.