Last Comment Bug 626421 - Non-clickable area on top of each tab in Windows XP (tabs in titlebar)
: Non-clickable area on top of each tab in Windows XP (tabs in titlebar)
Status: RESOLVED FIXED
[softblocker]
:
Product: Firefox
Classification: Client Software
Component: Theme (show other bugs)
: unspecified
: x86 Windows XP
: -- normal with 3 votes (vote)
: Firefox 4.0
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
: 628052 (view as bug list)
Depends on: 570279
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-17 07:53 PST by pumay
Modified: 2013-12-27 14:34 PST (History)
13 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
final+


Attachments
Hover the tab, normal (25.89 KB, image/jpeg)
2011-01-17 07:54 PST, pumay
no flags Details
Non-clickable area on top of each tab and not hover (23.51 KB, image/jpeg)
2011-01-17 07:57 PST, pumay
no flags Details
Windows XP - 120 DPI (7.82 KB, image/jpeg)
2011-02-04 14:08 PST, Michael Kraft [:morac]
no flags Details

Description pumay 2011-01-17 07:53:03 PST
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0b9) Gecko/20100101 Firefox/4.0b9
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b9) Gecko/20100101 Firefox/4.0b9

Non-clickable area on top of each tab

Reproducible: Always

Steps to Reproduce:
1. Ensure you have browser.tabs.drawInTitlebar option set to true, tabs on top,
and your browser window is maximized.
2. Open some tabs.
3. Keep your mouse pointer at the very top of screen 
4. The tabs is no highlighted and is non-clickable.

Expected Results:  
Should be able to click anywhere along tab bar.
Actual Results:  
Unable to click and activate any tab 

Expected Results:  
Should be able to click anywhere along top tab bar
Comment 1 pumay 2011-01-17 07:54:49 PST
Created attachment 504472 [details]
Hover the tab, normal
Comment 2 pumay 2011-01-17 07:57:32 PST
Created attachment 504475 [details]
Non-clickable area on top of each tab and not hover
Comment 3 Jo Hermans 2011-01-17 08:22:18 PST

*** This bug has been marked as a duplicate of bug 624129 ***
Comment 4 Dão Gottwald [:dao] 2011-01-17 08:32:46 PST
Not a duplicate of bug 624129
Comment 5 Jo Hermans 2011-01-17 08:53:34 PST
No, but the discussion is there.
Comment 6 Dão Gottwald [:dao] 2011-01-17 09:48:09 PST
(In reply to comment #5)
> No, but the discussion is there.

Still doesn't make this a duplicate.
Comment 7 pumay 2011-01-17 09:51:49 PST
(In reply to comment #3)
> 
> *** This bug has been marked as a duplicate of bug 624129 ***

Not a duplicate, because bug 624129 - for x86 Windows 7
This bug on Windows XP.
Comment 8 Jo Hermans 2011-01-17 11:44:51 PST
It's the same code. Even though Windows XP still uses the menubar as default, it can also display the tabs in the titlebar (otherwise you wouldn't have seen the bug in the first place).
Comment 9 Dão Gottwald [:dao] 2011-01-17 12:42:27 PST
Same code, quite different bug report.
Comment 10 Luke Iliffe (Harlequin99) 2011-01-17 15:13:58 PST
Dup of bug 624225 instead?
Comment 11 Marat Tanalin | tanalin.com 2011-01-19 10:20:25 PST
Just note: under Windows 7, the bug is not exposed. Firefox 4 under Windows XP should behave just the same as under Windows 7.

Tab clickability face to face to top screen edge with no any unclickable gaps is very important for usability of tabs placed in titlebar.
Comment 12 pumay 2011-01-19 11:42:39 PST
(In reply to comment #11)
> Just note: under Windows 7, the bug is not exposed. Firefox 4 under Windows XP
> should behave just the same as under Windows 7.
> 
> Tab clickability face to face to top screen edge with no any unclickable gaps
> is very important for usability of tabs placed in titlebar.

This bug ONLY under Windows XP !
In Windows 7 all OK.
Comment 13 Marat Tanalin | tanalin.com 2011-01-19 11:48:11 PST
(In reply to comment #12)
> This bug ONLY under Windows XP !
> In Windows 7 all OK.

This is exactly what is my comment about.
Comment 14 Asa Dotzler [:asa] 2011-01-20 16:15:13 PST
I think this should be a softblocker for XP. It's not the default toolbar state but for those who do switch, it's an unfortunate shortcoming in a very common usage case.
Comment 15 Jo Hermans 2011-01-22 14:51:03 PST
*** Bug 628052 has been marked as a duplicate of this bug. ***
Comment 16 Sheila Mooney 2011-01-25 14:01:21 PST
Johnath, here's another one for your list.
Comment 17 Michael Kraft [:morac] 2011-02-04 14:08:27 PST
Created attachment 509892 [details]
Windows XP - 120 DPI

I'm running Windows XP on a laptop set to a DPI setting of "Large size (120
DPI)" and the different is a lot worse.  Tabs only take up about 60% the title
bar.

I never even realized it was supposed to take up the entire title bar.
Comment 18 Michael Kraft [:morac] 2011-02-04 14:24:12 PST
Just to give you some values of the different elements heights on my machine:

1. The titlebar vbox has a height of 32px.
2. The TabsToolbar toolbar has a height of 23px.
3. The tab-view-deck deck has a height of 1158px.
4. The entire window has a height of 1170px.
Comment 19 Zio_Fede 2011-04-11 23:15:42 PDT
New branding changes triggered this bug again.
Comment 20 Mike Beltzner [:beltzner, not reading bugmail] 2011-04-12 02:03:32 PDT
Re-opening as per comment 19.
Comment 21 Dão Gottwald [:dao] 2011-04-12 05:02:13 PDT
Bug 640490 has been backed out, closing again.

Note You need to log in before you can comment on or make changes to this bug.