XULRunner Error Platform version '2.0b9' is not compatible - from Portable Beta 9




8 years ago
6 years ago


(Reporter: ewerybody, Unassigned)


Firefox Tracking Flags

(Not tracked)




8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv: Gecko/20101203 Firefox/3.6.13 (.NET CLR 3.5.30729)
Build Identifier: http://portableapps.com/apps/internet/firefox_portable/test

I installed and setup FF4 Beta 9 Portable at my office PC.: Win7 64 Professional
Synced it to the cloud.
After coming home and syncing here: Win7 32 Home Premium
FF4 beta won't run. All I get is a popupwindow:


Error: Platform version '2.0b9' is not compatible with
minVersion >= 2.0b7
maxVersion <= 2.0b7

not even firefox.exe -safe-mode worked.
( bummer. I'm doing this for years with previous versions of Firefox :/ )

Reproducible: Always

Seems no crash report is written. Or does XULRunner put it somewhere else?
I'd love to give more about this. But yet I don't know how.
That is no crash.
In short: Firefox itself are 2 parts: The Firefox UI and Gecko/XULrunner Core.
Firefox4.0b9 requires Gecko2.0b9 and this message tells you that Firefox4.0b9 found only Gecko2.0b7. Gecko2.0b7 is used by Firefox4.0b7 

Look at the first line of your report, your UA shows that you are using Gecko which itself is used by Firefox3.6.13

We got a few reports with the official Firefox installer and the cause is always some kind of stupid security software like Zonealarm forcefield which is doing some kind of virtualization. The installer updated all files but the Security software rolled the Gecko/XULrunner core back to an old version.

The portable Version is not from Mozilla and that makes this report invalid.
We would also mark it invalid if you used an official Firefox version unless you can prove that no stupid security Software is involved.
Last Resolved: 8 years ago
Resolution: --- → INVALID

Comment 2

8 years ago
no crash? :D
Of course I'm reporting from my old 3.6 Firefox! I mean.. How should I report then if the new one doesn't start?

Ok. lets be productive: Stupid Security software? I installed it with Eset NOD32 enabled on the Win7 64 Pro. Worked like a charm there.
Here (at home Win7 Home 32) is only MSE enabled. No Zonealarm or other ****.
So: I guess the installer must have installed it correctly on the Win7 64 if it runs there. True?

Suggestions? Or am I too invalid now?
I understand that you are only reporting from FF3.6.13

I don't think that Eset comes with a virtualization feature.
You are using a portableapps version of Firefox. In that case report your problem to them because it's a build/packaging/installer issue.

On the other side I would remove Firefox Beta8 and manually clean the directory except your profile folder. I don't know where portableapps puts your profile, the normal firefox build put your profile in your user directory but they must changed the location for portableapps. After that reinstall it.

Comment 4

8 years ago
Ok. Great thanks! you are right.
I check back at work and then I report to portable dudes.

I actually had a former beta installed in the folder but I remember to have cleaned it before. Portable FF dir looks like:
Firefox4Test\App -- with \Firefox\Firefox.exe
Firefox4Test\Data -- with \profile
Firefox4Test\FirefoxPortable.exe -- portable starter

And if I start the firefox.exe directly it works with a profile from \users
thanks again.

Comment 5

6 years ago
I have the same problem on a 11.0 installation (Win7 32 Enterprise). After upgrading to 12.0 with the automatic update system, on the release update channel, I get the same error message :


  Error: Platform version '11.0' is not compatible with
  minVersion >= 12.0
  maxVersion <= 12.0

I suspected the shortcut to be the cause, but it fails even when I am directly launching firefox.exe.

The error is still there after upgrading from 12.0 to 13.0.

However, hyperlinks from other applications are successfully launching Firefox.
You need to log in before you can comment on or make changes to this bug.