Closed Bug 626529 Opened 9 years ago Closed 9 years ago

"This is unsafe! Fix the caller!" when toggling View -> Menu Bar on Windows 7

Categories

(Core :: DOM: UI Events & Focus Handling, defect)

x86
Windows 7
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 671635

People

(Reporter: Dolske, Assigned: smaug)

References

Details

(Whiteboard: [sg:moderate?] may be problem for extensions)

Toggling the regular (old-style) menu bar on Windows 7 (via App Menu --> Options --> Menu Bar, or if the menu bar is already shown, View --> Toolbars --> Menu Bar) triggers a "This is unsafe! Fix the caller!" assert. Reproducible with a current trunk debug build.

Stack looks like:

  NS_DebugBreak_P
  nsEventDispatcher::Dispatch
  PresShell::FireBeforeResizeEvent
  PresShell::ResizeReflowIgnoreOverride
  PresShell::ResizeReflow
  PresShell::ResizeReflow
  nsViewManager::DoSetWindowDimensions
  nsViewManager::SetWindowDimensions
  nsViewManager::DispatchEvent
  AttachedHandleEvent
  nsWindow::DispatchEvent
  nsWindow::DispatchWindowEvent
  nsWindow::OnResize
  nsWindow::ResetLayout
  nsWindow::UpdateNonClientMargins
  nsWindow::SetNonClientMargins
  nsXULElement::SetChromeMargins
  nsXULElement::AfterSetAttr
  nsGenericElement::SetAttrAndNotify

(raw stack: http://pastebin.mozilla.org/952834)
Blocks: 602962
Oh, interesting. This is a bug in nsXULElement::AfterSetAttr.
The problem isn't the new event, but that nsXULElement::AfterSetAttr
does something which may cause reflow.
My bad, I reviewed the code.

Fortunately only chrome can trigger this, AFAIK.
Blocks: 513162
No longer blocks: 602962
Whiteboard: [sg:moderate?] may be problem for extensions
Olli, can you look into this?
Assignee: nobody → Olli.Pettay
Wasn't this fixed by bug 671635?
Yes, I think so.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 671635
Group: core-security
Component: Event Handling → User events and focus handling
You need to log in before you can comment on or make changes to this bug.