Closed Bug 626553 Opened 9 years ago Closed 5 years ago

XML parser seemingly inserts FFFF characters into XML which results in a parsing error

Categories

(Firefox :: General, defect)

3.6 Branch
x86
Windows 7
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 569229

People

(Reporter: sleep.supermeister, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13

When I open certain XML files, Firefox gives me an XML Parsing Error, showing me an FFFF character somewhere in the document which results in a "not well-formed" error. However, there are no such characters in these files. (I checked that using a hex editor. I have also validated the XML files.) When I delete the section from the XML file where the imaginary character is supposed to be, Firefox may or may not give me the same error at a different position, depending on how many parts I have deleted. Unfortunately, the XML files contain sensitive information, so I can't show them publicly. I have not yet managed to create a dummy file that results in the same behavior. The files are encoded with UTF-8 and contain lots of CDATA sections with Windows-style line breaks (CR LF) in them.

Reproducible: Always



Expected Results:  
Display the XML tree.
Version: unspecified → 3.6 Branch
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 569229
You need to log in before you can comment on or make changes to this bug.