Errant "Do you want to save your tabs?" Message [probably caused by Add-on SDK]

VERIFIED WORKSFORME

Status

Add-on SDK
General
VERIFIED WORKSFORME
7 years ago
6 years ago

People

(Reporter: Chris B., Assigned: kinger)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(4 attachments, 1 obsolete attachment)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b10pre) Gecko/20110118 Firefox/4.0b10pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b10pre) Gecko/20110118 Firefox/4.0b10pre

I have the following tabs open:

http://nightly.mozilla.org/
http://games.latimes.com/index_crossword.html?uc_feature_code=tmcal
http://www.patsajakgames.com/games/psgcc_online.html
http://www.patsajakgames.com/games/luckyletters_online.html
http://www.bigfishgames.com/download-games/10833/chronicles-of-mystery-tree-of-life/index.html?src=dailygamesplash


When I look at the game images on the last site (Big Fish) and then click the close button on the screenshot pop up, I receive the "Do you want to save your tabs?" message.  This shouldn't pop up unless I click on the MAIN red X where all my other tabs are.  I only have ONE Minefield window open.

Reproducible: Always

Steps to Reproduce:
See above.
Actual Results:  
"Do you want to save tabs?" errantly pops up when closing a pop up window.

Expected Results:  
"Save tabs?" should only appear when clicking on the red X to the right of all tabs currently open.
(Reporter)

Comment 1

7 years ago
*** ADDITIONAL NOTE ***

When only ONE tab is open and it is a Big Fish Games game page, this bug does not appear.  This error just appeared now when I had Microsoft as First Tab, Big Fish Games as Second Tab, and this Bugzilla Report as Third Tab.

I am just using the popular Big Fish Games site as an example to show the bug to your programmers, but would think this error appears on any site with pop up windows / screenshots.

I am going to see if I can figure out what Nightly build it works.
(Reporter)

Comment 2

7 years ago
It took me a little while, but I found the regression range!

WORKS = 1295031121-20110114105201-9caa011615ff-firefox-4.0b10pre.en-US.win32.zip
BROKEN = 1295031826-20110114110346-1eb45ae169fa-firefox-4.0b10pre.en-US.win32.zip
(Reporter)

Updated

7 years ago
Summary: Errant "Do you want to save your tabs?" Message → *** REGRESSION *** Errant "Do you want to save your tabs?" Message
(Reporter)

Updated

7 years ago
Keywords: regression
(Reporter)

Comment 3

7 years ago
Just in case anyone is wondering.....I reported this on the 1/18 build, but it is also broken on the 1/19 Nightly as well (Windows 32-Bit download).
(Reporter)

Comment 4

7 years ago
*** ANOTHER NOTE ***
This bug only occurs in the first browser window I have open.

If I open a new, blank window with the same tabs or even different tabs, the error disappears in BOTH the first and second windows.  However, if I then close all the tabs in the second window, the error reappears in the first window.  Hope this makes sense to whoever is viewing this bug report.
(Reporter)

Updated

7 years ago
blocking2.0: --- → ?
(Reporter)

Updated

7 years ago
Component: General → Tabbed Browser
Version: unspecified → Trunk
(Reporter)

Updated

7 years ago
Priority: -- → P1

Updated

7 years ago
Priority: P1 → --
QA Contact: general → tabbed.browser
(In reply to comment #2)
> WORKS =
> 1295031121-20110114105201-9caa011615ff-firefox-4.0b10pre.en-US.win32.zip
> BROKEN =
> 1295031826-20110114110346-1eb45ae169fa-firefox-4.0b10pre.en-US.win32.zip

This doesn't look correct. There is only one check-in in that range which only changes the keyboard shortcut for Panorama.

http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=9caa011615ff&tochange=1eb45ae169fa

Can you please check again, even with a nightly build?
Keywords: regressionwindow-wanted
(Reporter)

Comment 6

7 years ago
(In reply to comment #5)
> (In reply to comment #2)
> > WORKS =
> > 1295031121-20110114105201-9caa011615ff-firefox-4.0b10pre.en-US.win32.zip
> > BROKEN =
> > 1295031826-20110114110346-1eb45ae169fa-firefox-4.0b10pre.en-US.win32.zip
> 
> This doesn't look correct. There is only one check-in in that range which only
> changes the keyboard shortcut for Panorama.
> 
> http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=9caa011615ff&tochange=1eb45ae169fa
> 
> Can you please check again, even with a nightly build?

I wanted to report with a Nightly build, but how to I download older ones?
You can get them here:
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2011/01/
(Reporter)

Comment 8

7 years ago
(In reply to comment #7)
> You can get them here:
> http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2011/01/

Thanks - I figured it out after you posted that.  I am still working on finding the breaking point.
(Reporter)

Comment 9

7 years ago
Mozilla.....you better thank me for taking the time to do this.

I didn't realize this regression was so HUGE.  I had to go back THREE MONTHS to find a Nightly build (Windows 32-Bit) that works!


Works = 10/26/10 Nightly
Broken = Everything after and including 10/27/10 Nightly.
Can you please open the about:buildconfig page for both of those builds and tell us the changeset id - the link which is listed at the top.
(Reporter)

Comment 11

7 years ago
(In reply to comment #10)
> Can you please open the about:buildconfig page for both of those builds and
> tell us the changeset id - the link which is listed at the top.

Sure, please give me a couple minutes, need to reinstall 10/26 and 10/27 builds.
(Reporter)

Comment 12

7 years ago
(In reply to comment #10)
> Can you please open the about:buildconfig page for both of those builds and
> tell us the changeset id - the link which is listed at the top.

10/26/10 = http://hg.mozilla.org/mozilla-central/rev/d253c44465ae
10/27/10 = http://hg.mozilla.org/mozilla-central/rev/2f456d0310fa
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=d253c44465ae&tochange=2f456d0310fa

I still can't find a reasonable check-in in this time period.

Do you have any extensions installed? I can't reproduce it at all. Would be great if you could run a test in safe mode (http://support.mozilla.com/en-US/kb/Safe Mode).
Keywords: regressionwindow-wanted
(Reporter)

Comment 14

7 years ago
Okay - following extension are running:

1) Hard blockers counter 0.8 By Zbigniew Braniecki
2) Norton IPS 2.0
3) RealPlayer Browser Record Plugin 14.0.1

Do you want me to do the Safe Mode test with the current Nightly or with the October build?
(Reporter)

Comment 15

7 years ago
This bug was reported BEFORE I installed the Hard Blocker Counter.
(Reporter)

Comment 16

7 years ago
(In reply to comment #13)
> Pushlog:
> http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=d253c44465ae&tochange=2f456d0310fa
> 
> I still can't find a reasonable check-in in this time period.
> 
> Do you have any extensions installed? I can't reproduce it at all. Would be
> great if you could run a test in safe mode
> (http://support.mozilla.com/en-US/kb/Safe Mode).

Problem does NOT occur in Safe Mode!  How do I diagnose further to determine the cause?
(Reporter)

Comment 17

7 years ago
In Safe Mode, ALL of my Plug-ins are running, so that can't be the cause of the problem.

Extensions:
1) DNA 1.0.0.1                              (Incompatible - so doesn't run)
2) Hard blockers counter 0.8
3) Norton IPS 2.0
4) Norton Toolbar 5.5                       (Incompatible - so doesn't run)
5) Personas 1.6.1                           (Incompatible - so doesn't run)
6) RealPlayer Browser Record Plugin 14.0.1
7) Toolbar - Big Fish Games 2.1             (Won't display anything - disabled)
8) Virtual Account Numbers 3.7.11.0         (Incompatible - so doesn't run)

Appearance:
I use "Default 4.0b10pre By Mozilla".
(Reporter)

Comment 18

7 years ago
Sorry, it IS the "Hard blockers counter 0.8".  I just disabled only that and the pop-up problem does not occur.  I am going to just copy the HTML link from that add on and save it to my Favorites menu, instead of having it on the Add On bar.

What do I do now?  Should I report this issue to the Add-on developer or will you, Mozilla, since it is posted on your site?


I downloaded it from:

https://addons.mozilla.org/en-US/firefox/addon/hard-blockers-counter/

and it currently says "This add-on has been preliminarily reviewed by Mozilla."
(Reporter)

Comment 19

7 years ago
Kind of sucks when an add-on you want breaks things!
(Reporter)

Comment 20

7 years ago
Mozilla, refer to bug 626728 for the Add-on developer e-mail address.
(Reporter)

Updated

7 years ago
Severity: major → normal
blocking2.0: ? → ---
Keywords: regression
Yes, please get in contact with the add-on author. He will be the one who has to fix that. Thanks for your time finding that data!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Component: Tabbed Browser → Extension Compatibility
QA Contact: tabbed.browser → extension.compatibility
Resolution: --- → INVALID
Summary: *** REGRESSION *** Errant "Do you want to save your tabs?" Message → Errant "Do you want to save your tabs?" Message [caused by Hard blockers counter 0.8]
(Reporter)

Comment 22

7 years ago
(In reply to comment #21)
> Yes, please get in contact with the add-on author. He will be the one who has
> to fix that. Thanks for your time finding that data!

Add-on developer contacted.  Hopefully he will update his "Known Issues" section on the add-on page after reading this bug (I sent him a link in the e-mail).
@whimboo, @chris: I have a hard time finding any connection between my extension and this issue. Nor I can reproduce it :(
(Reporter)

Comment 24

7 years ago
(In reply to comment #23)
> @whimboo, @chris: I have a hard time finding any connection between my
> extension and this issue. Nor I can reproduce it :(

I was afraid you would say that.  Not sure what the issue is though - just reporting what I am finding.
Chris, would there be a way to share the profile? If not, could you create a new one and populate it with extensions you also have in your normal profile? Would be good to know if it is reproducible.

Also when you open the game screenshot, how do they open? In a tab or as popup? Lets reopen for now.
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: INVALID → ---
when I'm trying to reproduce it, I open the screenshot in a new popup window, then I press the "close" button on the topmost toolbar (OS specific, not browser specific button) to close it.

I do not see any popup.
(Reporter)

Comment 27

7 years ago
(In reply to comment #25)
> Chris, would there be a way to share the profile? If not, could you create a
> new one and populate it with extensions you also have in your normal profile?
> Would be good to know if it is reproducible.
> 
> Also when you open the game screenshot, how do they open? In a tab or as popup?
> Lets reopen for now.

If you can tell me how to share the profile, I would love to so that at least one other person can see the issue I am experiencing.

Not sure how to create a brand new profile either.

I created a video showing the bug.
(Reporter)

Comment 28

7 years ago
Sorry - I was trying to upload a video to show issue but not sure how to keep it under 2 MB.  See screenshot for how popups appear.
(Reporter)

Comment 29

7 years ago
Maybe I can upload the video (converted to Shockwave Flash file).
(Reporter)

Comment 30

7 years ago
Created attachment 505614 [details]
Video Showing the Bug in Action
(Reporter)

Comment 31

7 years ago
Nope - that didn't work.
(Reporter)

Comment 32

7 years ago
Steps to reproduce:

1) Have Hard Blocker addon installed (see comment 18).
2) Go to any site in the first tab.
3) Open www.bigfishgames.com in the second tab.  [See Screen 1 attachment].
4) Click on one of the game images.  [See Screen 2 attachment].
5) Close the pop up window.  Tab message appears errantly.  [See Screen 3 attachment].
(Reporter)

Comment 33

7 years ago
Created attachment 505616 [details]
Comment 32 - Screen 1
(Reporter)

Comment 34

7 years ago
Created attachment 505617 [details]
Comment 32 - Screen 2
Attachment #505614 - Attachment is obsolete: true
(Reporter)

Comment 35

7 years ago
Created attachment 505618 [details]
Comment 32 - Screen 3
Chris, go to Help | Troubleshooting. There you will find a button to open the profile folder. Copy all those files to a temporary location and make sure to delete all files which contain private data. Those are places.*, search.*, cookies.*, signons*, and bookmarkbackups (folder).

After that compress the files as zip archive and send it to hskupin(at)mozilla.com. Thanks for you willingness to share the profile. There is a good chance to get this sorted out. Btw. the behavior looks strange.
(Reporter)

Comment 37

7 years ago
(In reply to comment #36)
> Chris, go to Help | Troubleshooting. There you will find a button to open the
> profile folder. Copy all those files to a temporary location and make sure to
> delete all files which contain private data. Those are places.*, search.*,
> cookies.*, signons*, and bookmarkbackups (folder).
> 
> After that compress the files as zip archive and send it to
> hskupin(at)mozilla.com. Thanks for you willingness to share the profile. There
> is a good chance to get this sorted out. Btw. the behavior looks strange.

Mr. Skupin - I have my profile created, but am unable to send it to you!  I tried both (hskupin@mozilla.com) AND (hskupin@mozilla.org) and both came right back to me with a "Delivery Status Notification (Failure)" in my e-mail.
(In reply to comment #37)
> Mr. Skupin - I have my profile created, but am unable to send it to you!  I
> tried both (hskupin@mozilla.com) AND (hskupin@mozilla.org) and both came right
> back to me with a "Delivery Status Notification (Failure)" in my e-mail.

Looks like filter restrictions are in-place. Please send me the profile as given here on Bugzilla.
(Reporter)

Comment 39

7 years ago
Created attachment 505823 [details]
My Firefox Profile (Minus Personal Info) to Diagnose Bug
Please don't attach profiles to bugzilla. For now I have made this attachment private, so only members of the core team will have access to it. I will investigate later today. Thanks.
(Reporter)

Comment 41

7 years ago
(In reply to comment #40)
> Please don't attach profiles to bugzilla. For now I have made this attachment
> private, so only members of the core team will have access to it. I will
> investigate later today. Thanks.

Sorry - But you stated "Please send me the profile as given here on Bugzilla" so I assumed that to mean post an attachment to Bugzilla.  I was kind of iffy about uploading my profile on Bugzilla.  Why didn't you just say "Send it to my Gmail account"?  I am kind of a newbie on Bugzilla (started around October 2010) and haven't used it for years, like Alice in Japan, so I don't know what some of the rules are for attachments / profile uploads / etc.
Sorry, but looks like I missed "by my email address" in that comment. No-one will have access to the profile, and I will request to delete it once we have found the cause.
Btw. this profile doesn't have the hardblocker extension installed. So are you sure that you have sent me the right version?
(Reporter)

Comment 44

7 years ago
Sorry - forgot about that.  I removed the addon.  I will resend the profile to your e-mail account.
(Reporter)

Comment 45

7 years ago
I am working on resending you the profile, Henrik.  I am also getting a weird small screen window popup when clicking the two digit number for the addon to display the current blockers (in the addon bar).  I then have to click on that mini window to display the blocking bugs.
(Reporter)

Comment 46

7 years ago
(In reply to comment #43)
> Btw. this profile doesn't have the hardblocker extension installed. So are you
> sure that you have sent me the right version?

Check your GMail account, Henrik, and remove the incorrect profile post from this Bugzilla report (not sure how to do that).
(Reporter)

Comment 47

7 years ago
I would like to see if this bug appears on a brand new profile, but am unsure how to do that.  Maybe my Minefield setting files / profile got corrupted somehow.
(Reporter)

Comment 48

7 years ago
Henrik:

Great news!

I backed up my bookmarks, uninstalled Minefield with the clear settings option (I still have the broken profile on my Desktop), reinstalled the Hard Blocker Addon, and everything is working correctly.

The only issue I have is if the following problem I am experiencing is indeed a bug with the addon.  The issue is this:
Am I supposed to be able to click on the "76" (current number) on the bottom right to load the Bugzilla website and list those 76 bugs?

What I am experiencing right now is the following.  First time I installed the addon, when I clicked on the "76" nothing happened.  Then, when I closed Minefield and restarted the program, now when I click on the "76" I get a little popup window (I will provide a screenshot).  Clicking on this mini window loads the Bugzilla page, listing the 76 bugs remaining.  Is this normal behavior for the addon?

Even with this problem, I am not seeing the errant save tabs message any more with this new profile.  Not sure if you want to keep this open to figure out what got corrupted with my old profile that I sent you and how that corruption affected tabbed browsing.
(Reporter)

Comment 49

7 years ago
Created attachment 505928 [details]
Mini Window Appears with Addon (did not appear during addon first run)
@Chris:

You seem to be using version 0.8, can you try version 1.0 - https://addons.mozilla.org/en-US/firefox/addon/hard-blockers-counter/versions/?page=1#version-1.0 - it should work much better :)

Glad it's solved, but I'm wondering what caused the original bug anyway...
(Reporter)

Comment 51

7 years ago
(In reply to comment #50)
> @Chris:
> 
> You seem to be using version 0.8, can you try version 1.0 -
> https://addons.mozilla.org/en-US/firefox/addon/hard-blockers-counter/versions/?page=1#version-1.0
> - it should work much better :)
> 
> Glad it's solved, but I'm wondering what caused the original bug anyway...

Version 1.0 is now installed and I see something similar to this when clicking on the number:

---------------------------- (green line)
|
|since 21/01/2011
---------------------------- (black line)


What is this window supposed to display?

Also, when I click on "latest version" on the site you provided above in the text "Be careful with old versions!  These versions are displayed for reference and testing purposes. You should always use the latest version of an add-on.", version 0.8 is what loads as the most current and is thus what I downloaded.
Chris: when you aggregate more data points it'll show a trend line of changes over time.

Yeah, that's how AMO prevents you from choosing other version than the reviewed ones - unfortunately it means that I have to wait days after releasing a version until it's "reviewed".
(Assignee)

Comment 53

7 years ago
I suspect this is an Add-ons SDK (Jetpack) bug.

It is happening with another SDK based add-on. I can reproduce intermittently.

Add-on:
http://www.interoperabilitybridges.com/html5-extension-for-wmp-plugin

Test page:
http://www.gsmarena.com/samsung_i9010_galaxy_s_giorgio_armani-review-554.php
(Click on phone pictures to get popup)

Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.9) Gecko/20100824 Firefox/3.6.9

Other users are seeing it:
http://support.mozilla.com/ak/questions/669132
http://support.mozilla.com/bs/questions/775249
(Assignee)

Comment 54

7 years ago
(In reply to comment #53)
> Add-on:
> http://www.interoperabilitybridges.com/html5-extension-for-wmp-plugin
> 
> Test page:
> http://www.gsmarena.com/samsung_i9010_galaxy_s_giorgio_armani-review-554.php
> (Click on phone pictures to get popup)
> 
> Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.9) Gecko/20100824
> Firefox/3.6.9

I can more reliably reproduce on:
Mozilla/5.0 (Windows NT 6.1; rv:2.0b9) Gecko/20100101 Firefox/4.0b9

Although you will have to install the Add-on Compatibility Reporter for the HTML5 Extension to be compatible.
Interesting fact Brian! Thanks for your input. It would explain why the hardblocker Jetpack is affected by that. Sadly I'm not able to reproduce it yet on any my Windows machines. Can you reproduce it in a recent nightly build?
Status: REOPENED → NEW
Component: Extension Compatibility → General
Product: Firefox → Add-on SDK
QA Contact: extension.compatibility → general
Summary: Errant "Do you want to save your tabs?" Message [caused by Hard blockers counter 0.8] → Errant "Do you want to save your tabs?" Message [probably caused by Add-on SDK]
Version: Trunk → unspecified
The content of attachment 505823 [details] has been deleted by
    Gervase Markham [:gerv] <gerv@mozilla.org>
who provided the following reason:

Request from the uploader, because it contains personal information.

The token used to delete this attachment was generated at 2011-01-25 07:12:16 PST.
The Firefox profile attached to this bug has been deleted.

Gerv
(Reporter)

Comment 58

7 years ago
(In reply to comment #57)
> The Firefox profile attached to this bug has been deleted.
> 
> Gerv

Thank you for deleting the profile I uploaded after collecting your necessary data.  I am sorry but cannot provide any more bug details, since I now have a new profile and the Blocker Count addon is working fine and doesn't cause the popup error anymore.  I see that other people have experienced this problem and it occurs in other addons, which is a good indication that a solution will be found.
(Assignee)

Comment 59

7 years ago
To summarise, with:

> Add-on:
> http://www.interoperabilitybridges.com/html5-extension-for-wmp-plugin
> 
> Test page:
> http://www.gsmarena.com/samsung_i9010_galaxy_s_giorgio_armani-review-554.php

I *can* reproduce reliably on:

- Firefox 3.6.9
- Firefox 4b9

I *can not* reproduce on the most recent nightly:

- Mozilla/5.0 (Windows NT 6.1; rv:2.0b10pre) Gecko/20110125 Firefox/4.0b10pre

... which points to it not being a Jetpack bug.
(Assignee)

Updated

7 years ago
Duplicate of this bug: 621173
(Assignee)

Comment 61

7 years ago
Wondering out loud if bug 592822 "fixed" this, i.e. if the pref 'browser.warnOnQuit' is set back to true will we I see this again on a nightly. I'm not in a position to test this right now, but will later.
Duplicate of this bug: 629316
(In reply to comment #59)
> - Firefox 3.6.9
> - Firefox 4b9
> 
> I *can not* reproduce on the most recent nightly:

Do you have a clean profile? Are any plugins active? Any extensions installed? I really would like to be able to reproduce this problem. If you have such a profile would you mind sharing it with me?
(Assignee)

Comment 64

7 years ago
(In reply to comment #61)
> Wondering out loud if bug 592822 "fixed" this, i.e. if the pref
> 'browser.warnOnQuit' is set back to true will we I see this again on a nightly.
> I'm not in a position to test this right now, but will later.

Yep, I suspected right. The issue is not fixed, just masked by the checkin for bug 592822, i.e. when 'browser.warnOnQuit' is true, the behaviour in popups is seen even on the nightly.

Comment 65

7 years ago
I can confirm that html5-extension-for-wmp-plugin is causing the problem. Disabling this add-on solves the problem.
(Assignee)

Comment 66

7 years ago
(In reply to comment #65)
> I can confirm that html5-extension-for-wmp-plugin is causing the problem.
> Disabling this add-on solves the problem.

The root of the problem *may* be in the Add-ons SDK, because it happens with another add-on as well (https://addons.mozilla.org/en-US/firefox/addon/hard-blockers-counter/).

I need to investigate more.
(Assignee)

Comment 67

7 years ago
I have narrowed the cause down to this checkin:

https://github.com/mozilla/addon-sdk/commit/64ea77c833aa00b67950dba1bde1ed580a0d931c

I have yet to determine if the fix is wrong, or if it is a bug in another SDK module, e.g. window-utils.

It appears to only happen with add-ons that use page-mod.
Assignee: nobody → briks.si
Brian: HBC does not use page-mod, but it uses tabs, which share some code with page-mod and are known to cause at least one more bug: bug 628188.

Updated

7 years ago
Hardware: x86_64 → x86
(In reply to comment #67)
> I have yet to determine if the fix is wrong, or if it is a bug in another SDK
> module, e.g. window-utils.
> 
> It appears to only happen with add-ons that use page-mod.

Brian, do you have any update on for that bug?
I'm under the impression this has been fixed on the latest tip of the SDK code.  If that's incorrect, however, please reopen!
Status: NEW → RESOLVED
Last Resolved: 7 years ago6 years ago
Resolution: --- → FIXED
No known patch -> WFM. Brian, can you verify it?
Resolution: FIXED → WORKSFORME
(Assignee)

Comment 72

6 years ago
I can indeed verify that this issue has gone away. I have a version of the WMP add-on built with *beta 3* of the SDK and can not reproduce any more.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.