Closed Bug 626997 Opened 9 years ago Closed 9 years ago

Bogus resizer in maximized and fullscreen windows

Categories

(Firefox :: General, defect, major)

x86
Windows XP
defect
Not set
major

Tracking

()

VERIFIED FIXED
Firefox 4.0b11
Tracking Status
blocking2.0 --- final+

People

(Reporter: dao, Assigned: enndeakin)

References

Details

(Keywords: polish, regression, Whiteboard: [softblocker][fx4-fixed-bugday])

Attachments

(2 files, 2 obsolete files)

There's a resizer at the bottom right corner in maximized and fullscreen windows. It's functional, allowing the window to resize the window in a mode where windows aren't supposed to be resizable.
blocking2.0: --- → ?
Severity: normal → major
I reused the existing 'resize' listener in the tabs binding rather than create a new one.
Assignee: nobody → enndeakin
Status: NEW → ASSIGNED
Attachment #505164 - Flags: review?(dao)
Comment on attachment 505164 [details] [diff] [review]
hide resizer when maximized or fullscreen

>       <method name="updateWindowResizers">
>         <body><![CDATA[
>           if (!window.gShowPageResizers)
>             return;
> 
>-          var show = document.getElementById("addon-bar").collapsed;
>+          let windowState = window.windowState;
>+          var show = document.getElementById("addon-bar").collapsed &&
>+                     windowState != window.STATE_MAXIMIZED &&
>+                     windowState != window.STATE_FULLSCREEN;

How about window.windowState == window.STATE_NORMAL?

>@@ -2858,16 +2861,17 @@
>                 break;
>               var width = this.mTabstrip.boxObject.width;
>               if (width != this.mTabstripWidth) {
>                 this.adjustTabstrip();
>                 this._fillTrailingGap();
>                 this._handleTabSelect();
>                 this.mTabstripWidth = width;
>               }
>+              gBrowser.updateWindowResizers();

should be this.tabbrowser.updateWindowResizers();
Attached patch patch, version 2 (obsolete) — Splinter Review
Attachment #505164 - Attachment is obsolete: true
Attachment #505459 - Flags: review?(dao)
Attachment #505164 - Flags: review?(dao)
Comment on attachment 505459 [details] [diff] [review]
patch, version 2

>--- a/browser/base/content/tabbrowser.xml
>+++ b/browser/base/content/tabbrowser.xml
>@@ -177,17 +177,19 @@
>         ]]></getter>
>       </property>
> 
>       <method name="updateWindowResizers">
>         <body><![CDATA[
>           if (!window.gShowPageResizers)
>             return;
> 
>-          var show = document.getElementById("addon-bar").collapsed;
>+          let windowState = window.windowState;
>+          var show = document.getElementById("addon-bar").collapsed &&
>+                     windowState == window.STATE_NORMAL;

No need to assign window.windowState to a variable anymore.
Attachment #505459 - Flags: review?(dao) → review+
Attachment #505459 - Attachment is obsolete: true
Attachment #505499 - Flags: review+
Attachment #505499 - Flags: approval2.0?
Attachment #505499 - Flags: approval2.0? → approval2.0+
http://hg.mozilla.org/mozilla-central/rev/95f9c203178e
Status: ASSIGNED → RESOLVED
blocking2.0: ? → ---
Closed: 9 years ago
Resolution: --- → FIXED
Duplicate of this bug: 629292
Duplicate of this bug: 629315
The resizer still shows up when opening a new tab in an already-maximized window.
Status: RESOLVED → REOPENED
blocking2.0: --- → ?
Resolution: FIXED → ---
Happy to keep approving patches, but I can't see us blocking on this issue.
blocking2.0: ? → -
Keywords: polish
(In reply to comment #0)
> It's functional, allowing the window to resize the window in a mode
> where windows aren't supposed to be resizable.

To be more clear: This leads to an entirely unexpected and broken state. The window remains in maximized or fullscreen mode despite its size.
blocking2.0: - → ?
Attachment #507833 - Flags: review?(dao) → review+
Attachment #507833 - Flags: approval2.0?
blocking2.0: ? → final+
Whiteboard: [softblocker]
Comment on attachment 507833 [details] [diff] [review]
extra patch to update resizer when new tab is created

a=beltzner
Attachment #507833 - Flags: approval2.0? → approval2.0+
http://hg.mozilla.org/mozilla-central/rev/214a2453b441
Status: REOPENED → RESOLVED
Closed: 9 years ago9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 4.0b11
Verified fixed in Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b12pre) Gecko/20110204 Firefox/4.0b12pre
Status: RESOLVED → VERIFIED
Whiteboard: [softblocker] → [softblocker][fx4-fixed-bugday]
You need to log in before you can comment on or make changes to this bug.