Can't mark a collapsed thread read in a newsgroup when the first message as read

RESOLVED INVALID

Status

MailNews Core
Networking: NNTP
RESOLVED INVALID
8 years ago
8 years ago

People

(Reporter: standard8, Unassigned)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
Probably a regression from bug 575732.

If I have a newsgroup thread which is collapsed and selected, and the top message is read but the rest of the messages are read; then I cannot mark the thread as read, I can only mark it unread.

Comment 1

8 years ago
The same thing happens for me in 3.1, so this can't be a regression from bug 575732. Mark thread as read ("R") still works on trunk, which is good.

Maybe the behavior should be changed, but I thought this was intentional since collapsed newsgroup threads don't have summaries and thus we're really just looking at the root message.

Bug 478167 would fix this in a roundabout way and get us some other nice stuff, like gloda in news.
(Reporter)

Comment 2

8 years ago
Oh, so the bit that probably confused me is the change of location for marking a thread as read (for some reason I tend to use the context menu for threads).

I didn't notice it on the sub-menu either.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.