License agreement dialog will not contain anything after scrolling down Readme

VERIFIED FIXED in mozilla0.9

Status

P4
normal
VERIFIED FIXED
18 years ago
14 years ago

People

(Reporter: teruko, Assigned: samir_bugzilla)

Tracking

Trunk
mozilla0.9
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [xpibug] Fix in hand)

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
This is similar bug to 58604.

If  you use ja_JP locale on Redhad Linux, the license agreement dialog will not
contain anything after you scroll down the readme dialog.

Steps of reproduce
1. Start ./netscape-installer
   Now, the readme dialog shows up.
2. Use scroll bar to scroll at the bottom of the readme
3. Click on Next button on Readme dialog
   License agreement dialog will not contain anything.

I tried English locale in the same Redhat 6.2 system, but this is not
reproduciable. 

If you do not scroll down in readme dialog, you can see the document in
License agreement dialog.

Tested 2000-11-08 MN6, 2000-12-12-08 Mtrunk,  and 2000-12-11-16-Mtest Linux build.

Updated

18 years ago
QA Contact: gemal → gbush

Comment 1

18 years ago
yokoyama said it should be intl and nsbeta1
Keywords: intl, nsbeta1

Comment 2

18 years ago
Teruko - Is this only hapenning for JA? Any ideas why EN works and JA does not
(i.e. Is it too long)?

Comment 3

18 years ago
remove nsbeta1
Keywords: nsbeta1

Comment 4

18 years ago
Need Info - Jaime to talk to legal and Ying to see if this is still happening.

Assinging to Jaime per Nav Triage team
Assignee: sgehani → jaimejr
(Reporter)

Comment 5

18 years ago
This is not JA version Netscape bug.  This is English Netscape with ja_JP locale
problem.  This is related to bug 58604.  Samir may know why this happens.

Yuying, please check this in the latest English build with Japanese Redhat linux
to see this is still reproduciable.

QA Contact: gbush → ylong

Comment 6

18 years ago
It still exists in 01-09-2001 Mtrunk build with Japanese locale linux.

Comment 7

18 years ago
I am confused, is this a lang pack or build issue???

If this is a build issue, Legal says need need to fix this one (i.e. The user
needs to be able to read the ENTIRE agreement the first time it is displayed).
(Reporter)

Comment 8

18 years ago
Jaime, this is not Lang pack problem. ja_JP is not language pack.  I was talking
about ja_JP locale which means in Redhat Japanese system. This is English
installer problem with Redhat Japanese.  I tested this Netscape JA rtm with
Rethat 6.2 JA. I cannot reproduce it. However, this is reproduciable Netscape
English rtm with Redhat 6.2JA.

This need to be reassigned to sgehani@netscape.com.  Added nsbeta1 in keyword.
Assignee: jaimejr → sgehani
Keywords: nsbeta1

Comment 9

18 years ago
This is a "Must Fix" accroding to legal.

Adding Vishy to cc: list.
Whiteboard: [xpibug]
Target Milestone: --- → mozilla0.9
Moz 0.9 tasks
(Assignee)

Updated

18 years ago
Priority: P3 → P4

Updated

18 years ago
Keywords: intl, nsbeta1 → nsbeta1+
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Whiteboard: [xpibug] → [xpibug] Waiting for ja_JP locale system from i18n to debug on
(Assignee)

Updated

18 years ago
Whiteboard: [xpibug] Waiting for ja_JP locale system from i18n to debug on → [xpibug]
(Assignee)

Comment 11

18 years ago
Created attachment 27955 [details] [diff] [review]
Initialize license and readme buffers to file size + 1 (instead of just file size).
(Assignee)

Updated

18 years ago
Whiteboard: [xpibug] → [xpibug] Fix in hand

Comment 12

18 years ago
r=ssu
(Assignee)

Comment 13

18 years ago
Created attachment 28069 [details] [diff] [review]
Revised patch to remove DEBUG printf.

Comment 14

18 years ago
sr=mscott
(Assignee)

Comment 15

18 years ago
Fix checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 16

18 years ago
Fixed verified on 03-29 trunk build.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.