Error when editing article based on unreviewed localized revision

VERIFIED FIXED in 2.5

Status

support.mozilla.org
Knowledge Base Software
P1
normal
VERIFIED FIXED
7 years ago
7 years ago

People

(Reporter: jsocol, Assigned: jsocol)

Tracking

unspecified

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Assignee)

Description

7 years ago
Described here[1].

1. Click on a not-yet-reviewed revision in the history.
2. Click "Edit article based on this revision"
3. Edit the article
4. Upon saving the article I get the error 



[1] https://support.mozilla.com/en-US/forums/contributors/704919#post-7490
It works for English articles, might be that this is restricted to localizations, would have to check though
Okay, confirmed. You can't edit an article based on an unreviewed localized version.
Summary: Issue editing article based on a revision → Issue editing article based on a localized revision
Summary: Issue editing article based on a localized revision → Error when editing article based on a localized revision
Summary: Error when editing article based on a localized revision → Error when editing article based on unreviewed localized revision
Upping priority, since apparently a lot of people use this feature to 'save temporarily' and then hit broken functionality
Priority: -- → P1
(Assignee)

Updated

7 years ago
Assignee: nobody → james
(Assignee)

Comment 4

7 years ago
https://github.com/jsocol/kitsune/commit/2783924

The commit message contains STR as well.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Verified able to edit localized unreviewed translation w/o error
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.