Closed Bug 627393 Opened 9 years ago Closed 9 years ago

[Accelerated Layers] Whole content area gets black for a second for pages that uses a dimming effect

Categories

(Core :: Graphics, defect, minor)

x86
Windows 7
defect
Not set
minor

Tracking

()

VERIFIED FIXED
Tracking Status
blocking2.0 --- betaN+

People

(Reporter: redsign, Assigned: roc)

References

()

Details

(Keywords: regression, Whiteboard: [softblocker][fx4-fixed-bugday])

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b10pre) Gecko/20110120 Firefox/4.0b10pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0b10pre) Gecko/20110120 Firefox/4.0b10pre

The whole content area is getting black for a second if a site dims the whole site like in AMO if you click on one of the preview pictures for an add-on. 

Reproducible: Always

Steps to Reproduce:
1. Go to https://addons.mozilla.org/en-US/firefox/addon/stratiform/
2. Make sure that Direct2D/Layers with DirectX 10 is enabled
3. Click on of the preview pictures
Actual Results:  
Whole content area gets black for a second. 

Expected Results:  
Site should dim without getting completely black. 

Occurs only with hardware acceleration enabled.

  Grafik

        Karten-Beschreibung
        NVIDIA GeForce 8600 GTS

        Vendor-ID
        10de

        Geräte-ID
        0400

        Karten-Ram
        256

        Karten-Treiber
        nvd3dum nvwgf2um,nvwgf2um

        Treiber-Version
        8.17.12.6089

        Treiber-Datum
        10-8-2010

        Direct2D aktiviert
        true

        DirectWrite aktiviert
        true (6.1.7600.20830)

        WebGL-Renderer
        NVIDIA Corporation -- GeForce 8600 GTS/PCI/SSE2 -- 3.3.0

        GPU-beschleunigte Fenster
        1/1 Direct3D 10
Summary: Whole content area gets black for a second for pages that uses a dimming effect → [D2D] Whole content area gets black for a second for pages that uses a dimming effect
I can confirm on Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b10pre) Gecko/20110120 Firefox/4.0b10pre with an HD4330.
Confirming.
Problem appeared with 20110120 nightly.
With build: Mozilla/5.0 (Windows NT 6.1; rv:2.0b10pre) Gecko/20110119 Firefox/4.0b10pre is fine.

Graphics: 
Adapter Description NVIDIA GeForce 8400 GS
Vendor ID 10de
Device ID 06e4
Adapter RAM 512
Adapter Driver snvd3dum nvwgf2um,nvwgf2um
Driver Version 8.17.12.6658
Driver Date 1-7-2011
Direct2D Enabled true
DirectWrite Enabled true (6.1.7600.20830)
WebGL Renderer TransGaming Inc. -- ANGLE -- OpenGL ES 2.0 (git-devel Jan 19 2011 03:41:44)
GPU Accelerated Windows1/1 Direct3D 10
Regression window:
Works:
http://hg.mozilla.org/mozilla-central/rev/e807269acaa3
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b10pre) Gecko/20110119
Firefox/4.0b10pre ID:20110119030331
Fails:
http://hg.mozilla.org/mozilla-central/rev/710c1a6faf99
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b10pre) Gecko/20110119
Firefox/4.0b10pre ID:20110119003149
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=e807269acaa3&tochange=710c1a6faf99
Status: UNCONFIRMED → NEW
Component: General → Graphics
Ever confirmed: true
Keywords: regression
Product: Firefox → Core
QA Contact: general → thebes
Version: unspecified → Trunk
blocking2.0: --- → ?
Seems likely to be Bug 625409
Indeed, please retest after Bug 625409 check-in.
In local build,
build from 9163f9b80bce : fails
build from e807269acaa3 : works
Regressed by:
9163f9b80bce	Robert O'Callahan — Bug 625409. ColorLayer implementations need to premultiply by the alpha value of their color. r=bas,a=blocking
Blocks: 625409
Assignee: nobody → roc
blocking2.0: ? → betaN+
Whiteboard: [softblocker]
Mozilla/5.0 (Windows NT 5.1; rv:2.0b10pre) Gecko/20110121 Firefox/4.0b10pre ID:20110121030329

this is still a problem
I changed the title since this seems to be a problem with accelerated layers and not D2D. I tried with D2D only(set layers.acceleration.disabled;true) and it does not occur any longer.
Summary: [D2D] Whole content area gets black for a second for pages that uses a dimming effect → [Accelerated Layers] Whole content area gets black for a second for pages that uses a dimming effect
This same thing is seen on www.jango.com if you search an artist then click "pics" and then click on a picture.
Seems to be D3D10-only for me.
Attached patch fixSplinter Review
I am stupid.
Attachment #506490 - Flags: review?(bas.schouten)
Whiteboard: [softblocker] → [softblocker][needs review]
Attachment #506490 - Flags: review?(bas.schouten) → review+
Whiteboard: [softblocker][needs review] → [softblocker][needs landing]
http://hg.mozilla.org/mozilla-central/rev/dd3dcc6f3b1d
Status: NEW → RESOLVED
Closed: 9 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Whiteboard: [softblocker][needs landing] → [softblocker]
Verified fixed in Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b12pre) Gecko/20110204 Firefox/4.0b12pre
Status: RESOLVED → VERIFIED
Whiteboard: [softblocker] → [softblocker][fx4-fixed-bugday]
Duplicate of this bug: 629408
You need to log in before you can comment on or make changes to this bug.