Lots of L10n repack failures after omnijar switch

RESOLVED FIXED in seamonkey2.1b2

Status

SeaMonkey
Build Config
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: Robert Kaiser, Assigned: Robert Kaiser)

Tracking

({regression})

Trunk
seamonkey2.1b2
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

6 years ago
I tried to make L10n repacks work fine with omni.jar and I mostly have succeeded, but what I didn't look at is repeated L10n repacks for different locales from the same directory structure, which is what our buildbots do. There seems to be a small glitch (missed porting from l10n.mk) that makes those fail.

I *should* have a patch for that, but I'm trying to confirm on a slave right now.
(Assignee)

Comment 1

6 years ago
Created attachment 505475 [details] [diff] [review]
port missed hunk

This ports the missing l10n.mk hunk from http://hg.mozilla.org/mozilla-central/rev/d37b6b337227 to suite/ as we're not using l10n.mk yet. I tested that it works on a slave with the steps our factories are applying.
Attachment #505475 - Flags: review?(bugspam.Callek)

Updated

6 years ago
Attachment #505475 - Flags: review?(bugspam.Callek) → review+
(Assignee)

Comment 2

6 years ago
Thanks for the fast review, pushed as http://hg.mozilla.org/comm-central/rev/1025dd5f0c49
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Summary: Lot of L10n repack failure after omnijar switch → Lots of L10n repack failures after omnijar switch
Target Milestone: --- → seamonkey2.1b2
Blocks: 588067
No longer depends on: 588067
Keywords: regression
You need to log in before you can comment on or make changes to this bug.