Last Comment Bug 627718 - Firefox - Does not report map tag info correctly
: Firefox - Does not report map tag info correctly
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Disability Access APIs (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla10
Assigned To: alexander :surkov
:
: alexander :surkov
Mentors:
https://biblio.brailcom.org/biblio/ca...
Depends on:
Blocks: treea11y
  Show dependency treegraph
 
Reported: 2011-01-21 07:31 PST by Frank DiPalermo
Modified: 2011-10-06 07:23 PDT (History)
5 users (show)
surkov.alexander: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (5.41 KB, patch)
2011-10-01 09:23 PDT, alexander :surkov
mzehe: review+
Details | Diff | Splinter Review

Description Frank DiPalermo 2011-01-21 07:31:14 PST
User-Agent:       Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; Tablet PC 2.0; MALC)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13

To Reproduce:
1. Open the URL.

Note that the map tag that encloses the two page tabs (Biblio and Help) is not exposed to assistive technology.

Reproducible: Always
Comment 1 David Bolter [:davidb] 2011-01-21 07:33:29 PST
Isn't this incorrect use of html? Not sure whether we should do anything here -- at least not for FF4. We assume maps are for image maps.
Comment 2 Marco Zehe (:MarcoZ) 2011-01-21 07:48:34 PST
This seems to have regressed. I remember bug 431615 having fixed this once. We also have test coverage, or at least I thought we had, but for some reason, this got lost at some point. We do get an accessible for the links map, but we don't test the links underneath anymore in our mochitests.
Comment 3 Frank DiPalermo 2011-01-21 11:53:55 PST
Yes, this is probably a poor use of the map tag, but doesn't it still point out a FF problem?
Comment 4 alexander :surkov 2011-10-01 09:23:55 PDT
Created attachment 563974 [details] [diff] [review]
patch
Comment 5 Marco Zehe (:MarcoZ) 2011-10-04 01:27:13 PDT
Comment on attachment 563974 [details] [diff] [review]
patch

r=me with one nit:

>+    // be used in conjuction with HTML image element and in this case we don't

typo: Conjunction (a missing n).

Also I wonder whether we should combine the test from tests/hyperlink/test_general.html into this one, too. There, we also only test if the links get created at all inside the map. What do you think?
Comment 6 alexander :surkov 2011-10-04 19:27:01 PDT
(In reply to Marco Zehe (:MarcoZ) from comment #5)

> Also I wonder whether we should combine the test from
> tests/hyperlink/test_general.html into this one, too. There, we also only
> test if the links get created at all inside the map. What do you think?

map used for grouping is just generic hypertext accessible. All we need is to make sure accessibles for map and its children are created in this case. Hyperlink tests aren't necessary I think because don't test new paths of code logic.
Comment 7 alexander :surkov 2011-10-04 23:26:52 PDT
inbound land http://hg.mozilla.org/integration/mozilla-inbound/rev/628c7f04dbbc
Comment 8 Marco Bonardo [::mak] 2011-10-05 05:13:05 PDT
https://hg.mozilla.org/mozilla-central/rev/628c7f04dbbc

Note You need to log in before you can comment on or make changes to this bug.