Closed Bug 627819 Opened 9 years ago Closed 9 years ago

Broken icon in the message "The Web Console logging API has been disabled by a script on this page"

Categories

(DevTools :: General, defect)

x86
Windows 7
defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED
Firefox 4.0b11

People

(Reporter: jk1700, Assigned: pcwalton)

References

Details

(Keywords: polish)

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b10pre) Gecko/20110121 Firefox/4.0b10pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b10pre) Gecko/20110121 Firefox/4.0b10pre

After opening the console the icon for the first message is broken, see the attachment

Reproducible: Always
Blocks: devtools4
Version: unspecified → Trunk
Attached image screenshot
Invalid icon shows only for the message "The Web Console logging API (console.log, console.info, console.warn, console.error) has been disabled by a script on this". On the screenshot there's a polish version of this message.
Summary: Broken icon in the first message in console → Broken icon in the message "The Web Console logging API has been disabled by a script on this page"
Blocks: 605621
No longer blocks: devtools4
I haven't seen this myself yet. Not sure if this is an l10n issue or a bad file.

Marking this as dependent on our other icon bug which adds some better visual polish to the icons and color palette.
Depends on: 609372
It's easy to reproduce this: just go to cnn.com (or any other site that defines the console object) and then open the web console and you'll see the message and the icon in question. I've cc'ed Patrick because it's possible that that icon is supposed to represent something.
Blocks: devtools4
its showing this icon without the proper offsets: chrome://global/skin/icons/webconsole.png
Status: UNCONFIRMED → NEW
Ever confirmed: true
specifically, it is missing: -moz-image-region: rect(10px, 20px, 20px, 10px); (or whatever it's correct rect values are)
so, this is the JS Error icon (the orange x).

Note that this is fixed in the blocking bug 609372. We should get that in.
Doh, I think I had caught all of those cases.
So this is caused by the half-baked CATEGORY_MISC. Killing it off and moving the "console API replaced" code to CATEGORY_JS should fix it.
Attached patch Proposed patch.Splinter Review
Quick fix attached.
Assignee: nobody → pwalton
Status: NEW → ASSIGNED
Attachment #506543 - Flags: review?(gavin.sharp)
Comment on attachment 506543 [details] [diff] [review]
Proposed patch.

I think gavin's traveling today. Moving to dolske for r+ing.
Attachment #506543 - Flags: review?(gavin.sharp)
Attachment #506543 - Flags: review?(dolske)
Attachment #506543 - Flags: feedback+
incidentally, bug 609372 doesn't fix this afterall as I suggested in c#7. Just sayin'.
Comment on attachment 506543 [details] [diff] [review]
Proposed patch.

rs=me
Attachment #506543 - Flags: review?(dolske)
Attachment #506543 - Flags: review+
Attachment #506543 - Flags: approval2.0+
Keywords: polish
Keywords: checkin-needed
Whiteboard: [checkin-needed]
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Whiteboard: [checkin-needed]
Target Milestone: --- → Firefox 4.0b11
Verified fixed on 

Mozilla/5.0 (Windows NT 6.1; rv:2.0b12pre) Gecko/20110206 Firefox/4.0b12pre
Status: RESOLVED → VERIFIED
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.