Last Comment Bug 627834 - Intermittent failure in browser_625257.js | newly created tab should be in save state
: Intermittent failure in browser_625257.js | newly created tab should be in sa...
Status: RESOLVED FIXED
: intermittent-failure
Product: Firefox
Classification: Client Software
Component: Session Restore (show other bugs)
: Trunk
: x86_64 Mac OS X
: -- normal (vote)
: ---
Assigned To: Mehdi Mulani [:mmm] (I don't check this)
:
: Mike de Boer [:mikedeboer]
Mentors:
Depends on:
Blocks: 438871 625257
  Show dependency treegraph
 
Reported: 2011-01-21 12:31 PST by Mehdi Mulani [:mmm] (I don't check this)
Modified: 2012-11-25 19:31 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Rework test to not use session save events. (2.58 KB, patch)
2011-01-21 15:42 PST, Mehdi Mulani [:mmm] (I don't check this)
paul: review+
Details | Diff | Splinter Review
Renaming and removing state tracker from test. (4.19 KB, patch)
2011-01-24 14:08 PST, Mehdi Mulani [:mmm] (I don't check this)
mars.martian+bugmail: review+
Details | Diff | Splinter Review

Description Mehdi Mulani [:mmm] (I don't check this) 2011-01-21 12:31:15 PST
Looks like this is a result from bug 625257.
Talked to zpao and we think that a session save state is being triggered from a previous test, or from changing the session save interval.

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1295634590.1295637530.19591.gz

TEST-PASS | chrome://mochitests/content/browser/browser/components/sessionstore/test/browser/browser_625257.js | newly created tab should exist by now
JavaScript strict warning: chrome://mochitests/content/browser/browser/components/sessionstore/test/browser/browser_625257.js, line 76: reference to undefined property tab.linkedBrowser.__SS_data
ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/sessionstore/test/browser/browser_625257.js | newly created tab should be in save state
TEST-INFO | chrome://mochitests/content/browser/browser/components/sessionstore/test/browser/browser_625257.js | Console message: [JavaScript Warning: "reference to undefined property tab.linkedBrowser.__SS_data" {file: "chrome://mochitests/content/browser/browser/components/sessionstore/test/browser/browser_625257.js" line: 76}]
++DOMWINDOW == 350 (0x145377148) [serial = 3932] [outer = 0x14159ec50]
TEST-PASS | chrome://mochitests/content/browser/browser/components/sessionstore/test/browser/browser_6252
Comment 1 Mehdi Mulani [:mmm] (I don't check this) 2011-01-21 15:42:07 PST
Created attachment 505985 [details] [diff] [review]
Rework test to not use session save events.

With this patch, the test manually does a save state but after the tab has loaded. This is to ensure that the tab has a history.count > 0, so that a save state will create a cache.

Because we do not wait for a save state, we no longer have to change any preferences!
Comment 2 Treeherder Robot 2011-01-22 04:37:06 PST
dao%mozilla.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1295696496.1295699341.20315.gz
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-central debug test mochitest-other on 2011/01/22 03:41:36

s: talos-r3-snow-013
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/sessionstore/test/browser/browser_625257.js | newly created tab should be in save state
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
Comment 3 Treeherder Robot 2011-01-22 04:37:48 PST
bill%wg9s.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1295696496.1295699341.20315.gz
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-central debug test mochitest-other on 2011/01/22 03:41:36

s: talos-r3-snow-013
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/sessionstore/test/browser/browser_625257.js | newly created tab should be in save state
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
Comment 4 Treeherder Robot 2011-01-23 23:16:42 PST
ehsan%mozilla.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1295849315.1295852268.2484.gz
Rev3 Fedora 12 mozilla-central debug test mochitest-other on 2011/01/23 22:08:35

s: talos-r3-fed-037
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/sessionstore/test/browser/browser_625257.js | newly created tab should be in save state
559 ERROR TEST-UNEXPECTED-FAIL | /tests/modules/plugin/test/test_visibility.html | [SimpleTest/SimpleTest.js, window.onerror] An error occurred - didPaint is not defined at http://mochi.test:8888/tests/modules/plugin/test/test_visibility.html:93
Comment 5 Treeherder Robot 2011-01-23 23:51:45 PST
philringnalda%gmail.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1295852403.1295855217.15590.gz
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-central debug test mochitest-other on 2011/01/23 23:00:03

s: talos-r3-snow-053
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/sessionstore/test/browser/browser_625257.js | newly created tab should be in save state
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
Comment 6 Treeherder Robot 2011-01-24 06:11:37 PST
mounir.lamouri%gmail.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1295873921.1295876851.31270.gz
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-central debug test mochitest-other on 2011/01/24 04:58:41

s: talos-r3-snow-045
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/sessionstore/test/browser/browser_625257.js | newly created tab should be in save state
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
Comment 7 Treeherder Robot 2011-01-24 09:31:49 PST
rcampbell%mozilla.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1295886812.1295889699.788.gz
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-central debug test mochitest-other on 2011/01/24 08:33:32

s: talos-r3-snow-023
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/sessionstore/test/browser/browser_625257.js | newly created tab should be in save state
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
Comment 8 Treeherder Robot 2011-01-24 09:32:19 PST
ehsan%mozilla.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1295886812.1295889699.788.gz
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-central debug test mochitest-other on 2011/01/24 08:33:32

s: talos-r3-snow-023
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/sessionstore/test/browser/browser_625257.js | newly created tab should be in save state
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
Comment 9 Paul O'Shannessy [:zpao] (not reading much bugmail, email directly) 2011-01-24 10:26:21 PST
Comment on attachment 505985 [details] [diff] [review]
Rework test to not use session save events.

First thing's first: we don't need the state setting or checking. The test is pretty linear now and with the listners being attached mostly as needed, then we shouldn't get into weird states.

>-// First, the newly created blank tab should trigger a save state.
>-function test_bug625257_1() {
>+function test_bug625257_1(aEvent) {

Let's call this firstOnLoad or something and rename onLoad similarly.

>+  tab.linkedBrowser.removeEventListener("load", test_bug625257_1, true);
>+
>+  let uri = aEvent.target.location;
>+  is(uri, "about:blank", "first load should be for about:blank");
>+
>+  // Trigger a save state.
>+  ss.getBrowserState();
>+
>   is(gBrowser.tabs[1], tab, "newly created tab should exist by now");
>   ok(tab.linkedBrowser.__SS_data, "newly created tab should be in save state");
> 
>   tab.linkedBrowser.loadURI(URI_TO_LOAD);
>   state = 0;
> }
> 
> let tabsListener = {
>   onLocationChange: function onLocationChange(aBrowser) {
>     gBrowser.removeTabsProgressListener(tabsListener);
>-    is(state, 0, "should be the first listener event");
>+    is(state, 0, "should occur after about:blank load");
>     state++;

Since we're getting rid of the state checks, you can just check that the currentURI is correct

> 
>     // Since we are running in the context of tabs listeners, we do not
>     // want to disrupt other tabs listeners.
>     executeSoon(function() {
>       tab.linkedBrowser.removeEventListener("load", onLoad, true);

This listener will not have been added yet so nothing to remove here.

Otherwise it looks good and takes out the dependency on the save notification.
Comment 10 Treeherder Robot 2011-01-24 11:47:36 PST
dholbert%mozilla.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1295895366.1295898236.13919.gz
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-central debug test mochitest-other on 2011/01/24 10:56:06

s: talos-r3-snow-038
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/sessionstore/test/browser/browser_625257.js | newly created tab should be in save state
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
Comment 11 Treeherder Robot 2011-01-24 12:32:41 PST
dtownsend%oxymoronical.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1295897911.1295900824.27742.gz
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-central debug test mochitest-other on 2011/01/24 11:38:31

s: talos-r3-snow-006
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/sessionstore/test/browser/browser_625257.js | newly created tab should be in save state
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
Comment 12 Treeherder Robot 2011-01-24 13:26:39 PST
ian%iangilman.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1295900855.1295903840.11424.gz
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-central debug test mochitest-other on 2011/01/24 12:27:35

s: talos-r3-snow-018
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/sessionstore/test/browser/browser_625257.js | newly created tab should be in save state
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
Comment 13 Mehdi Mulani [:mmm] (I don't check this) 2011-01-24 14:08:42 PST
Created attachment 506519 [details] [diff] [review]
Renaming and removing state tracker from test.

Will check-in pending a run through try.
Comment 14 Treeherder Robot 2011-01-24 15:06:14 PST
philringnalda%gmail.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1295907159.1295910005.12738.gz
Rev3 Fedora 12 mozilla-central debug test mochitest-other on 2011/01/24 14:12:39

s: talos-r3-fed-023
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/sessionstore/test/browser/browser_625257.js | newly created tab should be in save state
Comment 15 Treeherder Robot 2011-01-24 16:17:29 PST
philringnalda%gmail.com
http://tinderbox.mozilla.org/showlog.cgi?log=TraceMonkey/1295910039.1295912958.28892.gz
Rev3 MacOSX Snow Leopard 10.6.2 tracemonkey debug test mochitest-other on 2011/01/24 15:00:39

s: talos-r3-snow-008
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/sessionstore/test/browser/browser_625257.js | newly created tab should be in save state
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
Comment 16 Treeherder Robot 2011-01-24 17:39:45 PST
philringnalda%gmail.com
http://tinderbox.mozilla.org/showlog.cgi?log=TraceMonkey/1295915794.1295918745.29693.gz
Rev3 MacOSX Snow Leopard 10.6.2 tracemonkey debug test mochitest-other on 2011/01/24 16:36:34

s: talos-r3-snow-042
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/sessionstore/test/browser/browser_625257.js | newly created tab should be in save state
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
Comment 17 Treeherder Robot 2011-01-24 19:57:29 PST
Callek%gmail.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1295924474.1295927498.16326.gz
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-central debug test mochitest-other on 2011/01/24 19:01:14

s: talos-r3-snow-030
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/sessionstore/test/browser/browser_625257.js | newly created tab should be in save state
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
Comment 18 Treeherder Robot 2011-01-25 05:20:52 PST
bjarne%runitsoft.com
http://tinderbox.mozilla.org/showlog.cgi?log=MozillaTry/1295957275.1295960268.24061.gz
Rev3 MacOSX Snow Leopard 10.6.2 tryserver debug test mochitest-other on 2011/01/25 04:07:55

s: talos-r3-snow-045
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/sessionstore/test/browser/browser_625257.js | newly created tab should be in save state
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
Comment 19 Treeherder Robot 2011-01-25 08:01:26 PST
philringnalda%gmail.com
http://tinderbox.mozilla.org/showlog.cgi?log=TraceMonkey/1295957538.1295960476.25869.gz
Rev3 MacOSX Snow Leopard 10.6.2 tracemonkey debug test mochitest-other on 2011/01/25 04:12:18

s: talos-r3-snow-036
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/sessionstore/test/browser/browser_625257.js | newly created tab should be in save state
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
Comment 20 Treeherder Robot 2011-01-25 09:03:26 PST
dholbert%mozilla.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1295971001.1295973884.1364.gz
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-central debug test mochitest-other on 2011/01/25 07:56:41

s: talos-r3-snow-004
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/sessionstore/test/browser/browser_625257.js | newly created tab should be in save state
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
Comment 21 Treeherder Robot 2011-01-25 09:03:39 PST
tnikkel%gmail.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1295971001.1295973884.1364.gz
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-central debug test mochitest-other on 2011/01/25 07:56:41

s: talos-r3-snow-004
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/sessionstore/test/browser/browser_625257.js | newly created tab should be in save state
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
Comment 22 Mehdi Mulani [:mmm] (I don't check this) 2011-01-25 10:30:38 PST
Everything looked good on TryServer.
Pushed on mozilla-central: http://hg.mozilla.org/mozilla-central/rev/5d466f5defc9

Will keep bug open until branches merge and we can expect to not see this anymore.
Comment 23 Treeherder Robot 2011-01-25 11:35:33 PST
tnikkel%gmail.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1295980846.1295983778.21011.gz
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-central debug test mochitest-other on 2011/01/25 10:40:46

s: talos-r3-snow-021
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/sessionstore/test/browser/browser_625257.js | newly created tab should be in save state
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
Comment 24 Treeherder Robot 2011-01-25 14:37:08 PST
philringnalda%gmail.com
http://tinderbox.mozilla.org/showlog.cgi?log=TraceMonkey/1295991350.1295994411.13982.gz
Rev3 MacOSX Snow Leopard 10.6.2 tracemonkey debug test mochitest-other on 2011/01/25 13:35:50

s: talos-r3-snow-009
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/sessionstore/test/browser/browser_625257.js | newly created tab should be in save state
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
Comment 25 Treeherder Robot 2011-01-25 15:40:16 PST
philringnalda%gmail.com
http://tinderbox.mozilla.org/showlog.cgi?log=TraceMonkey/1295994762.1295997744.32436.gz
Rev3 Fedora 12 tracemonkey debug test mochitest-other on 2011/01/25 14:32:42

s: talos-r3-fed-038
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/sessionstore/test/browser/browser_625257.js | newly created tab should be in save state
Comment 26 Treeherder Robot 2011-01-25 16:20:03 PST
philringnalda%gmail.com
http://tinderbox.mozilla.org/showlog.cgi?log=TraceMonkey/1295997776.1296000670.15080.gz
Rev3 MacOSX Snow Leopard 10.6.2 tracemonkey debug test mochitest-other on 2011/01/25 15:22:56

s: talos-r3-snow-011
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/sessionstore/test/browser/browser_625257.js | newly created tab should be in save state
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
Comment 27 Treeherder Robot 2011-01-27 20:59:21 PST
philringnalda%gmail.com
http://tinderbox.mozilla.org/showlog.cgi?log=TraceMonkey/1296181422.1296184498.11359.gz
Rev3 MacOSX Snow Leopard 10.6.2 tracemonkey debug test mochitest-other on 2011/01/27 18:23:42

s: talos-r3-snow-020
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/sessionstore/test/browser/browser_625257.js | newly created tab should be in save state
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
Comment 28 Mehdi Mulani [:mmm] (I don't check this) 2011-04-26 16:15:52 PDT
Must've forgotten to close this as resolved when I committed the patch.

http://hg.mozilla.org/mozilla-central/rev/5d466f5defc9

Note You need to log in before you can comment on or make changes to this bug.