Closed Bug 627853 Opened 9 years ago Closed 9 years ago

Crash in GeckoConnectivityReceiver (java.lang.NullPointerException) upon device startup

Categories

(Firefox for Android Graveyard :: General, defect, critical)

ARM
Android
defect
Not set
critical

Tracking

(fennec2.0b4+)

RESOLVED FIXED
Tracking Status
fennec 2.0b4+ ---

People

(Reporter: aaronmt, Assigned: m_kato)

References

Details

(Keywords: crash, regression)

Attachments

(1 file)

Device: HTC Google Nexus One

Mozilla/5.0 (Android; Linux armv7l; rv:2.0b10pre) Gecko/20110121 Firefox/4.0b10pre Fennec/4.0b4pre

Log:

W/dalvikvm(  497): threadid=1: thread exiting with uncaught exception (group=0x4001d7f0)
E/AndroidRuntime(  497): FATAL EXCEPTION: main
E/AndroidRuntime(  497): java.lang.RuntimeException: Unable to start receiver org.mozilla.gecko.GeckoConnectivityReceiver: java.lang.NullPointerException
E/AndroidRuntime(  497): 	at android.app.ActivityThread.handleReceiver(ActivityThread.java:2821)
E/AndroidRuntime(  497): 	at android.app.ActivityThread.access$3200(ActivityThread.java:125)
E/AndroidRuntime(  497): 	at android.app.ActivityThread$H.handleMessage(ActivityThread.java:2083)
E/AndroidRuntime(  497): 	at android.os.Handler.dispatchMessage(Handler.java:99)
E/AndroidRuntime(  497): 	at android.os.Looper.loop(Looper.java:123)
E/AndroidRuntime(  497): 	at android.app.ActivityThread.main(ActivityThread.java:4627)
E/AndroidRuntime(  497): 	at java.lang.reflect.Method.invokeNative(Native Method)
E/AndroidRuntime(  497): 	at java.lang.reflect.Method.invoke(Method.java:521)
E/AndroidRuntime(  497): 	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:858)
E/AndroidRuntime(  497): 	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:616)
E/AndroidRuntime(  497): 	at dalvik.system.NativeStart.main(Native Method)
E/AndroidRuntime(  497): Caused by: java.lang.NullPointerException
E/AndroidRuntime(  497): 	at org.mozilla.gecko.GeckoConnectivityReceiver.onReceive(GeckoConnectivityReceiver.java:49)
E/AndroidRuntime(  497): 	at android.app.ActivityThread.handleReceiver(ActivityThread.java:2810)
E/AndroidRuntime(  497): 	... 10 more

https://mxr.mozilla.org/mozilla-central/source/embedding/android/GeckoConnectivityReceiver.java#49

STR: Install latest nightly (01/21), reboot Android device.
AR: "The application Fennec (process org.mozilla.fennec) has stopped unexpectedly. Please try again"
tracking-fennec: --- → ?
Depends on: 616075
The obvious fix here would be to use the provided context instead of the geckoapp context.
Attached patch fixSplinter Review
Assignee: nobody → m_kato
Attachment #506021 - Flags: review?(mwu)
Attachment #506021 - Flags: review?(mwu) → review+
tracking-fennec: ? → 2.0b4+
pushed http://hg.mozilla.org/mozilla-central/rev/42b5ac790e51

I've hit this a bunch this weekend
Status: NEW → RESOLVED
Closed: 9 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
I'm still crashing on startup with the same error message, using a Motorola Droid and the nightly Fennec build from 2011-01-24.

This is the log from the Dalvik Debug Monitor:
01-24 16:44:28.881: ERROR/AndroidRuntime(32156): FATAL EXCEPTION: Thread-9
01-24 16:44:28.881: ERROR/AndroidRuntime(32156): java.lang.NullPointerException
01-24 16:44:28.881: ERROR/AndroidRuntime(32156):     at java.util.Arrays$ArrayList.<init>(Arrays.java:49)
01-24 16:44:28.881: ERROR/AndroidRuntime(32156):     at java.util.Arrays.asList(Arrays.java:171)
01-24 16:44:28.881: ERROR/AndroidRuntime(32156):     at org.mozilla.gecko.GeckoAppShell.loadGeckoLibs(GeckoAppShell.java:169)
01-24 16:44:28.881: ERROR/AndroidRuntime(32156):     at org.mozilla.gecko.GeckoApp$3.run(GeckoApp.java:201)
01-24 16:44:28.881: ERROR/AndroidRuntime(32156):     at java.lang.Thread.run(Thread.java:1096)
(In reply to comment #4)
> I'm still crashing on startup with the same error message, using a Motorola
> Droid and the nightly Fennec build from 2011-01-24.
> 
> This is the log from the Dalvik Debug Monitor:
> 01-24 16:44:28.881: ERROR/AndroidRuntime(32156): FATAL EXCEPTION: Thread-9
> 01-24 16:44:28.881: ERROR/AndroidRuntime(32156): java.lang.NullPointerException
> 01-24 16:44:28.881: ERROR/AndroidRuntime(32156):     at
> java.util.Arrays$ArrayList.<init>(Arrays.java:49)
> 01-24 16:44:28.881: ERROR/AndroidRuntime(32156):     at
> java.util.Arrays.asList(Arrays.java:171)
> 01-24 16:44:28.881: ERROR/AndroidRuntime(32156):     at
> org.mozilla.gecko.GeckoAppShell.loadGeckoLibs(GeckoAppShell.java:169)
> 01-24 16:44:28.881: ERROR/AndroidRuntime(32156):     at
> org.mozilla.gecko.GeckoApp$3.run(GeckoApp.java:201)
> 01-24 16:44:28.881: ERROR/AndroidRuntime(32156):     at
> java.lang.Thread.run(Thread.java:1096)

Martijn, could you file a new bug?  This is another issue.
Ok, I filed bug 628926 for it.
You need to log in before you can comment on or make changes to this bug.