[SeaMonkey] xpcshell: permanent timeout in "test_browserGlue_corrupt_nobackup_default.js"

VERIFIED FIXED in seamonkey2.1b2

Status

SeaMonkey
Bookmarks & History
--
major
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: sgautherie, Assigned: neil@parkwaycc.co.uk)

Tracking

(Blocks: 1 bug, {regression})

Trunk
seamonkey2.1b2
regression
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [perma-orange], URL)

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
(This started during/after the SeaMonkey omnijar landing bustage,
so I'm not sure which changeset caused this...)

Last success:
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1295366333.1295368368.30209.gz
Linux comm-central-trunk debug test xpcshell on 2011/01/18 07:58:53
rev:476b91f50827
moz:141d92d974b4

First failure:
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1295465511.1295467739.19898.gz
Linux comm-central-trunk debug test xpcshell on 2011/01/19 11:31:51
rev:44bfbaecd266
moz:94271581b601
{
TEST-INFO | /builds/slave/test/build/xpcshell/tests/suite/common/places/tests/unit/test_browserGlue_corrupt_nobackup_default.js | running test ...

command timed out: 1200 seconds without output, killing pid 16770
}

Hopefully, this has the same cause as bug 627417.

KaiRo, can you check your c-c changesets?
(Reporter)

Updated

6 years ago
blocking-seamonkey2.1: --- → ?

Comment 1

6 years ago
http://hg.mozilla.org/comm-central/annotate/2e8f93800bce/suite/common/places/tests/unit/test_browserGlue_corrupt_nobackup_default.js#l101

>   // The test will continue once import has finished and smart bookmarks
>   // have been created.

Are we somehow hanging here? Marco do you have any advice?

Updated

6 years ago
No longer depends on: 627417

Comment 2

6 years ago
Looks like we need to port attachment 458864 [details] [diff] [review] as well.
(In reply to comment #2)
> Looks like we need to port attachment 458864 [details] [diff] [review] as well.

that was done for the omnijar, did you switch to it?
(Assignee)

Comment 4

6 years ago
Created attachment 506365 [details] [diff] [review]
Proposed patch
[Checked in: Comment 7]
Assignee: nobody → neil
Status: NEW → ASSIGNED
Attachment #506365 - Flags: review?(philip.chee)

Comment 5

6 years ago
Comment on attachment 506365 [details] [diff] [review]
Proposed patch
[Checked in: Comment 7]

r=me since this fixes the test and the default bookmarks are imported into a new profile.

Note to run one xpcshell test do something like this:

Philip@HARUHI /c/t1/hg/objdir-sm/suite/common/places/tests
$ SOLO_FILE=test_browserGlue_corrupt_nobackup_default.js  make check-one
Attachment #506365 - Flags: review?(philip.chee) → review+
(Reporter)

Updated

6 years ago
Blocks: 588067
Component: Testing Infrastructure → Bookmarks & History
Depends on: 556644
Keywords: regressionwindow-wanted
QA Contact: testing-infrastructure → bookmarks

Comment 6

6 years ago
(In reply to comment #3)
> (In reply to comment #2)
> > Looks like we need to port attachment 458864 [details] [diff] [review] as well.
> 
> that was done for the omnijar, did you switch to it?

Just to answer this: Yes, we did, see bug 588067.
(Reporter)

Updated

6 years ago
Blocks: 627417
(Assignee)

Comment 7

6 years ago
Pushed changeset 7821b0a1c9f5 to comm-central.
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Reporter)

Comment 8

6 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1295919374.1295920894.10770.gz
OS X 10.6 comm-central-trunk debug test xpcshell on 2011/01/24 17:36:14

V.Fixed
Status: RESOLVED → VERIFIED
blocking-seamonkey2.1: ? → ---
(Reporter)

Updated

6 years ago
Attachment #506365 - Attachment description: Proposed patch → Proposed patch [Checked in: Comment 7]
You need to log in before you can comment on or make changes to this bug.