Closed Bug 628132 Opened 9 years ago Closed 9 years ago

Crash [@ mozilla::ipc::RPCChannel::CxxStackFrame::CxxStackFrame] (from PContentPermissionRequestParent::Send__delete__)

Categories

(Core :: DOM: Geolocation, defect)

x86
Linux
defect
Not set

Tracking

()

VERIFIED FIXED
Tracking Status
fennec 2.0+ ---

People

(Reporter: jdm, Assigned: alexp)

Details

Attachments

(1 file)

I was able to reproduce a chrome crash by tapping Allow on a geolocation prompt at the same time as I crashed the content process.  Obviously unlikely in real life, but we could rectify the problem by having the ContentPermissionParent call a function on the request proxy in ActorDestroy to null out mParent.
Summary: Crash [@ mozilla::ipc::RPCChannel::CxxStackFrame::CxxStackFrame] (from PContentPermissionHelper::Send__delete__) → Crash [@ mozilla::ipc::RPCChannel::CxxStackFrame::CxxStackFrame] (from PContentPermissionRequestParent::Send__delete__)
tracking-fennec: --- → ?
tracking-fennec: ? → 2.0+
Assignee: nobody → alexp
Attached patch FixSplinter Review
Josh, is this patch what you meant?

Can you give more exact steps how you reproduced it? What site did you use, and are there any specific timing requirements?
I wanted to try it on maps.google.com, but for some reason cannot open that at the moment.
Yep, that looks good to me.  When I first reported the problem, I was going to google maps and killing the content process from a terminal, and then I immediately afterwards press Allow or Cancel on the prompt.  I don't think it's worth trying to reproduce, however, since there's a bug that makes Fennec unusable if a geolocation prompt is showing and the content process dies.
Attachment #511137 - Flags: review?(doug.turner)
Attachment #511137 - Flags: review?(doug.turner) → review?(jones.chris.g)
Comment on attachment 511137 [details] [diff] [review]
Fix

Looks OK to me, assuming dougt is happy with it.
Attachment #511137 - Flags: review?(jones.chris.g) → review+
Keywords: checkin-needed
yup.  thanks for fixing.
pushed:
http://hg.mozilla.org/mozilla-central/rev/0644a18eb249
Status: NEW → RESOLVED
Closed: 9 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Cannot find any recent reports of this crash -- marking verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.