Closed Bug 628134 Opened 9 years ago Closed 9 years ago

Closing the last tab twice breaks "Undo closed tab" feature

Categories

(Firefox :: Session Restore, defect)

x86
Windows 7
defect
Not set

Tracking

()

VERIFIED DUPLICATE of bug 581937

People

(Reporter: sidrabbit, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b10pre) Gecko/20110123 Firefox/4.0b10pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0b10pre) Gecko/20110123 Firefox/4.0b10pre

With browser.tabs.closeWindowWithLastTab set to false, closing the last tab twice breaks "Undo closed tab" feature.

Reproducible: Always

Steps to Reproduce:
1. Go to about:config and toggle browser.tabs.closeWindowWithLastTab to false.
2. Open a window with just 1 non-empty tab.
3. Click on "Close tab" button twice. Alternatively, press Ctrl+W twice. The tab will close.
4. Try and restore this closed tab (either by pressing Ctrl+Shift+T or from tab context menu).
Actual Results:  
"Undo closed tab" feature is broken. Unable to restore the last closed tab (and, consequently, any of tabs that were closed before).

Expected Results:  
Should be able to restore last tab, no matter how much times I clicked on "Close tab" button or pressed Ctrl+W.
Version: unspecified → Trunk
Confirming
Status: UNCONFIRMED → NEW
Ever confirmed: true
WFM. Did you try it on a clean profile?
Though, I have partially experience that problem.
If I click ctrl+w twice, then 2-nd time it closes an empty tab, so when I start undoing closed tabs - I get an empty tab restored first, and if I undo once again - the original tab gets restored. I think they might disallow closing an empty tab, if it's the only tab in the browser's window and if browser.tabs.closeWindowWithLastTab=false, ofc.
(In reply to comment #3)
> Though, I have partially experience that problem.
> If I click ctrl+w twice, then 2-nd time it closes an empty tab, so when I start
> undoing closed tabs - I get an empty tab restored first, and if I undo once
> again - the original tab gets restored. I think they might disallow closing an
> empty tab, if it's the only tab in the browser's window and if
> browser.tabs.closeWindowWithLastTab=false, ofc.

I think you're just seeing bug 581937
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 581937
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.