Closed Bug 628207 Opened 9 years ago Closed 9 years ago

Crash Report [@ gfxFontGroup::BuildFontList() ]

Categories

(Core :: Graphics, defect, critical)

x86
Windows 7
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 628152

People

(Reporter: cbook, Assigned: jtd)

Details

(Keywords: crash)

Crash Data

Trunk Crash (Firefox but also SeaMonkey and Thudnerbird) - http://crash-stats.mozilla.com/report/list?signature=gfxFontGroup::BuildFontList%28%29

only one comment so far, seems chinese/japanese or so

Windows only crash so far


Crashing Thread
Frame 	Module 	Signature [Expand] 	Source
0 	xul.dll 	gfxFontGroup::BuildFontList 	
1 	xul.dll 	gfxFontGroup::gfxFontGroup 	gfx/thebes/gfxFont.cpp:1970
2 	xul.dll 	gfxWindowsPlatform::CreateFontGroup 	gfx/thebes/gfxWindowsPlatform.cpp:535
3 	xul.dll 	nsThebesFontMetricsConstructor 	gfx/src/thebes/nsThebesGfxFactory.cpp:52
4 	xul.dll 	mozilla::GenericFactory::CreateInstance 	obj-firefox/xpcom/build/GenericFactory.cpp:48
5 	xul.dll 	nsRefPtr<nsIRunnable>::~nsRefPtr<nsIRunnable> 	obj-firefox/dist/include/nsAutoPtr.h:969
6 	xul.dll 	nsFontCache::GetMetricsFor 	gfx/src/thebes/nsThebesDeviceContext.cpp:181
7 	xul.dll 	nsCOMPtr_base::assign_from_gs_contractid 	obj-firefox/xpcom/build/nsCOMPtr.cpp:132
8 	xul.dll 	nsBlockReflowState::nsBlockReflowState 	layout/generic/nsBlockReflowState.cpp:147
9 	xul.dll 	nsRuleNode::WalkRuleTree 	layout/style/nsRuleNode.cpp:2050
looks like a bunch of duplicates between Jan 22, 2011 03:31  and 4:13 from same user on build 20110121153543  

otherwise this seems to be low volume.
Assignee: nobody → jdaggett
OS: Windows XP → Windows 7
Depends on: 628152
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 628152
No longer depends on: 628152
Crash Signature: [@ gfxFontGroup::BuildFontList() ]
You need to log in before you can comment on or make changes to this bug.