Last Comment Bug 628269 - Pages are zoomed in at reload
: Pages are zoomed in at reload
Status: REOPENED
:
Product: Fennec Graveyard
Classification: Graveyard
Component: General (show other bugs)
: Trunk
: ARM Android
: P2 normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-24 07:05 PST by Ioana Chiorean
Modified: 2011-10-25 06:16 PDT (History)
9 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Ioana Chiorean 2011-01-24 07:05:45 PST
Build Identifier:  Mozilla/5.0 (Android; Linux armv7l; en-US; rv:2.0b10pre)
Gecko/20110124 Firefox/4.0b10pre Fennec/4.0b4pre 
Device: HTC Desire A8181
OS: android 2.1

Steps to reproduce:
1. Open Fennec
2. Go to www.nypost.com, www.profm.ro, www.mozila.org
3. Press reload

Expected result:
- the page should remain the same scale

Actual result:
- the page is zoomed in 

Note:
- please see: http://www.youtube.com/watch?v=xGcP6bm4cww
Comment 1 Aakash Desai [:aakashd] 2011-01-31 09:08:52 PST
Yeah, I'm seeing this as well on the Vibrant.
Comment 2 Cristian Nicolae (:xti) 2011-03-15 06:36:27 PDT
The issue is still reproducing on:
Build id : Mozilla/5.0 (Maemo;Linux armv7l;rv:2.0b13pre)Gecko/201100315
Firefox/4.0b13pre Fennec /4.0b6pre
Device: Sony Ericsson Xperia X10
OS: Android 2.1 update 1
Comment 3 Anna (Waverley) 2011-03-17 09:44:37 PDT
Build Id: Mozilla /5.0 (Android;Linux armv7l;rv:2.0b13pre) Gecko/20110317 Firefox/4.0b13pre Fennec /4.0 (rc1)

Device: HTC Desire (Android 2.2)

I can still reproduce this issue, but only when using the mobile version of webpages: www.nypost.com, www.cancan.ro

Steps to reproduce:
1. Load www.nypost.com 
2. Press reload
3. Press reload

Actual: 
after step 2, the webpage is zoomed out.
after step 3, the webpage is zoomed in.

Expected:
the page should remain at the same scale
Comment 4 Mark Finkle (:mfinkle) (use needinfo?) 2011-03-17 10:29:32 PDT
I would expect everyone to be able to still see this bug. It has not been fixed. If it was fixed, we would set the status to RESOLVED:FIXED
Comment 5 Doug Turner (:dougt) 2011-03-17 10:41:46 PDT
Mark, I can reproduce this bug.
Comment 6 Aakash Desai [:aakashd] 2011-05-16 08:44:25 PDT
Mark, can we track this bug to a release somewhere? It's been failing our test suites for months now and its a common enough use case to warrant not being stuck in bugzilla for this long.
Comment 7 Mark Finkle (:mfinkle) (use needinfo?) 2011-05-16 10:40:25 PDT
I don't follow the reasoning for this bug. Do we want to remember the last zoom for every website you ever visit?
Comment 8 Ioana Chiorean 2011-05-17 00:22:59 PDT
Mark, I guess that the correct behavior is to leave the page at same zoom level. Cause now, at each reload it zooms in or out. (even for error pages) 

Here is a video of the problem: 
http://www.youtube.com/watch?v=2DvRU0s6-Zw
Comment 9 Ioana Chiorean 2011-05-19 01:52:43 PDT
Test case : https://litmus.mozilla.org/show_test.cgi?id=12294 fails due to this bug.
Comment 10 Ioana Chiorean 2011-05-20 08:16:53 PDT
and also http://litmus.mozilla.org/single_result.cgi?id=426935
Comment 11 Mark Finkle (:mfinkle) (use needinfo?) 2011-09-21 13:50:25 PDT
Is this still happening on Nightly?
Comment 12 Aaron Train [:aaronmt] 2011-09-21 13:57:37 PDT
This is fixed. Tested on Mozilla/5.0 (Android; Linux armv7l; rv:9.0a1) Gecko/20110921 Firefox/9.0a1 Fennec/9.0a1
Comment 13 Cristian Nicolae (:xti) 2011-10-25 06:16:50 PDT
This issue occurs on the latest Nightly build. Please see the following video: http://youtu.be/4kEHTe3Cb5g

--
Mozilla/5.0 (Android;Linux armv7l;rv:10.0a1)Gecko/20111025
Firefox/10.0a1 Fennec/10.0a1
Device: Motorola Droid 2
OS: Android 2.3.3

Note You need to log in before you can comment on or make changes to this bug.