Closed Bug 628328 Opened 10 years ago Closed 10 years ago

404s for people.mozilla.com urls

Categories

(Socorro :: General, task)

task
Not set
normal

Tracking

(Not tracked)

VERIFIED INVALID

People

(Reporter: jabba, Assigned: rhelmer)

References

Details

Kohana logs show lots of messaages like:

2011-01-24 10:50:50 -08:00 --- error: fopen(http://people.mozilla.com/crash_analysis/20110124/20110124_Camino_2.1a1-core-counts.txt): failed to open stream: HTTP request failed! HTTP/1.1 404 Not Found
2011-01-24 10:50:51 -08:00 --- error: gzopen(http://people.mozilla.com/crash_analysis/20110124/20110124_Camino_2.1a1-core-counts.txt.gz): failed to open stream: HTTP request failed! HTTP/1.1 404 Not Found
Should we be testing these via Selenium?
Flags: in-testsuite?
OS: Mac OS X → All
Hardware: x86 → All
If the error messages are only for Camino-related files, it's probably because the correlation reports aren't being run for us at all; before the holidays I intended to file a bug to have someone get them set up for us, but the holidays got in the way.
(In reply to comment #2)
> If the error messages are only for Camino-related files, it's probably because
> the correlation reports aren't being run for us at all; before the holidays I
> intended to file a bug to have someone get them set up for us, but the holidays
> got in the way.

I just filed bug 628341 about getting those reports enabled for Camino.
so, there was an accidental information disclosure on people a while back. the response to this was to move everyone's public_html directories to something else to force each user to carefully consider whether their public content was appropriate for public consumption...
(In reply to comment #4)
> response to this was to move everyone's public_html directories to something

http://people.mozilla.com/crash_analysis/ still contains files (and 20110124/ appears to contain today's files for Fx, Tb, and Sm).
Summary: 404s for people.mozilla.com urls → 404s for people.mozilla.com urls for Camino reports
Sorry, should have been more clear. It isn't just Camino URLs:

nd
2011-01-25 06:09:09 -08:00 --- error: fopen(http://people.mozilla.com/crash_analysis/20110125/20110125_Firefox_3.6.3-interesting-addons.txt): failed to open stream: HTTP request failed! HTTP/1.1 404 Not Found
2011-01-25 06:09:09 -08:00 --- error: gzopen(http://people.mozilla.com/crash_analysis/20110125/20110125_Firefox_3.6.3-interesting-addons.txt.gz): failed to open stream: HTTP request failed! HTTP/1.1 404 Not Found
2011-01-25 06:09:09 -08:00 --- error: fopen(http://people.mozilla.com/crash_analysis/20110125/20110125_Firefox_3.6.3-interesting-addons.txt): failed to open stream: HTTP request failed! HTTP/1.1 404 Not Found
2011-01-25 06:09:09 -08:00 --- error: gzopen(http://people.mozilla.com/crash_analysis/20110125/20110125_Firefox_3.6.3-interesting-addons.txt.gz): failed to open stream: HTTP request failed! HTTP/1.1 404 Not Found
2011-01-25 06:09:09 -08:00 --- error: fopen(http://people.mozilla.com/crash_analysis/20110125/20110125_Firefox_3.6.3-interesting-addons.txt): failed to open stream: HTTP request failed! HTTP/1.1 404 Not Found
2011-01-25 06:09:09 -08:00 --- error: gzopen(http://people.mozilla.com/crash_analysis/20110125/20110125_Firefox_3.6.3-interesting-addons.txt.gz): failed to open stream: HTTP request failed! HTTP/1.1 404 Not Found


I think I saw some Thunderbird ones in there too.
Summary: 404s for people.mozilla.com urls for Camino reports → 404s for people.mozilla.com urls
Duplicate of this bug: 613235
Target Milestone: --- → 1.7.7
Assignee: nobody → rhelmer
(In reply to comment #6)
> Sorry, should have been more clear. It isn't just Camino URLs:
> 
> gzopen(http://people.mozilla.com/crash_analysis/20110125/20110125_Firefox_3.6.3-interesting-addons.txt.gz):
> failed to open stream: HTTP request failed! HTTP/1.1 404 Not Found
> 

I've tracked down how this works. Most cron jobs are now public and included as part of the Socorro release, however the two responsible for the reports that get uploaded to people.m.o/crash_analysis/ are not (see bug 629029).

The problem here is that the product/version to generate the .txt and .txt.gz  reports is hard-coded into cron_libraries.sh (fixing for Camino in bug 628341), and the "*-pub-crashdata.csv.gz" reports is configured to generate only reports for Firefox.

The 404s in this bug are from requests to the web UI for product/version combos that are not in these scripts. I suggest that we :

1) close this bug
2) fix this for real in bug 629029
3) file bugs on missing products/versions in the meantime

#2 will make this use the Socorro config and database, so we could automatically generate these reports for any product/versions that are active in the branch data sources admin settings.
404s in product/versions that we don't generate reports for are expected.

Please file bugs if there are any products/versions that we should be getting reports for on people.m.o/crash_analysis/ but are not.

(In reply to comment #1)
> Should we be testing these via Selenium?

I would say yes, if you can tell which versions are "current"... I know this has been an issue with testing staging which might have different settings than production. 

We'll work on getting a staging version of this up in bug 629029, so let's follow-up there.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → INVALID
Component: Socorro → General
Product: Webtools → Socorro
Flags: in-testsuite?
Status: RESOLVED → VERIFIED
Flags: in-testsuite?
Flags: needinfo?
Flags: needinfo?
You need to log in before you can comment on or make changes to this bug.