Closed Bug 628366 Opened 10 years ago Closed 8 years ago

Scrolling the Get Add-ons page in about:addons is slow

Categories

(Toolkit :: Add-ons Manager, defect)

x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla15

People

(Reporter: smaug, Unassigned)

References

(Blocks 2 open bugs)

Details

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.5; rv:2.0b10pre) Gecko/20110124 Firefox/4.0b10pre

The page seems to be this https://services.addons.mozilla.org/en-US/firefox/discovery/pane/4.0b10pre/Darwin


Based on Shark profile
26.9% is taken by painting background (including 17.5% PaintGradient)
17.5% is taken by painting borders.
10.4% is taken by nsTextFrame::PaintOneShadow and things under it
7.8%  is taken by nsDisplayBoxShadowInner::Draw and things under it


(I'll file another bug for the usability issues.)
Summary: Scrolling the addon page is slow → Scrolling the addon page in about:addons is slow
If I load just https://services.addons.mozilla.org/en-US/firefox/discovery/pane/4.0b10pre/Darwin, scrolling is quite fast. So something in
about:addons triggers slow paths.
Bug 623615 is the same issue for the list view, any reason to think this would be something different?
I don't think so. AS given by comment 1 the problem is not in the discovery pane but only happens when content is presented in our pane with rounded corners.
this could be the same as bug 623615. Marking dependency
Depends on: 623615
When you put anything inside a rounded rect with overflow hidden it gets slow.
This should have gotten better.
Duplicate of this bug: 629017
Lets keep this bug for the Get Add-ons case.
Summary: Scrolling the addon page in about:addons is slow → Scrolling the Get Add-ons page in about:addons is slow
Blocks: slowui
Is this fixed now by bug 716439?
Thanks for the confirmation :)

-> FIXED via bug 716439
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla15
You need to log in before you can comment on or make changes to this bug.