Note: There are a few cases of duplicates in user autocompletion which are being worked on.

introduce webgl.force-enabled and webgl.disabled prefs

RESOLVED FIXED

Status

()

Core
Canvas: WebGL
RESOLVED FIXED
7 years ago
a year ago

People

(Reporter: bjacob, Assigned: bjacob)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

Created attachment 506524 [details] [diff] [review]
webgl force-enabled and disabled prefs

This replaces the old webgl.enabled_for_all_sites by a tri-state like we already do for layers and for d2d.

force-enabled bypasses the blacklist, allowing us to land bug 623338.

This patch also removed the old mochitest_native_gl pref that we no longer use.
Attachment #506524 - Flags: review?(vladimir)
(Assignee)

Comment 1

7 years ago
note: this patch makes the WebGL mochitest ignore the blacklist.
Comment on attachment 506524 [details] [diff] [review]
webgl force-enabled and disabled prefs

(fwiw, enabled_for_all_sites was intended to be part of a per-site permissions thing that we never implemented :)

While you're in this code, can you change prefer_gl to prefer-native-gl and add it to all.js?
Attachment #506524 - Flags: review?(vladimir) → review+
(Assignee)

Comment 3

7 years ago
Created attachment 506854 [details] [diff] [review]
prefer-native-gl pref
Attachment #506854 - Flags: review?(vladimir)
Comment on attachment 506854 [details] [diff] [review]
prefer-native-gl pref

great, thanks :)
Attachment #506854 - Flags: review?(vladimir) → review+
Attachment #506524 - Flags: approval2.0+
Attachment #506854 - Flags: approval2.0+
(Assignee)

Comment 5

7 years ago
http://hg.mozilla.org/mozilla-central/rev/828decbcc564
http://hg.mozilla.org/mozilla-central/rev/2a7ac4407669
Group: mozilla-confidential
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED

Updated

6 years ago
Group: mozilla-confidential

Updated

6 years ago
Assignee: nobody → bjacob
You need to log in before you can comment on or make changes to this bug.