Pressing ctrl key in Flash doesn't work as expected

VERIFIED FIXED

Status

()

VERIFIED FIXED
8 years ago
8 years ago

People

(Reporter: fryn, Assigned: mmm)

Tracking

({regression})

Trunk
x86
Mac OS X
regression
Points:
---

Firefox Tracking Flags

(blocking2.0 Macaw+, status2.0 .1-fixed)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
I just tried playing Wolfenstein 1-D at the above URL, but when i tried to shoot by pressing the ctrl key, my character instead moved to the left. :mmm and :dolske also experienced this. We all were using the a recent Minefield build on OS X.

I tested the game in Google Chrome on OS X, and the shoot command worked correctly as expected upon pressing the ctrl key. :mmm and i also tested this in Minefield on Windows, and it worked correctly.
(Reporter)

Comment 1

8 years ago
This is a regression from 3.6. (I just played Wolfenstein 1-D in Firefox 3.6 with the same Flash plugin, and it worked.)
Not sure if this is a regression from plugin focus fixes for OS X.
blocking2.0: --- → ?
Keywords: regression

Comment 2

8 years ago
Cocoa event handling? Not a blocker.
blocking2.0: ? → .x

Comment 3

8 years ago
dupe of bug 616177 ?
> dupe of bug 616177 ?

Possibly.  I'll need to dig further into both bugs.
Created attachment 522444 [details] [diff] [review]
Always set keyCode.

Instead of setting keyCode if the event is either NSKeyDown or NSKeyUp, this patch also sets the keyCode if the event is a NSFlagsChanged.

Tested this in a build and it seemed to work, the Mac documentation states that this "Raises an NSInternalInconsistencyException if sent to a non-key event." so this seems safe.
Assignee: nobody → mars.martian+bugmail
Status: NEW → ASSIGNED
Attachment #522444 - Flags: review?
Attachment #522444 - Flags: review? → review?(joshmoz)

Comment 6

8 years ago
Comment on attachment 522444 [details] [diff] [review]
Always set keyCode.

Looks good, thanks!
Attachment #522444 - Flags: review?(joshmoz) → review+
http://hg.mozilla.org/mozilla-central/rev/f3c2eea82430
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED

Updated

8 years ago
Duplicate of this bug: 616177
(Reporter)

Comment 9

8 years ago
mehdi++!

Would we want to push this to 4.x too?

Comment 10

8 years ago
Yes, we want this for Firefox 4 as soon as possible.
Comment on attachment 522444 [details] [diff] [review]
Always set keyCode.

This is pretty low risk, only affects Mac users and slightly changes how key events are handled with plugins.
Attachment #522444 - Flags: approval2.0?
blocking2.0: .x+ → Macaw
Comment on attachment 522444 [details] [diff] [review]
Always set keyCode.

Approved for mozilla2.0 repository, a=dveditz for release-drivers
Attachment #522444 - Flags: approval2.0? → approval2.0+

Comment 14

8 years ago
WFM on 
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.2a1pre) Gecko/20110404 Firefox/4.2a1pre
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.