Closed Bug 628626 Opened 9 years ago Closed 8 years ago

Doorhanger is misplaced when canceling an installation in the add-ons manager

Categories

(Toolkit :: Add-ons Manager, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
mozilla10

People

(Reporter: srinivas, Assigned: enndeakin)

References

Details

(Whiteboard: [qa!][4b11][doorhanger])

Attachments

(4 files)

User-Agent:       Mozilla/5.0 (Windows NT 6.0; rv:2.0b10pre) Gecko/20110124 Firefox/4.0b10pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0b10pre) Gecko/20110124 Firefox/4.0b10pre

Doorhanger is not displayed properly after canceling the install of an add-on via add-on manager

Reproducible: Always

Steps to Reproduce:
1.Open Fx, goto Add-on Manager
2.Click on any add-on in Top Add-ons(Add-on Manager->Get Add-ons->Top Add-ons) - Add-on detail page loads
3.Click "Add to Firefox" in Add-on Detail page - Doorhanger will be dispalyed with Add-on download
4.Now click stop in the Doorhanger
Attached image Doorhanger
Whiteboard: [4b11]
Confirmed in new profile on Win7
Status: UNCONFIRMED → NEW
Component: General → Add-ons Manager
Ever confirmed: true
Product: Firefox → Toolkit
Version: unspecified → Trunk
QA Contact: general → add-ons.manager
Depends on: 617553
Interesting. Happens for any remote installation of add-ons in the add-ons manager. Also visible on OS X.
OS: Windows 7 → All
Hardware: x86 → All
Summary: Doorhanger is not displayed properly → Doorhanger is misplaced when canceling an installation in the add-ons manager
It looks like the panel opens in the same place, but the arrow is on the wrong side. This may be an issue with arrow panel arrow positioning, not the popup notifications. We're opening the panel with this.panel.openPopup(anchorElement, "bottomcenter topleft") (http://mxr.mozilla.org/mozilla-central/source/toolkit/content/PopupNotifications.jsm#449), but the arrow is appearing on the top right.

Enn, do you have any ideas what might cause this to happen?
I didn't see this problem when I tested it. Is this a specific platform?

The patches in bugs 524545, 628238 and 629002 might help here.
Whiteboard: [4b11] → [4b11][doorhanger]
I can reproduce the bug following the steps in the description:

1. On a clean profile launch Firefox and open Addons manager.
2. Maximize browser window.
3. In the "GetAddons" -> "Top Addons" section click on an Addon (example: "Adblock Plus")
4. In the Addon's page click on the "Add to Firefox" button
5. When the Doorhanger appears, click on the blue circle with an "x" next to the bar (not the simple "x" in the top right corner).

* OS: Windows 7
  build: Mozilla/5.0 (Windows NT 6.1; rv:2.0b12pre) Gecko/20110207 Firefox/4.0b12pre

** Note: IMO it's something related to the empty space in the tab bar. 
   Example: for me if the browser window is maximized and 5 or more tabs are opened the doorhanger displays correctly.
I can reproduce the behavior which is like this bug, following step,
0. Set preference, "devtools.chrome.enabled" is "true".
1. Open ScratchPad and Environment->Browser is enable.
2. Paste following code to ScratchPad and Run it.
/**/
PopupNotifications.show(
  gBrowser.selectedBrowser,
  "test",
  "test",
  "default-notification-icon",
  { label:"ok", accessKey:"o", callback:function(){} },
  null,
  null
);
/**/
**Note: I can reproduce this behavior on:
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:9.0a1) Gecko/20110920 Firefox/9.0a1

I thought this bug is caused by bug 634391.
Attached patch patchSplinter Review
Looks to be caused by what I described in https://bugzilla.mozilla.org/show_bug.cgi?id=626605#c5

Mounir, do you remember why you added these checks?
Assignee: nobody → enndeakin
Status: NEW → ASSIGNED
Attachment #561738 - Flags: feedback?(mounir)
Attached patch patch with testSplinter Review
Comment on attachment 561738 [details] [diff] [review]
patch

Review of attachment 561738 [details] [diff] [review]:
-----------------------------------------------------------------

I have to say I do not remember and I'm not able to understand it either.
Let's remove it then.
Attachment #561738 - Flags: feedback?(mounir) → feedback+
Attachment #561779 - Flags: review?(neil)
Attachment #561779 - Flags: review?(neil) → review+
Flags: in-testsuite+
https://hg.mozilla.org/mozilla-central/rev/51f9e410d66f
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla10
Setting resolution to Verified Fixed on:

Mozilla/5.0 (Windows NT 6.1; rv:10.0a1) Gecko/20111011 Firefox/10.0a1
Mozilla/5.0 (Windows NT 5.1; rv:10.0a1) Gecko/20111011 Firefox/10.0a1
Mozilla/5.0 (X11; Linux i686; rv:10.0a1) Gecko/20111012 Firefox/10.0a1
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:10.0a1) Gecko/20111011 Firefox/10.0a1

I have followed the STR from comment7 and the issue is fixed on latest Nightly.
Status: RESOLVED → VERIFIED
Whiteboard: [4b11][doorhanger] → [qa!][4b11][doorhanger]
Neil, does the automated test has a good enough coverage, or do we need a manual test here?
Flags: in-litmus?
I changed the automated test to check for the specific issue caused by this bug.

However, the test doesn't test the addons manager specifically just the underlying problem. I found the addons manager issue difficult to reproduce so a manual test might not be feasible, but probably isn't necessary anyway.
You need to log in before you can comment on or make changes to this bug.