Last Comment Bug 628649 - nsCoreUtils::IsXLink looks either incorrect or obsolete
: nsCoreUtils::IsXLink looks either incorrect or obsolete
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Disability Access APIs (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla19
Assigned To: alexander :surkov
:
:
Mentors:
Depends on:
Blocks: cleana11y
  Show dependency treegraph
 
Reported: 2011-01-25 06:51 PST by Henri Sivonen (:hsivonen) (Not reading bugmail or doing reviews until 2016-10-03)
Modified: 2012-11-10 14:02 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (6.58 KB, patch)
2012-11-07 21:30 PST, alexander :surkov
tbsaunde+mozbugs: review+
Details | Diff | Splinter Review

Description Henri Sivonen (:hsivonen) (Not reading bugmail or doing reviews until 2016-10-03) 2011-01-25 06:51:09 PST
The method nsCoreUtils::IsXLink seems to treat an element as an XLink link only if xlink:type="simple" is present. If this code is for the old generic XLink support, the code is obsolete, because generic XLink support is gone. If this code is for SVG, it is incorrect, because SVG doesn't require xlink:type.
Comment 1 alexander :surkov 2011-01-25 07:11:15 PST
It is about XLink only. We use accessible of generic type for SVG, though we should be more diverse.
Comment 2 alexander :surkov 2012-11-07 20:56:52 PST
let's make sure to address xlink stuff for svg in bug 809744 and remove nsCoreUtils::IsXLink for now.
Comment 3 alexander :surkov 2012-11-07 21:30:23 PST
Created attachment 679541 [details] [diff] [review]
patch
Comment 5 Ryan VanderMeulen [:RyanVM] 2012-11-10 14:02:45 PST
https://hg.mozilla.org/mozilla-central/rev/4586e6f3c550

Note You need to log in before you can comment on or make changes to this bug.