Closed Bug 628807 Opened 12 years ago Closed 12 years ago

Firefox button split menu sub-menus disappear immediately on mouse out of the main command, if you touch another split menu

Categories

(Firefox :: Menus, defect)

x86
Windows 7
defect
Not set
normal

Tracking

()

VERIFIED FIXED
Firefox 4.0b11
Tracking Status
blocking2.0 --- betaN+

People

(Reporter: faaborg, Assigned: dao)

References

(Depends on 1 open bug)

Details

(Whiteboard: [softblocker][fx4-fixed-bugday])

Attachments

(2 files)

The attached mockup will show this more clearly, but the problem is that sometimes (but not always) the sub-menus displays when hovering the main command disappear immediately on mouse out of the main command.  This makes it impossible to access any of the items inside of the sub-menu, unless you very carefully house horizontally staying inside of the bounds of the main command and over to the expansion arrow.

Expected results: consistently using a timer to dismiss the sub-menu, similar to native sub-menus on windows (and our current XUL implementation of sub-menus)

Even better expected results: using a, invisible triangle similar to native OS X menus :) (but yeah, that's a lot of work).
Nomintating for blocking since it is obviously kind of frustrating to try to target something and have the target immeiately disapear as you move towards it.

I seem to be able to recreate the issue with the options menu more than the history menu (despite the mockup), and I believe (but am not entirely sure) that when it is in the broken state the hover effect for the main control is show, but the hover effect for the expansion arrow is not shown, but that might be a totally independent issue.
blocking2.0: --- → ?
>I seem to be able to recreate the issue with the options menu more than the
>history menu (despite the mockup)

should read "more than the help menu," I believe because help is last and the issue is related to hovering into the next menu item below.
From irc discussion with margaret: we figured out that the bug seems to happen when you move from one split menu to another.  So new tab, print, and help are unaffected since their placement makes it less likely/impossible to hit another split menu when you move out of them.
History also works as long as you don't hit Add-ons on your way over.
Summary: Firefox button sub-menus sometimes disappear immediately on mouse out of the main command → Firefox button split menu sub-menus disappear immediately on mouse out of the main command, if you touch another split menu
Attached patch patchSplinter Review
Assignee: nobody → dao
Status: NEW → ASSIGNED
Attachment #507083 - Flags: review?(gavin.sharp)
Attachment #507083 - Flags: review?(gavin.sharp)
Attachment #507083 - Flags: review+
Attachment #507083 - Flags: approval2.0+
Keywords: checkin-needed
http://hg.mozilla.org/mozilla-central/rev/1b475db72be2
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 4.0b11
blocking2.0: ? → betaN+
Whiteboard: [softblocker]
Can we make the delay also happen when mousing between split menu entries and regular menu entries?

For example, hover over Options and wait for the submenu to appear. Then quickly mouse over to addons and then back over to Options before the submenu disappears. You'll see that even though there's a delay before the Options submenu closes, you can't make it stay open. The delay in this case is rendered useless and gives users the false impression that they have a short period of time to return to the submenu after accidentally mousing over something else.
(In reply to comment #7)
> Can we make the delay also happen when mousing between split menu entries and
> regular menu entries?
> 
> For example, hover over Options and wait for the submenu to appear. Then
> quickly mouse over to addons and then back over to Options before the submenu
> disappears. 

I think this is a valid bug which should be filed, separate from this bug report.  Can you file it, Benjamin?
Status: RESOLVED → VERIFIED
Whiteboard: [softblocker] → [softblocker][fx4-fixed-bugday]
(In reply to comment #8)
> I think this is a valid bug which should be filed, separate from this bug
> report.  Can you file it, Benjamin?

Filed bug 631715
You need to log in before you can comment on or make changes to this bug.