can't sign up for a Windows Live account using fx4

RESOLVED WORKSFORME

Status

()

Core
JavaScript Engine
RESOLVED WORKSFORME
7 years ago
2 years ago

People

(Reporter: juanb, Unassigned)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(blocking2.0 final+)

Details

(Whiteboard: [Input][hardblocker])

(Reporter)

Description

7 years ago
While testing the latest Fx4beta (beta 10), I noticed that you can't sign up for for a Windows Live account. When you miss a field (on purpose) and submit the form, you get none of the fields pre-filled, but even if you fill out all the fields correctly and submit the form, the page comes back empty. There are lots of errors in the console about undefined variables.

Using Chrome I don't see this problem. When you miss a field you get prompted to enter something, and when you enter all the fields correctly, your account sign-up goes through.

I didn't try UA spoofing to see if it has anything to do with it.

Comment 1

7 years ago
I believe this is a pretty serious regression for FF4. It works in 3.6
blocking2.0: --- → ?

Comment 2

7 years ago
It appears to have occurred between beta6 and beta7 as beta6 seems to work.
Yep, people are mentioning it on Input as well around the Beta 9 timeframe
(1/14/2011):

http://input.mozilla.com/en-US/beta/search?product=firefox&q=hotmail+login
Whiteboard: [Input]

Comment 4

7 years ago
Have raised it with Dharmesh at Microsoft.
Error: SignUp.HIPControl is undefined
Source File: https://signup.live.com/signup.aspx?id=64855&mkt=en-US&form=MWGELB&publ=SIGNINHM&crea=SITEACQ_CIMS015888_Hotmail_EN-US_0x0_36214&lic=1
Line: 41

Error: SignUp.HIPControl is undefined
Source File: https://signup.live.com/signup.aspx?id=64855&mkt=en-US&form=MWGELB&publ=SIGNINHM&crea=SITEACQ_CIMS015888_Hotmail_EN-US_0x0_36214&lic=1
Line: 41

Looks like an error in their JS, for now moving this over to Core::JavaScript but I suspect that it will end up in Tech Evang.
Assignee: nobody → general
blocking2.0: ? → final+
Component: General → JavaScript Engine
Product: Firefox → Core
QA Contact: general → general
Whiteboard: [Input] → [Input][hardblocker]
What's the regression window here?
Keywords: regressionwindow-wanted
(In reply to comment #0)
> While testing the latest Fx4beta (beta 10), I noticed that you can't sign up
> for for a Windows Live account. When you miss a field (on purpose) and submit
> the form, you get none of the fields pre-filled, but even if you fill out all
> the fields correctly and submit the form, the page comes back empty. There are
> lots of errors in the console about undefined variables.

I tried this part, specifically:

1. Load https://signup.live.com/signup.aspx?id=64855&mkt=en-US&form=MWGELB&publ=SIGNINHM&crea=SITEACQ_CIMS015888_Hotmail_EN-US_0x0_36214&lic=1
2. Enter "foo" for First name.
3. Enter "bar" for Last name.
4. Click "I accept"

and it worked. Specifically, I got back the same page, with First name and Last name filled in, and no JS errors in the console. This was with a current TM nightly. Would you mind retrying on that, and maybe an m-c nightly as well? I suspect this has been fixed in TM.
(Reporter)

Comment 8

7 years ago
It works on Minefield builds from the 10/10 but not 10/11:

http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=26c47ba8064f&tochange=5a41a70eb631

I'll try the latest TM builds now.
(Reporter)

Comment 9

7 years ago
This is on the latest TM builds: In one try I entered all of the fields except, the date of birth, and submitted the form, the form came back empty.

When I tried entering all fields it seemed to go through, except that I ran out of registration attempts for today, according to the site, so I was not able to go through the whole process and check that it did in fact register me.

Then I tried not entering other missing fields, including retrying with only the date of birth missing, and submitting, but I was not able to reproduce the problem. The form is refreshed with "required information missing" next to the fields.

Ideally I would be able to try all with all fields, and registering an account, but like I said, I ran out of tries for today.
I signed up for an account using Build identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b11pre) Gecko/20110126 Firefox/4.0b11pre.
It worked fine.
The errors from comment 5 came after filling out all fields, fwiw. Looks like we have a regression range in comment 8.

Juan: does it work if you disable JIT in content?
(Reporter)

Comment 12

7 years ago
Today I checked again on the latest nightly, the TM with and without JIT in content, and back to the builds around the regression range, and I am not able to reproduce the problem. If the page isn't fully filled out I get the "required information missing" errors in the page, and no errors in the console like I was getting yesterday.

I also tried the beta 10 builds and everything went through, no errors in the console.

I think this is a WFM now. Maybe it was the gremlins.
OK. Thanks for rechecking.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
Keywords: regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.