Recursive "#sessionData" saving can result in enormous sessionstore.js

VERIFIED DUPLICATE of bug 467409

Status

()

Firefox
Session Restore
VERIFIED DUPLICATE of bug 467409
8 years ago
8 years ago

People

(Reporter: pcwalton, Unassigned)

Tracking

({perf})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
In my testing profile (in which I usually quit the browser with Ctrl+C), I have a 130 MB sessionstore.js due to huge amounts of nested "#sessionData". That is, I have "#sessionData": "{ ... \"sessionData\": \"{ ... \\\"sessionData\\\": ... }\" ... }" This causes terrible startup performance.
Yea, it's pretty atrocious.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 467409
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.