Flash video control bar is repainted wrongly when toggle maximizing/restoring normal mode of Browser on youtube[Windows7 Aero]

RESOLVED WORKSFORME

Status

()

Core
Widget: Win32
RESOLVED WORKSFORME
7 years ago
2 years ago

People

(Reporter: Alice0775 White, Unassigned)

Tracking

({regression})

Trunk
x86
Windows 7
regression
Points:
---

Firefox Tracking Flags

(blocking2.0 -)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Created attachment 507028 [details]
screenshot

Build Identifier:
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b10pre) Gecko/20110125 Firefox/4.0b10pre ID:20110125030335

Flash video control bar is repainted wrongly when toggle maximizing/restoring normal mode of Browser on youtube.
This happens on Windows7 Aero only.

Reproducible: Always

Steps to Reproduce:
1. Start Minefield with new profile
2. Open ( http://www.youtube.com/watch?v=23KlT-MCD-4&feature=channel )
3. Maximizing browser (F11)
3. Restoring normal mode browser (F11)

Actual Results:
 Flash video control bar is repainted wrongly.

Expected Results:
 Repainted properly

Regression window(cached jourly);
Works:
http://hg.mozilla.org/mozilla-central/rev/c1d00ecc8f98
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101008 Firefox/4.0b8pre ID:20101008123425
Fails:
http://hg.mozilla.org/mozilla-central/rev/3246002bd040
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101007 Firefox/4.0b8pre ID:20101008125135
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=c1d00ecc8f98&tochange=3246002bd040
Candidate:
966b58fd08ed	Timothy Nikkel — Bug 601547. Dispatch starved paints on the top level window too, not just child windows. r=jimm a=blocking-betaN+


Shockwave Flash
    File: NPSWF32.dll
    Version: 10.1.102.64
    Shockwave Flash 10.1 r102

Graphics
    Adapter Description: ATI Radeon HD 4300/4500 Series
    Vendor ID: 1002
    Device ID: 954f
    Adapter RAM: 512
    Adapter Drivers: aticfx64 aticfx64 aticfx32 aticfx32 atiumd64 atidxx64 atiumdag atidxx32 atiumdva atiumd6a atitmm64
    Driver Version: 8.801.0.0
    Driver Date: 
    Direct2D Enabled: true
    DirectWrite Enabled: true
    WebGL Renderer: TransGaming Inc. -- ANGLE -- OpenGL ES 2.0 (git-devel Jan 13 2011 03:37:36)
    GPU Accelerated Windows: 1/1 Direct3D 10
(Reporter)

Updated

7 years ago
blocking2.0: --- → ?
Does bug 627628 have any effect here?
(Reporter)

Comment 2

7 years ago
(In reply to comment #1)
> Does bug 627628 have any effect here?

Not fixed completely.
However, The frequency seems to have decreased.

http://hg.mozilla.org/mozilla-central/rev/273cb783edac
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b10pre) Gecko/20110125 Firefox/4.0b10pre ID:20110125105431
Assignee: nobody → tnikkel
blocking2.0: ? → -
Assignee: tnikkel → nobody
20160502172042 Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:46.0) Gecko/20100101 Firefox/46.0
20160516030211 Mozilla/5.0 (Windows NT 6.1; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0

I could not reproduce the issue on Windows 7 on the latest Firefox 46 RC and on the latest Nightly 49.0a1.
Setting the status to RESOLVED WORKSFORME.
If anyone can still reproduce it, feel free to reopen the issue and provide more information.
Thanks.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.