Don't load xul.css when xul is disallowed

RESOLVED DUPLICATE of bug 1008455

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 1008455
7 years ago
4 years ago

People

(Reporter: mano, Assigned: mano)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Bug 610682 comment 67 suggests that we still load xul.css for content documents.
The blocking request might be considered spam if it isn't as easy as I imagine...
blocking2.0: --- → ?
Testcase by gavin: data:text/html,<span class="accesskey">f</span>
Don't content documents depend on some of those styles?
Not that I know of, not that I know much, maybe the xbl rules? In any case, couldn't we move these to html.css?
> Not that I know of

Scrollbars.  And the styles for the videocontrols and such, right?

And yes, we could move those to html.css, maybe.  We just have to be careful about regressions.

And then we'd have to have the machinery to load it on-demand a la MathML or something, right?

Could be worth doing; not sure it's worth trying to do for 2.0.
Indeed.
blocking2.0: ? → ---
Assignee: nobody → mano
The rule attaching the binding is.  The binding's anonymous content contains XUL elements that rely on rules and bindings attached via xul.css for proper functioning, last I checked.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1008455
You need to log in before you can comment on or make changes to this bug.