bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Bugzilla admin should be able to disable platform/os

RESOLVED DUPLICATE of bug 449161

Status

()

Bugzilla
Administration
P3
normal
RESOLVED DUPLICATE of bug 449161
18 years ago
6 years ago

People

(Reporter: John Bafford, Assigned: justdave)

Tracking

Details

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
The Bugzilla admin should be able to disable the platform and OS fields if they 
are not required. For example, my bugzilla installaton is for a web-based 
application, so platform and OS are really not useful.
Since I'm feeling slightly insane at the moment, I'll volunteer to do this.
(Reporter)

Comment 1

18 years ago
Created attachment 20759 [details] [diff] [review]
Proposed patch to implement this.
(Reporter)

Comment 2

18 years ago
Created attachment 20761 [details] [diff] [review]
Ignore the last patch, please. I'm a moron. I copied too much HTML...
Keywords: patch, review
Target Milestone: --- → Bugzilla 2.16
I think it'd be better to do this in conjunction with moving these into the
database.
Moving to new Bugzilla product ...
Assignee: mozilla → justdave
Component: Bugzilla → Administration
Product: Webtools → Bugzilla
Version: other → 2.13
The easiest thing to do is edit the templates for enter_bug, show_bug etc. so
they don't show up, isn't it?

Gerv
Err, no.  Platforms and OSs aren't stored in templates, nor is it appropriate to
do so.
I know they are not stored in templates :-) My point is that, if the UI never
presents the fields, they might as well not be there.

"Remove it from the templates" is a scalable solution to "My Bugzilla doesn't
need field X". A not-scalable solution is implementing a pref for every field.

Gerv
But it's an incomplete solution.  Part of disabling a field might involve
editing a template, but I'd rather see alternatives.

For example, we could pass a list of fields to a template along with their types
and the template would worry about how to lay them out.  TT can do this.

Ignore my 2001-07-23 04:03 comment as I misinterpreted what this report was
about.
> For example, we could pass a list of fields to a template along with their types
> and the template would worry about how to lay them out.  TT can do this.

That's what we currently do. We're passing a bunch of fields, and the template
can decide not to lay out Platform and OS at all :-)

Gerv
We are currently trying to wrap up Bugzilla 2.16.  We are now close enough to
release time that anything that wasn't already ranked at P1 isn't going to make
the cut.  Thus this is being retargetted at 2.18.  If you strongly disagree with
this retargetting, please comment, however, be aware that we only have about 2
weeks left to review and test anything at this point, and we intend to devote
this time to the remaining bugs that were designated as release blockers.
Target Milestone: Bugzilla 2.16 → Bugzilla 2.18

Comment 11

16 years ago
Comment on attachment 20761 [details] [diff] [review]
Ignore the last patch, please. I'm a moron. I copied too much HTML...

Needs template-whacking anyway. But while Gerv's solution is imperfect, I think
it's sufficient. While we do have usemilestone and useqacontact already, it
still doesn't sound too good to add a useXXX param for every field that someone
might not want.

We do need a better solution for this someday, though - platform/os fields'
availability should be per product. But that's another bug... For the moment,
I'd go for WORKSFORME based on the possibility to do a trivial template edit.
Attachment #20761 - Flags: review-
The correct fix for this is custom fields; then, Platform and OS will just be
two default custom fields. In the mean time, the ease of template hackery means
that this bug is a WORKSFORME as outlined.

Gerv
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
clearing target in DUPLICATE/WORKSFORME/INVALID/WONTFIX bugs so they'll show up
as untriaged if they get reopened.
Target Milestone: Bugzilla 2.18 → ---

Comment 14

10 years ago
No reason to mark this bug as WFM. Having to edit templates is in no way a good solution. Anyway, this will be addressed by bug 449161.
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 449161
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.