Firefox displays wrong colors on image (only Linux)

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
8 years ago
7 years ago

People

(Reporter: jakub, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; cs-CZ; rv:1.9.2.13) Gecko/20101206 Ubuntu/10.10 (maverick) Firefox/3.6.13
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; cs-CZ; rv:1.9.2.13) Gecko/20101206 Ubuntu/10.10 (maverick) Firefox/3.6.13

If you open address http://www.chabek.cz/images/bg.jpg in Firefox on linux and in another browser, you will see hufe diference - it should be blue, but it's almost purple! Tryied that on multiple PC's and multiple OS's (Win - OK, Ubuntu 10.10 - wrong, Arch - wrong)

Reproducible: Always

Steps to Reproduce:
1.open url with image http://www.chabek.cz/images/bg.jpg
Actual Results:  
Wrong colors - purple

Expected Results:  
Right colors - blue
Please open about:config, confirm the warning and change gfx.color_management.mode from 2 to 0.

Does it fix your problem ?
You have a wrong color profile on your linux system in that case
(Reporter)

Comment 2

8 years ago
Hello, thank you for your suggestion. It was right - this solves the problem. Thank you and sorry for reporting as bug. But I think that it should be set as default.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Your color profile on linux is just broken.
The color correction works without problems.

marking wfm
Resolution: FIXED → WORKSFORME
(Reporter)

Comment 4

8 years ago
I think that it doesn't works without problems - it was fresh (and correct) install of Ubuntu 10.10, nothing else ... so the color profile was broken "from installation".

Comment 5

8 years ago
I do not understand how is this issue resolved when it happens to people on vanilla installations, it was happening for me too. The fix mentioned worked but it took a long time and a lot of effort to find out what's wrong ... regular users are just lost and stuck with this bug, Chrome works without problems so it clearly is a problem with Firefox ...
igilama.register@gmail.com: Please do not post in several different bugs about the same issue. Bugzilla is not for support.
Firefox is the only major browser that is doing color correction and a statement that "it works in chrome" doesn't matter. And it seems that wither your xserver/graphic driver or color profile is broken out of the box.

Comment 7

8 years ago
If it is the same issue then it should be marked as a duplicate, apparently people commenting on the other bug were not aware of the "fix" suggested here so I think it is reasonable to add it there when people stumble upon that bug report as I did - some may appreciate the workaround, as I would ;)

So it's the classic "it's not a bug, it's a feature!" kind of thing then? When it cannot do it properly maybe it shouldn't do it at all ... the fact is that it's broken and that "Firefox is the only major browser that is doing color correction" doesn't matter, it simply doesn't work as intended.

Maybe it would be a good idea to set gfx.color_management.mode to 0 by default for Linux users? That would be the easiest fix. The proper way would be to find out why does it happen and possibly communicate with the K/Ubuntu guys to fix it if the problem is on their side ... but I understand that may be too much work.

But just ignoring it and keep it broken for a lot of people and proclaim it "resolved" is not a proper way to handle it I would think.

Thanks
>If it is the same issue then it should be marked as a duplicate
Your issue is a single issue. The bug reports could be caused by different underlying bugs. 
I can't tell you the exact reason for each bug.

>When it cannot do it properly maybe it shouldn't do it at all
Firefox can do it properly but not your system as it seems.

>it simply doesn't work as intended.
That doesn't mean that it's a bug in Gecko and we track only bugs for the mozilla code.

>But just ignoring it and keep it broken for a lot of people and proclaim it 
>"resolved" is not a proper way to handle it I would think.

I think you don't understand bugzilla. If you report something like "Firefox is doing the color correction wrong" and Firefox isn't doing something wrong then the bug is invalid/wfm. In this case the reporter set the status and I only corrected it.

>Maybe it would be a good idea to set gfx.color_management.mode to 0 by default for 
>Linux users?

Please create a new bug report for this request  Be aware that it doesn't have to be a widespread problem if you and a few others get a problem and it might be rejected.

Comment 9

8 years ago
Thanks, I'll create the suggested bug report.

Just a sidenote: maybe I misunderstood the purpose of bugzilla but the fact that Firefox acts broken on the same system where other browsers function properly is a problem of Firefox. It is perhaps important to understand that I stayed with Firefox only out of loyalty to the philosophy of Mozilla.

This bug has been annoying me for MONTHS, the point where I decided to file a bug was when I got annoyed enough to go like "That's it! This bug must go or Firefox goes." It took hours of searching for what may be the problem ... this is extremely unusual generally for your average user. It would took something like 5 minutes to switch to Chrome and be done with it, that's what all those people you do not see filling bugs have probably done.

So you may be right that it's not strictly a problem of Gecko codebase or that my "xserver/graphic driver or color profile is broken out of the box" ... there may be all kinds of reasons to avoid spending any time on it, legitimate or not, but at the end of the day ... Firefox is the loser. 99.99% of people are not going to spend hours searching, filling bugs and tinkering with advanced settings, they won't care "why" it's broken, they simply switch to a browser that works. And for this reason this is certainly a bug in Firefox in my eyes and in the eyes of every user that experienced it.

For every user that reports the issue there are thousands who didn't bother and simply ditched FF considering it broken (and telling their friends). For that reason I would perhaps expect a little more engagement from Mozilla devs, especially when the fix/workaround is so trivial. But then ... Mozilla is non-profit and a lot of the dev are probably volunteers so there are no obligations, many would say that "I'm getting what I'm paying for" and maybe they're right ... going to make that bug report now
Bugzilla is a tool for our developers to manage their work.
When you report a bug about the color correction and it is not a bug in our code then the bug report is invalid. That doesn't solve your problem but bugzilla isn't there to solve user problems. We have the support for that (http://support.mozilla.com).
Creating a new bug (in Core:GFX Color management) to disable the color correction on linux is the only way to get your problem getting fixed for all users that are affected by this problem. It seems that the linux graphic driver problem is just too bad. We had nearly no reports from windows or mac users....

Comment 11

8 years ago
That request was filed as bug 694553, but bug 655637 seems the same.

Comment 12

7 years ago
I am having the same problem however the proposed workaround is not working. The colours are still incorrect even though I've changed gfx.color_management.mode to 0.

I am using Firefox 8.0 on Ubuntu 11.04
You need to log in before you can comment on or make changes to this bug.