Closed Bug 629430 Opened 11 years ago Closed 9 years ago

intermittent failure: file:///c:/talos-slave/test/build/reftest/tests/modules/plugin/test/reftest/border-padding-1.html and/or border-padding-2.html and/or border-padding-3.html | image comparison (==)

Categories

(Core :: Plug-ins, defect)

x86
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: bjacob, Unassigned)

References

()

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

Blocks: 438871
Whiteboard: [orange]
Version: unspecified → Trunk
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1296235171.1296237957.6271.gz
Rev3 WINNT 6.1 mozilla-central opt test reftest on 2011/01/28 09:19:31
s: talos-r3-w7-016
REFTEST TEST-UNEXPECTED-FAIL | file:///c:/talos-slave/test/build/reftest/tests/modules/plugin/test/reftest/border-padding-2.html | image comparison (==)
Summary: intermittent failure: file:///c:/talos-slave/test/build/reftest/tests/modules/plugin/test/reftest/border-padding-2.html | image comparison (==) → intermittent failure: file:///c:/talos-slave/test/build/reftest/tests/modules/plugin/test/reftest/border-padding-1.html and/or border-padding-2.html | image comparison (==)
The only reason -3 wasn't failing is that it was commented out.

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1296942557.1296946159.10775.gz
Rev3 WINNT 6.1 mozilla-central debug test reftest on 2011/02/05 13:49:17
s: talos-r3-w7-007

REFTEST TEST-UNEXPECTED-FAIL | file:///c:/talos-slave/test/build/reftest/tests/modules/plugin/test/reftest/border-padding-3.html | image comparison (==)
Summary: intermittent failure: file:///c:/talos-slave/test/build/reftest/tests/modules/plugin/test/reftest/border-padding-1.html and/or border-padding-2.html | image comparison (==) → intermittent failure: file:///c:/talos-slave/test/build/reftest/tests/modules/plugin/test/reftest/border-padding-1.html and/or border-padding-2.html and/or border-padding-3.html | image comparison (==)
Attached file reftest logs
These aren't very exciting, since just like bug 631832, the difference is that following the Win7 driver update, it's random whether or not the plugin in the test will have rendered by the time we take the snapshot.
And just like bug 631832, annotated as random-if(win7) in http://hg.mozilla.org/mozilla-central/rev/5bf94fcd5115.
I don't have any ideas about why this is happening, but should note that I also marked a few tests as random-if that I added in bug 626602, for the same reason, no plugin rendering in the snapshots.  One long-shot candidate for fixing this is bug 631388, but I seriously doubt that.
My latest patch for bug 90268 makes this happen every time.
Mass marking whiteboard:[orange] bugs WFM (to clean up TBPL bug suggestions) that:
* Haven't changed in > 6months
* Whose whiteboard contains none of the strings: {disabled,marked,random,fuzzy,todo,fails,failing,annotated,leave open,time-bomb}
* Passed a (quick) manual inspection of bug summary/whiteboard to ensure they weren't a false positive.

I've also gone through and searched for cases where the whiteboard wasn't labelled correctly after test disabling, by using attachment description & basic comment searches. However if the test for which this bug was about has in fact been disabled/annotated/..., please accept my apologies & reopen/mark the whiteboard appropriately so this doesn't get re-closed in the future (and please ping me via IRC or email so I can try to tweak the saved searches to avoid more edge cases).

Sorry for the spam! Filter on: #FFA500
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → WORKSFORME
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.