Closed Bug 629450 Opened 12 years ago Closed 12 years ago

[si] Sinhala rendering is broken in Firefox 4.0 beta

Categories

(Core :: Layout: Text and Fonts, defect)

defect
Not set
critical

Tracking

()

VERIFIED FIXED
mozilla2.0b11
Tracking Status
blocking2.0 --- final+

People

(Reporter: danishka, Assigned: jfkthame)

Details

(Keywords: regression, Whiteboard: [hardblocker])

Attachments

(9 files)

Both GUI and webpages rendering broken in Firefox 

this could reproduce in Firefox 4 beta 9 and 10.
Could not test on earlier beta versions of Firefox 4.0

If you notice the firstrun page (i have attached) 
The Main Heading end with the character 'දේ' but its not showing properly
in the same line (after 4 beta) the second Sinhala word should be අඩංගු but the word appear is totally wrong.

if you noticed the 'File menu' File should appear as "ගොනු (F)"

in the same submenu, check the printing (just front of Ctrl+P)  
මුද්‍රණය also not rendering well
i was checking firstrun page on both Fx 3.6.13 and 4.ob10
http://www.mozilla.com/en-US/firefox/4.0b10/firstrun/
I reproduced this on the mac, too.

This requires fonts, though, which I found on http://web.nickshanks.com/typography/.

I'll also attach two screenshots from the first-run page, the video block shows at least two bugs:

In the white heading, two glyphs change order. In the regular paragraph, the first glyph of the second word displays as it was standalone (if you copy and paste just the first glyph in 3.6, it looks like in 4.0).
Attached image snippet in 4.0
Attached image snippet in 3.6
This is a regression compared at least to 3.6, requesting blocking.
blocking2.0: --- → ?
regarding comment#1:

I am sorry I was checking whatsnew page 
http://www.mozilla.com/si/firefox/4.0b10/whatsnew
Axel, both attachments ( 507546 and 507548) are not correct

This is the correct text

507548 is some what ok but it also has an issue on very first word
Danishka, Axel, could you attach or link to a simple testcase and include steps to reproduce the problem with a given font?
Attached file two paragraph testcase
This is a two line testcase that shows differently in 4.0 and 3.6. It's taken from the 4.0b10 whatsnew page.

IIRC, this is about hints from the font about how to interact with neighboring glyphs not working. That's paraphrased by someone that knows jack about fonts, but it seems like they're not showing up as written, but like in an alphabet listing.

Also, all I can say is that it looks different, not how it's supposed to look, sadly. I can reproduce this on the mac, with the font linked above.
The problem is that Sinhala was omitted from the list of scripts in gfxUnicodeProperties.cpp that require specific shaping support, and so it is being rendered via harfbuzz by default, but harfbuzz doesn't yet have shaping support for it.

Fix is to assign Sinhala to Level 3, along with the Indic scripts, etc.
Assignee: nobody → jfkthame
Attachment #507621 - Flags: review?(jdaggett)
This should block 2.0, IMO, as it means Sinhala text is totally broken; happily, it's a trivial and safe patch. :)
Comment on attachment 507621 [details] [diff] [review]
patch, assign Sinhala to shaping level 3

Are there others that might have been missed?
Attachment #507621 - Flags: review?(jdaggett)
Attachment #507621 - Flags: review+
Attachment #507621 - Flags: approval2.0?
Attachment #507621 - Flags: approval2.0? → approval2.0+
blocking2.0: ? → final+
Whiteboard: [hardblocker]
(In reply to comment #12)
> Comment on attachment 507621 [details] [diff] [review]
> patch, assign Sinhala to shaping level 3
> 
> Are there others that might have been missed?

John, are you asking for other locales which are not rendered correctly and only show squares? While running update tests for all locales on OS X yesterday I have seen some more.
Landed on trunk
http://hg.mozilla.org/mozilla-central/rev/103c3d98d560
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
(In reply to comment #15)

> > Are there others that might have been missed?
> 
> John, are you asking for other locales which are not rendered correctly and
> only show squares? While running update tests for all locales on OS X yesterday
> I have seen some more.

Actually, not exactly.  I was asking about other HB_SCRIPT values.
(In reply to comment #15)
> John, are you asking for other locales which are not rendered correctly and
> only show squares? While running update tests for all locales on OS X yesterday
> I have seen some more.

That doesn't surprise me; there are some languages/scripts for which OS X does not ship with any fonts, so you'd see hexboxes unless you've installed 3rd-party fonts that have the necessary character repertoire.
will this patch ship with Firefox 4b11 ?
Can I have a nightly build to test?
(In reply to comment #19)
> will this patch ship with Firefox 4b11 ?
> Can I have a nightly build to test?

Yes it will. Wait for todays nightly which will appear shortly.

(In reply to comment #18)
> > John, are you asking for other locales which are not rendered correctly and
> > only show squares? While running update tests for all locales on OS X yesterday
> > I have seen some more.
> 
> That doesn't surprise me; there are some languages/scripts for which OS X does
> not ship with any fonts, so you'd see hexboxes unless you've installed
> 3rd-party fonts that have the necessary character repertoire.

Yeah, my bad. Sorry, was kinda late in the night when I commented on that.
Target Milestone: --- → mozilla2.0b11
Henrik,

tested the firefox-4.0b11pre.si.i686 and its working for /me
sorry for the late reply. :)
Thanks Danishka. Marking as verified fixed then.
Status: RESOLVED → VERIFIED
Henrik, 

we can test the same on tomorrow as Fx 4 b11 will release on tomorrow AFAIK
You need to log in before you can comment on or make changes to this bug.