Closed Bug 629488 Opened 9 years ago Closed 9 years ago

Roboform toolbars 7.1.5 does not work with fx 4 beta 10 (installed and works with fx 4.0 beta 9)

Categories

(Firefox :: Toolbars and Customization, defect, major)

x86
Windows 7
defect
Not set
major

Tracking

()

RESOLVED INVALID

People

(Reporter: tobefosu, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b9) Gecko/20100101 Firefox/4.0b9
Build Identifier: Firefox 4.0 beta 10 x86 Win32 french

Under firefox 4.0 beta 9, Roboform toolbar 7.1.5 installs ans works correctly.
After updating to firefox 4.0 beta 10, Roboform toolbar 7.1.5 does not work any longer. A lot of error messages in "Console d'erreurs".

Reproducible: Always

Steps to Reproduce:
1.Installing Roboform toolbar 7.1.5 within firefox 4.0 beta 9
2.Updating to firefox 4.0 beta 10
3.Run firefox 
Actual Results:  
Roboform toolbar does not expand correctly (only two buttons "Roboform" and "Close"). Lot of error messages in "Console d'erreurs".

Expected Results:  
Roboform toolbar expands with about 8 buttons

nothing
Error message in "Console d'erreurs":
Erreur : uncaught exception: [Exception... "Component returned failure code: 0x80070057 (NS_ERROR_ILLEGAL_VALUE) [nsIComponentRegistrar.autoRegister]"  nsresult: "0x80070057 (NS_ERROR_ILLEGAL_VALUE)"  location: "JS frame :: chrome://roboform/content/roboform.js :: RoboStart :: line 390"  data: no]
Roboform needs to update their toolbar then. http://www.roboform.com/support/faq/roboform#faq_report
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → INVALID
Thank you for your answer. The problem has been taken into account by Roboform: 

Bug #452360
Alec replied (2011/01/27 05:04 pm EST) 	
Thank you for your message.
Currently this is correct. Currently beta 10 is not yet supported and we should have this fixed in the next release. No ETA
You need to log in before you can comment on or make changes to this bug.