Closed Bug 62964 Opened 19 years ago Closed 19 years ago

except for "Select All", message pane context menus fail to do anything.

Categories

(SeaMonkey :: MailNews: Message Display, defect, P3)

x86
All
defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: spam, Assigned: sspitzer)

References

Details

(Keywords: regression, verifyme)

Attachments

(1 file)

Linux SEA 2000121506

In a mail: both context menu's "open link in new window" or middle-button
clicking it, only spawns this in console:

JavaScript error:
chrome://communicator/content/contentAreaUtils.js line 33: isDocumentFrame is
not defined
I see the exact same problem on NT.  Mozilla 121508.
OS: All
OS: Linux → All
seems mstolz added the current line 33 in contentAreaUtils.js - adding to CC
Keywords: regression
Whoops...function OpenNewWindowWith() moved to ContentAreaUtils.js but
isDocumentFrame() is still in navigator.js - obviously not available to mail.
Can I move this function too, or just duplicate it?
Assignee: putterman → mstoltz
Status: NEW → ASSIGNED
Oh good...this wasn't my fault :-)  dup of bug 63185. You can take that if you 
want, Mitch, but I think jag and I will be fixing it in our cleanup anyways 
(soon).

*** This bug has been marked as a duplicate of 63185 ***
Status: ASSIGNED → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
why is this a dup?
Sorry, I didn't even realize this was the older bug.
You added yourself to CC here manually several days ago.
The problem was already located.
And at the time you marked it dup, it was already assigned.
So why is this a dup?
Reopening.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
*** Bug 63185 has been marked as a duplicate of this bug. ***
Blake,
  What's the best way to handle this? Can I move the isDocumentFrame function to
contentAreaUtils (it's used elsewhere in navigaror.js, ben G. wrote it) or
should I duplicate it in contentAreaUtils?
Calm down.  I marked it a dup because I was going to fix it, and 
contentAreaUtils.js is my file.

Mitch: I don't think there will be any problems moving it from navigator.js to 
contentAreaUtils.js.  But since this isn't really urgent, I'd recommend waiting 
til jag and I get further in our clean-up...which is why I wanted to dup this 
against the other bug...because I was holding onto it...
[and no, I was not the one who added me to the CC list.  look at the bug 
history]
ahh it was David. Anyways - why not just assign this to yourself if the bug is
yours? I agree it isn't urgent.
*** Bug 63343 has been marked as a duplicate of this bug. ***
Actually, I think we should fix this soon, with .7 coming by year's end.  
Moving it should be fine (do some ad hoc testing first).
taking this so it gets fixed today.
Assignee: mstoltz → sspitzer
Status: REOPENED → NEW
Summary: "open link in new window" fails → "open link in new window" fails from message pane
accepting, here comes the patch....
Status: NEW → ASSIGNED
actually, that isn't the error anymore.

I get "line 0: contextMenu has no properties"

working on the fix now, I think I've got it.
by the looks of it, I have a feeling all the message pane context menus were
broken.

zoinks.
r=blake
yep, except for "Select All" the context menu actions were broken.

this patch will fix them all.

updating summary.
Summary: "open link in new window" fails from message pane → except for "Select All", message pane context menus fail to do anything.
fixed.

thanks to bienvenu for the sr=.
Status: ASSIGNED → RESOLVED
Closed: 19 years ago19 years ago
Resolution: --- → FIXED
did this fix bug 58530 as well? "Copy Link Location broken in Mail messages"
*** Bug 58530 has been marked as a duplicate of this bug. ***
yes, that other bug was  a dup of this one.
VERIFIED FIXED on Build 2000122805, Windows 2000, build 2000122808, and as soon
as I get my mac to stop spewing XUL files all over the desktop at launch, I'll
verify on Mac ;-(
QA Contact: esther → stephend
Someone else on Mac needs to verify this, my builds keep doing the same thing I
reported above.  Adding verifyme keyword.
Keywords: verifyme
Context menu functionality in mail message pane all OK again.
Verifying Linux 2000-122721 fixed.

VERIFIED on Mac 2000122904.
Status: RESOLVED → VERIFIED
*** Bug 64112 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.