Closed Bug 629645 Opened 9 years ago Closed 1 year ago

Strange behavior when using geolocation pages.

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Android
defect
Not set

Tracking

(fennec-)

RESOLVED WONTFIX
Tracking Status
fennec - ---

People

(Reporter: anamaria.moldovan, Unassigned)

Details

BUILD ID: Mozilla /5.0 (Android;Linux armv7l;rv:2.0b11pre) Gecko/20110127 Firefox/4.0b11pre Fennec /4.0b5pre 


I have noticed a really strange behavior when using the geolocation test webpage. Assuming I have some web browsing history, bookmarks, synced accounts (basically lots of scenarios) and I want to load the geolocation web page I get a blank page.

A.
Steps to reproduce:
1. Load the geolocation page: http://hg.mozilla.org/qa/litmus-data/raw-file/tip/firefox/geolocation/wifi.html
2. Click the "Share Location" button
3. Verify you get a page with your geolocation information as well as a map

Actual result:
I get a blank page, no blue geolocation notification with: "Share" and "Don't share" buttons.

Expected result:
I should get a blue notification with: "Share" and "Don't share" buttons. After clicking on "Share" button, I should get a page with geolocation information as well as a map.

So, I clear my profile from: Settings -> Applications -> Manage Applications -> Fennec -> Clear data

B.  Then, following the same steps to reproduce from A., the actual result is:
The blue notification comes down: I click on "Share" button -> the notification disappears, but the page remains in blank. I reload the page -> Click on "Share" button, after which the page with geolocation information and a map appears. So, basically I have to click twice on the "Share" button for the geolocation information and map to appear.

The strange thing is that after cleaning the profile, and loading some webpages e.g.: www.cnn.com, www.msn.com and then http://hg.mozilla.org/qa/litmus-data/raw-file/tip/firefox/geolocation/wifi.html, I cannot reproduce A., only B.

So, is this related with loading some specific sites? I did not share my location on any webpages.
I'm getting a blank page too after tapping on the 'Share' button.
I'm also seening this error in the error console:
Cc['@mozilla.org/wifi/monitor;1'] is undefined
resource://gre/components/NetworkGeolocationProvider.js
257
Same issue with 4.0b6PRE Blank page.
Going back and forward also causes some issues from a geolocation page.
tracking-fennec: --- → ?
Assignee: nobody → doug.turner
tracking-fennec: ? → +
Assignee: doug.turner → nobody
tracking-fennec: + → -
Closing all opened bug in a graveyard component
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.