JS Navigator object returns bogus platform

VERIFIED DUPLICATE of bug 10465

Status

()

Core
DOM: Core & HTML
P3
normal
VERIFIED DUPLICATE of bug 10465
19 years ago
19 years ago

People

(Reporter: bobj, Assigned: Judson Valeski)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
Running xxx build on US NT4, and going to the URL
  http://rocknroll/users/nhotta/publish/html/nav_obj.html
it returns:

 navigator.appVersion=5
 navigator.platform=Win95
 navigator.language=en
 navigator.userAgent=Mozilla/5.0 [en] (Win95; I)
 screen.width=-1
 screen.height=-1
 screen.pixelDepth=-1 bits
 screen.colorDepth=-1 bits, 0.5 colors

but the platform is NT4, not Win95.

I tried this on 4.51 and it returns "Win32".  Better, but not
very precise...

Updated

19 years ago
Assignee: norris → vidur
Component: JavaScript → DOM Level 0

Updated

19 years ago
Assignee: vidur → warren

Comment 1

19 years ago
I'm just getting this from the nsINetService interface. Reassigning to the
netlib guys.

Updated

19 years ago
Assignee: warren → valeski
Depends on: 7232

Comment 2

19 years ago
Verify in necko.

Updated

19 years ago
QA Contact: cbegle → gerardok
(Assignee)

Comment 3

19 years ago
as it stands right now, necko will return null for all user agent components;
they aren't being initialized right now. How do we want to init them now that
they're in necko (pure xp code)? In the old world the FE would set the various
pieces as they are FE dependent. I suppose I should just have the code that is
setting them now grab an nsINetService and set them that way, but there are two
problems with that:

1. Before any urls are loaded we have to be sure that they get set via
nsINetService.
2. How do we protect ourselves from some rogue code grabbing the nsINetService
and changing the values? (there is a certain portion of the UA string that is
static and will act as our brand).

Updated

19 years ago
No longer depends on: 7232

Updated

19 years ago
Blocks: 7232

Updated

19 years ago
QA Contact: gerardok → desale
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 4

19 years ago
*** This bug has been marked as a duplicate of 10465 ***

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 5

19 years ago
Maring verified.
You need to log in before you can comment on or make changes to this bug.