leading and trailing whitespace not allowed

RESOLVED INVALID

Status

Cloud Services
Firefox Sync: UI
RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: tracy, Unassigned)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
This is a regression of bug 620593.  It happens on both 1.6.2 and minefield nightly build 20110128

-In initial account setup, if I prefix and/or suffix the email address with
spaces, the ui tells me it's an invalid address.

-If I do the same in the add client wizard, it tells me the account name or password is wrong.
It looks like the m-c part of Bug 620593 was never pushed. We were waiting for a merge from fx-sync up to m-c, and then never followed up.

Checking on the add-on now.
For the add-on: Bug 620593 was not applied to 1.6.x. We can transplant it, but it would require another release. mconnor's call -- if we're going straight to 1.7, there's no point.

For m-c: they're rolling up b11 now, so the tree is locked. Not going to happen today for sure.
I have reopened bug 620593, resolving this bug since it's not a regression (we never really fixed it in the first place.)

Richard, we haven't released 1.6.3 yet, so if you want to land those fixes on 1.6.x, go ahead.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
Landed on 1.6.x. Tests pass.
You need to log in before you can comment on or make changes to this bug.