Fire MozAfterPaint events when empty transactions occur

RESOLVED FIXED in mozilla2.0b12

Status

()

Core
Layout
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: roc, Assigned: kael)

Tracking

({regression})

unspecified
mozilla2.0b12
x86_64
Linux
regression
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(blocking2.0 final+)

Details

(Whiteboard: [softblocker])

Attachments

(1 attachment, 1 obsolete attachment)

Like bug 625248 but for MozAfterPaint events. This should be easier, you just need to call NotifyDidPaintForSubtree in the right place.

You'll need to write tests though.
blocking2.0: --- → final+
Whiteboard: [softblocker]
Keywords: regression
(Assignee)

Comment 1

7 years ago
I cannot come up with a reproduction case where trunk fails to fire MozAfterPaint for empty transactions, though I admit I don't understand the graphics stack very well at this point. Can you provide a repro, or at least a description of one?
(Assignee)

Comment 2

7 years ago
Created attachment 508644 [details] [diff] [review]
Dispatch MozAfterPaint events during empty transactions after incrementing mozPaintCount

I've attached a patch that dispatches the MozAfterPaint event after incrementing mozPaintCount during an empty transaction. The patch includes a couple tests based on the ones for the mozPaintCount bug.

Note that this patch won't merge correctly unless my patch from #625248 has been applied.
Attachment #508644 - Flags: review?(roc)
(Assignee)

Updated

7 years ago
Depends on: 625248
Looks great!

+        frame->PresContext()->NotifyDidPaintForSubtree();

Just use 'presContext'
(Assignee)

Comment 4

7 years ago
Created attachment 508855 [details] [diff] [review]
Dispatch MozAfterPaint events during empty transactions after incrementing mozPaintCount (2)

Patch updated.
Attachment #508644 - Attachment is obsolete: true
Attachment #508855 - Flags: review?(roc)
Attachment #508644 - Flags: review?(roc)
Attachment #508855 - Flags: review?(roc) → review+
Keywords: checkin-needed
Whiteboard: [softblocker] → [softblocker][needs landing]

Comment 5

7 years ago
http://hg.mozilla.org/mozilla-central/rev/f4c949162937
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Flags: in-testsuite+
Keywords: checkin-needed
Resolution: --- → FIXED
Whiteboard: [softblocker][needs landing] → [softblocker]
Target Milestone: --- → mozilla2.0b12

Comment 6

7 years ago
I backed this patch as part of this pushlog <http://hg.mozilla.org/mozilla-central/pushloghtml?changeset=7e12e3e16e6c> because of the oranges it caused <http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1296852850.1296854923.2345.gz&fulltext=1>.

I'm not sure which one of the bugs was at fault, so I just backed them all out.  The assignee needs to investigate and make sure that his patch has not been the culprit, and then re-add checkin-needed.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 7

7 years ago
(In reply to comment #6)
> I backed this patch as part of this pushlog
> <http://hg.mozilla.org/mozilla-central/pushloghtml?changeset=7e12e3e16e6c>
> because of the oranges it caused
> <http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1296852850.1296854923.2345.gz&fulltext=1>.
> 
> I'm not sure which one of the bugs was at fault, so I just backed them all out.
>  The assignee needs to investigate and make sure that his patch has not been
> the culprit, and then re-add checkin-needed.

Sorry, this belonged to bug 631329.
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → FIXED

Updated

7 years ago
Depends on: 631329
Relanded all but one of the patches in that push.  For this bug, that's:
http://hg.mozilla.org/mozilla-central/rev/10ecb300665e
The last four comments apparently all belonged on bug 631329.
You need to log in before you can comment on or make changes to this bug.