Last Comment Bug 629870 - Drop support for globalCompositeOperation=over,clear
: Drop support for globalCompositeOperation=over,clear
Status: VERIFIED FIXED
: dev-doc-complete
Product: Core
Classification: Components
Component: Canvas: 2D (show other bugs)
: Trunk
: All All
-- normal (vote)
: mozilla7
Assigned To: :Ms2ger (⌚ UTC+1/+2)
:
: Milan Sreckovic [:milan]
Mentors:
http://www.w3c-test.org/html/tests/ap...
Depends on: 673307
Blocks: 622842
  Show dependency treegraph
 
Reported: 2011-01-29 04:00 PST by :Ms2ger (⌚ UTC+1/+2)
Modified: 2011-08-22 01:45 PDT (History)
6 users (show)
Ms2ger: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+


Attachments
Patch v1 (3.85 KB, patch)
2011-02-08 11:03 PST, :Ms2ger (⌚ UTC+1/+2)
jonas: review+
Details | Diff | Splinter Review
Patch for checkin (3.93 KB, patch)
2011-03-25 09:07 PDT, :Ms2ger (⌚ UTC+1/+2)
no flags Details | Diff | Splinter Review

Description User image :Ms2ger (⌚ UTC+1/+2) 2011-01-29 04:00:12 PST

    
Comment 2 User image Vladimir Vukicevic [:vlad] [:vladv] 2011-01-29 11:22:57 PST
Er what? Why did these get removed?
Comment 4 User image :Ms2ger (⌚ UTC+1/+2) 2011-02-08 11:03:34 PST
Created attachment 510678 [details] [diff] [review]
Patch v1
Comment 5 User image Jonas Sicking (:sicking) No longer reading bugmail consistently 2011-03-11 18:06:49 PST
Comment on attachment 510678 [details] [diff] [review]
Patch v1

You're also removing "darker" from the getter. Is that safe since the setter never sets it?
Comment 6 User image :Ms2ger (⌚ UTC+1/+2) 2011-03-12 01:50:05 PST
I just missed the getter in bug 571532. I don't believe that change has an observable effect.
Comment 7 User image :Ms2ger (⌚ UTC+1/+2) 2011-03-25 09:07:55 PDT
Created attachment 521839 [details] [diff] [review]
Patch for checkin
Comment 8 User image Olli Pettay [:smaug] (pto-ish for couple of days) 2011-03-31 12:04:21 PDT
What do other browsers do?
Comment 9 User image :Ms2ger (⌚ UTC+1/+2) 2011-03-31 14:10:02 PDT
The last time I tested, Chrome supported "clear", IE, and Opera don't. None of Chrome, IE and Opera supported "over". I'm fine with waiting another cycle, as Boris suggested.
Comment 10 User image :Ms2ger (⌚ UTC+1/+2) 2011-06-02 08:48:17 PDT
http://hg.mozilla.org/mozilla-central/rev/25508c9bd01c
Comment 11 User image Eric Shepherd [:sheppy] 2011-07-11 12:13:46 PDT
We don't actually document these, so I've simply mentioned their removal on Firefox 7 for developers.
Comment 12 User image Simona B [:simonab ] 2011-08-19 06:29:41 PDT
Mozilla/5.0 (Windows NT 5.1; rv:7.0) Gecko/20100101 Firefox/7.0

I was trying to verify this on the QA side and by loading the page from Comment 1 I get "clear" and a "Passed" result under the "Actual output". Can anyone say what is expected to be seen for the test example in comment 1, or is there another testcase that can be used to verify the fix? Thanks!
Comment 13 User image :Ms2ger (⌚ UTC+1/+2) 2011-08-19 07:25:32 PDT
The testcase in comment 1 should have a green background, and say

* Passed

below the image.
Comment 14 User image Simona B [:simonab ] 2011-08-22 01:45:02 PDT
Mozilla/5.0 (Windows NT 5.1; rv:7.0) Gecko/20100101 Firefox/7.0

Based on Comment 13 - Verified issue on Win XP, Win 7, Ubuntu 11.04 and Mac OS X 10.6 using the test case provided in Comment 1.

Setting resolution to VERIFIED FIXED.

Note You need to log in before you can comment on or make changes to this bug.