Closed Bug 629876 Opened 9 years ago Closed 7 years ago

Throw when drawImage's sw/sh arguments are zero

Categories

(Core :: Canvas: 2D, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla19

People

(Reporter: Ms2ger, Assigned: Ms2ger)

References

(Blocks 1 open bug, )

Details

Attachments

(1 file)

> If one of the sw or sh arguments is zero, the implementation must raise an
> INDEX_SIZE_ERR exception.

http://www.w3c-test.org/html/tests/submission/PhilipTaylor/canvas/2d.drawImage.zerosource.html
might be addressed by the patch in the bug 629875
And indeed it is.
Status: NEW → RESOLVED
Closed: 9 years ago
No longer depends on: 629875
Resolution: --- → DUPLICATE
Duplicate of bug: 629875
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Attached patch Patch v1Splinter Review
Assignee: nobody → Ms2ger
Status: REOPENED → ASSIGNED
Attachment #676931 - Flags: review?(bzbarsky)
Comment on attachment 676931 [details] [diff] [review]
Patch v1

r=me if other UAs do this.
Attachment #676931 - Flags: review?(bzbarsky) → review+
https://hg.mozilla.org/mozilla-central/rev/fdb936f5d986
Status: ASSIGNED → RESOLVED
Closed: 9 years ago7 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla19
Depends on: 809239
Depends on: 812153
You need to log in before you can comment on or make changes to this bug.