Last Comment Bug 629925 - Return status panel to the left when mouse leaves the area
: Return status panel to the left when mouse leaves the area
Status: RESOLVED FIXED
fixed by bug 646038
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: unspecified
: All All
: -- enhancement with 2 votes (vote)
: Firefox 12
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on: 646038
Blocks: 628654
  Show dependency treegraph
 
Reported: 2011-01-29 11:11 PST by Rodze
Modified: 2012-01-13 03:59 PST (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Rodze 2011-01-29 11:11:53 PST
User-Agent:       Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:2.0b11pre) Gecko/20110129 Firefox/4.0b11pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:2.0b11pre) Gecko/20110129 Firefox/4.0b11pre

On bug 628654 the statuspanel moves to the right when you mouse over it, but it doesn't return back when the cursor goes away.

If the intent was to copy Chrome's workaround, it should go back to the default place.

Reproducible: Always
Comment 1 Dão Gottwald [:dao] 2011-01-29 11:33:09 PST
(In reply to comment #0)
> If the intent was to copy Chrome's workaround,

Not really. I didn't actually check what exactly Chrome was doing when fixing bug 628654.
Comment 2 Rodze 2011-01-29 12:30:36 PST
I was using Firefox and happened to find myself searching for the statuspanel a couple of times, only to realize it was on the right because I guess I moused over it. Then I went to check Chrome.

I guess their implementation makes sense since you're gonna be conditioned to look to one side and moving it away is really just a momentary workaround for it not to get in the way of what you supposedly want to do with your mouse in that moment.
Comment 3 Alex Limi (:limi) — Firefox UX Team 2011-01-29 13:01:22 PST
Just a quick impression: moving it over to the right side when the pointer gets close to the activity indicator makes the UI seem twitchy and unstable, and I thought I had hit a bug in the implementation. It then got "stuck" to the right, and I wondered why it broke.

My personal recommendation would be to just remove it when the cursor gets close, and restore it in the same location when you move away from it again. 

Showing the status indicator when you want to click a link that is located under it is an edge case that we shouldn't go out of our way to support.
Comment 4 Bill Gianopoulos [:WG9s] 2011-01-30 04:07:43 PST
The current implementation, where it moves to the left and sticks better addresses the grooveshark playback controls issue mentioned here:

https://bugzilla.mozilla.org/show_bug.cgi?id=628654#c33
Comment 5 Bill Gianopoulos [:WG9s] 2011-01-30 04:09:36 PST
(In reply to comment #4)
> The current implementation, where it moves to the left and sticks better
> addresses the grooveshark playback controls issue mentioned here:
> 
> https://bugzilla.mozilla.org/show_bug.cgi?id=628654#c33

Ooops!  I obviously meant moves to the right  (Sorry for additional SPAM here)

Note You need to log in before you can comment on or make changes to this bug.