Closed Bug 629969 Opened 9 years ago Closed 9 years ago

Don't show status messages for XHR requests

Categories

(Firefox :: General, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 4.0b11

People

(Reporter: vlad, Assigned: dao)

References

Details

Attachments

(1 file)

(Originally posted in bug 628654 comment #70.)

This change (bug 628654) essentially makes it impossible for anyone trying to do any kind of
full-screen web app, such as they might be doing with our new fast fancy
hardware accelerated graphics support.  The notification bar shows up *all the
time* when you do any kind of XHR request, and is incredibly distracting
because it keeps blinking in and out.

We made the decision very early on to remove the status bar; if we now want to
bring back the status bar, let's do that, but let's not do this half-baked
distracting thing.  We should kill this off IMO, go with the first goals for Firefox 4, and not try to second-guess ourselves in the 11th hour here.
> This change (bug 628654) essentially makes it impossible for anyone trying to
> do any kind of
> full-screen web app, such as they might be doing with our new fast fancy
> hardware accelerated graphics support.  The notification bar shows up *all the
> time* when you do any kind of XHR request, and is incredibly distracting
> because it keeps blinking in and out.

So there are multiple fast requests and the popup appears/disappears repeatedly?
Bug 628654 comment 0 states that "there is a concern that the browser feels slower for that removal since messages about page load status were removed". I'm not sure that's accurate. I can't speak for the people having made this decision, but I think the main concern is that for slow requests, we should give feedback about what's taking long. To that end I'd suggest hiding the popup for the first second or so.
Depends on: 629984
Suppressing status updates for the first second won't help with XHR that e.g. downloads a bunch of bitmaps or data (think Google Body Browser). I think we should leave XHR progress feedback to the web apps.
Attachment #508209 - Flags: feedback?(jag-mozilla)
Attachment #508209 - Attachment description: patch to suppress the status message when the throbber doesn't spin → patch to suppress status messages when the throbber doesn't spin
Comment on attachment 508209 [details] [diff] [review]
patch to suppress status messages when the throbber doesn't spin

Looks good. I'll give you r=jag too.
Attachment #508209 - Flags: review+
Attachment #508209 - Flags: feedback?(jag-mozilla)
Attachment #508209 - Flags: feedback+
(In reply to comment #4)
> I'll give you r=jag too.

I'm not sure if I can use that, but I'll try.
Attachment #508209 - Flags: approval2.0?
Not sure if attachment 508209 [details] [diff] [review] already does that, but --- how about just removing status messages when in full-screen mode, for starters? That should be an easy consensus.
Benoit, would you mind filing a new bug with that proposal? This bug addresses the flickering that comes from XHR (common in web apps) etc., whether you're in full-screen mode or not.
(In reply to comment #5)
> (In reply to comment #4)
> > I'll give you r=jag too.
> 
> I'm not sure if I can use that, but I'll try.

Jag's an old timer, from the dawn of XUL. He's still a SeaMonkey peer, FWIW.

/be
Attachment #508209 - Flags: review+
Attachment #508209 - Flags: approval2.0?
Attachment #508209 - Flags: approval2.0+
http://hg.mozilla.org/mozilla-central/rev/4a05e5eaca00
Assignee: nobody → dao
Status: NEW → RESOLVED
blocking2.0: ? → ---
Closed: 9 years ago
No longer depends on: 629984
Resolution: --- → FIXED
Summary: Remove blinking/flickering notification tooltip → Don't show status messages for XHR requests
Target Milestone: --- → Firefox 4.0b11
Duplicate of this bug: 629984
(In reply to comment #8)
> Jag's an old timer, from the dawn of XUL. He's still a SeaMonkey peer, FWIW.

... and he's still a super-reviewer. ;)
Duplicate of this bug: 630196
Duplicate of this bug: 630009
You need to log in before you can comment on or make changes to this bug.