Closed Bug 629979 Opened 9 years ago Closed 9 years ago

[SeaMonkey, Linux] xpcshell: permanent "test_async_history_api.js | 2 == 3"

Categories

(Toolkit :: Places, defect, major)

x86
Linux
defect
Not set
major

Tracking

()

RESOLVED FIXED
mozilla2.0b12

People

(Reporter: sgautherie, Assigned: Margaret)

References

(Blocks 1 open bug, )

Details

(Whiteboard: [fixed by bug 628805] [perma-orange])

Last good:
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1296165003.1296167387.16031.gz
Linux comm-central-trunk debug test xpcshell on 2011/01/27 13:50:03

1st failure: (which happened once only, probably before Mark's fix)
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1296180496.1296182947.4452.gz
Linux comm-central-trunk debug test xpcshell on 2011/01/27 18:08:16
{
TEST-UNEXPECTED-FAIL | /builds/slave/test/build/xpcshell/tests/toolkit/components/places/tests/unit/test_async_history_api.js | test failed (with xpcshell return code: 0), see following log:
...
TEST-UNEXPECTED-FAIL | /builds/slave/test/build/xpcshell/tests/toolkit/components/places/tests/unit/head_bookmarks.js -> file:///builds/slave/test/build/xpcshell/tests/toolkit/components/places/tests/head_common.js | [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIIOService.newURI]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: resource://gre/modules/NetUtil.jsm :: NetUtil_newURI :: line 222"  data: no] - See following stack:
JS frame :: /builds/slave/test/build/xpcshell/head.js :: do_throw :: line 439
JS frame :: /builds/slave/test/build/xpcshell/tests/toolkit/components/places/tests/unit/head_bookmarks.js -> file:///builds/slave/test/build/xpcshell/tests/toolkit/components/places/tests/head_common.js :: _run_next_test :: line 670
JS frame :: /builds/slave/test/build/xpcshell/head.js :: <TOP_LEVEL> :: line 406
}

New permanent failure:
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1296191832.1296194408.21458.gz
Linux comm-central-trunk debug test xpcshell on 2011/01/27 21:17:12
{
TEST-UNEXPECTED-FAIL | /builds/slave/test/build/xpcshell/tests/toolkit/components/places/tests/unit/test_async_history_api.js | test failed (with xpcshell return code: 0), see following log:
...
TEST-UNEXPECTED-FAIL | /builds/slave/test/build/xpcshell/tests/toolkit/components/places/tests/unit/test_async_history_api.js | 2 == 3 - See following stack:
JS frame :: /builds/slave/test/build/xpcshell/head.js :: do_throw :: line 439
JS frame :: /builds/slave/test/build/xpcshell/head.js :: do_check_eq :: line 491
JS frame :: /builds/slave/test/build/xpcshell/tests/toolkit/components/places/tests/unit/test_async_history_api.js :: <TOP_LEVEL> :: line 468
}

I don't know whether the cause is in Core/test or SeaMonkey...
blocking-seamonkey2.1: --- → ?
status2.0: --- → ?
I thought Mark had fixed this shortly after I merged...
No, I fixed the NS_ERROR_FAILURE case but not the 2 == 3.
Thinking about it, I may have seen occasional random failures with that test on Thunderbird tree before the big changes (unless I'm getting confused with another 2 == 3), but they are occasional. Thunderbird doesn't run tests in debug mode though, so maybe that's another reason.
(In reply to comment #3)
> Unclear why that would be failing on Seamonkey only.

We have different prefs, i.e. awesomebar only searching in history by default, I trust those don't influence this?
(In reply to comment #4)
> Thinking about it, I may have seen occasional random failures with that test on
> Thunderbird tree before the big changes (unless I'm getting confused with
> another 2 == 3), but they are occasional. Thunderbird doesn't run tests in
> debug mode though, so maybe that's another reason.
I think that this test file added this test function in the last merge, so this is unlikely.

(In reply to comment #5)
> We have different prefs, i.e. awesomebar only searching in history by default,
> I trust those don't influence this?
Nope, those don't matter at all here.
FTR we've just had a random Mac orange with this on the Thunderbird tree:

http://tinderbox.mozilla.org/showlog.cgi?log=Thunderbird/1296477071.1296478256.30873.gz#err0

TEST-UNEXPECTED-FAIL | /builds/slave/comm-central-trunk-macosx64-opt-unittest-xpcshell/build/xpcshell/tests/toolkit/components/places/tests/unit/test_async_history_api.js | 2 == 3 - See following stack:
JS frame :: /builds/slave/comm-central-trunk-macosx64-opt-unittest-xpcshell/build/xpcshell/head.js :: do_throw :: line 439
JS frame :: /builds/slave/comm-central-trunk-macosx64-opt-unittest-xpcshell/build/xpcshell/head.js :: do_check_eq :: line 491
JS frame :: /builds/slave/comm-central-trunk-macosx64-opt-unittest-xpcshell/build/xpcshell/tests/toolkit/components/places/tests/unit/test_async_history_api.js :: <TOP_LEVEL> :: line 468
Do you guys do anything funny with your event loop?
I can't reproduce this on my Linux VM. (Or on my Windows box, of course...)
Blocks: 632625
Filed bug 632625 for the intermittent failures in Firefox (comment 10 through comment 13).
Depends on: 628805
(In reply to comment #14)
> Filed bug 632625 for the intermittent failures in Firefox (comment 10 through
> comment 13).

Thanks!

***

So: intermittent on all Firefox, permanent on Linux SeaMonkey, intermittent on Thunderbird.
Caused by some "async" timing issue?

***

Ah, latest build passed this test:
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1297222876.1297224875.28128.gz
Linux comm-central-trunk debug test xpcshell on 2011/02/08 19:41:16

Fix timeframe would be:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=ffe65159d361&tochange=d2db6c6be747
Likely bug 628805.

Waiting for more builds before confirming...
(In reply to comment #16)
> Waiting for more builds before confirming...

I noticed 1 "random" failure, but otherwise this perma-orange is fixed.
Assignee: nobody → margaret.leibovic
Status: NEW → RESOLVED
blocking-seamonkey2.1: ? → ---
Closed: 9 years ago
status2.0: ? → ---
Component: Bookmarks & History → Places
Flags: in-testsuite-
Product: SeaMonkey → Toolkit
QA Contact: bookmarks → places
Resolution: --- → FIXED
Whiteboard: [perma-orange] → [fixed by bug 628805] [perma-orange]
Target Milestone: --- → mozilla2.0b12
You need to log in before you can comment on or make changes to this bug.