Tooltip text still uses greyscale AA

RESOLVED DUPLICATE of bug 629891

Status

()

Core
Graphics
RESOLVED DUPLICATE of bug 629891
7 years ago
a year ago

People

(Reporter: bb10, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b11pre) Gecko/20110130 Firefox/4.0b11pre
Build Identifier: 4.0b11pre

Tooltips in Firefox still use grey-scale AA for text even though the tooltips aren't transparent (they do fade in and out though, not sure if that's a problem).

Reproducible: Always

Steps to Reproduce:
1. Hover an element
2.
3.
Actual Results:  
text uses grey-scale AA

Expected Results:  
text uses sub-pixel AA
(Reporter)

Comment 1

7 years ago
Created attachment 508310 [details]
Tooltip showing grey-scale AA text

Comment 2

7 years ago
Using latest nightly W7 x86, hovering over the attachment above gives subpixel AA tooltip.

Comment 3

7 years ago
Sorry scrap that, was on Beta 7, on latest nightly this is confirmed. I've found a whole bunch of other problems with variable text antialiasing on bug 632423 - various (bad) changes occurred back on 15-16th July 2Pre builds for some pages, 19th-20th October Beta 8Pre builds for https bars, and 10th-11th November Beta
8Pre for some drop down menus where flash is enabled, these all regressed to greyscale anti-aliasing between Dec 31st-9th Jan 9Pre builds.

Comment 4

7 years ago
Should add, my cases are with hardware acceleration disabled though there may be a connection. Just to confuse things, it seems that urls in the location bar are also using greyscale AA with hardware acceleration on the latest nightly but not with hardware acceleration off.

Comment 5

7 years ago
(In reply to comment #4)
>Just to confuse things, it seems that urls in the location bar
> are also using greyscale AA with hardware acceleration on the latest nightly
> but not with hardware acceleration off.
Sorry, part 2, seems that was just down to me messing with drivers (that was with an old one), urls with hw on are fine. After some testing it seems the tooltips have been greyscale with acceleration on ever since the hardware acceleration enable box was added in Beta 5 so it was broken from the start.
(Reporter)

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 629891
You need to log in before you can comment on or make changes to this bug.