Last Comment Bug 630159 - User reviews do not display since Firefox 4 beta 7
: User reviews do not display since Firefox 4 beta 7
Status: RESOLVED FIXED
[softblocker]
: qawanted
Product: Core
Classification: Components
Component: XPConnect (show other bugs)
: Trunk
: All All
: -- major with 1 vote (vote)
: ---
Assigned To: Mounir Lamouri (:mounir)
:
Mentors:
http://www.argos.co.uk/static/Home.htm
Depends on: 629331
Blocks: 631725
  Show dependency treegraph
 
Reported: 2011-01-31 03:49 PST by vimes_2004
Modified: 2015-10-04 20:34 PDT (History)
12 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
final+


Attachments

Description vimes_2004 2011-01-31 03:49:27 PST
User-Agent:       Opera/9.80 (Windows NT 6.1; U; en) Presto/2.7.62 Version/11.01
Build Identifier: Minefield 4.0b.11pre (30.1.2011)

Using FF 4.6 and up if you go to the above site and then click on any product you can then look at the user reviews. When clicked on the browser will scroll down but then report "reviews timed out".
This can be reproduced on a different machine and by other users as shown in this thread...
http://forums.mozillazine.org/viewtopic.php?f=23&t=2043971

...however if you visit the site with FF 3.xx (or any other browser) and copy the URL from a product review (described in detail on page 4 of the above link) and then open a new session of FF 4 beta 10 or nightly and paste and go the product review will show and everything will then work as normal to display any product review on that website but ONLY during that session.
If you then close down the browser and start it up again and navigate to Argos main website the reviews will no longer show. 

Reproducible: Always

Steps to Reproduce:
1.Install FF 4.10 or latest nightly 
2.Navigate to Argos website 
3.Read product reviews on any product
Actual Results:  
You get a message stating "reviews timed out" - you can see screenshots from the link I posted of the issue in detail

Expected Results:  
Reveal all the customer reviews for ech and every product as it does in FF 3.xx or any other browser.

Default theme used not extensions at all installed. Even tried with safe mode and then disabled all plugins but still the problem occurs.
Comment 1 orangezilla 2011-01-31 04:09:33 PST
Confirmed problem with multiple websites: http://www.argos.co.uk, http://www.homebase.co.uk, http://www.comet.co.uk, http://www.ocado.com (UK), http://www.bestbuy.com (US)

As stated above, click on some of the direct product links i.e. on this page of the thread
http://forums.mozillazine.org/viewtopic.php?f=23&t=2043971&start=30
the reviews then work, close tab, restart, open new tab, search for those retail websites, go to site, navigate to a new product showing stars/reviews, no reviews then show
Comment 2 aravindm 2011-01-31 05:08:48 PST
Regression Range : 
works : 
Mozilla/5.0 (Windows NT 6.1; rv:2.0b7pre) Gecko/20101006 Firefox/4.0b7pre

broken:
Mozilla/5.0 (Windows NT 6.1; rv:2.0b7) Gecko/20100101 Firefox/4.0b7

pushlog: 
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=dee1e01fd8ed
&tochange=297086a0fb61
Comment 3 orangezilla 2011-01-31 09:53:52 PST
Looks like it's a duplicate of https://bugzilla.mozilla.org/show_bug.cgi?id=627424
Comment 4 Matthias Versen [:Matti] 2011-01-31 12:28:54 PST
bug 627424 is in Tech evangelism. That means that they other bugs are only a dupe if they are on the same domain. Or are they using the same underlying service ?
Comment 5 orangezilla 2011-01-31 13:31:49 PST
I assume it was placed in Tech evangelism because they believed it was a one off and therefore assumed bestbuy was likely at fault? Seeing as we now have 5 other major websites with the problem I'm not sure that seems likely unless as you indicate they are using the same/similar software or code. Argos.co.uk & Homebase.co.uk are both part of the 'Home Retail Group'
http://www.argos.co.uk/static/StaticDisplay/includeName/AboutArgos.htm#other

Comet.co.uk & Darty.com are part of 'Kesa Electricals' http://kesaelectricals.com/ although I can't see the issue with their other 3 company websites

Ocado.com AFAIK has no connection to either of these
Comment 6 Boris Zbarsky [:bz] (TPAC) 2011-01-31 20:32:41 PST
Hmm.  Comment 2 has a one-month pushlog range.  Is that on purpose?  If not, can that please be narrowed down more?

This looks like it might need to block, if it's still happening on trunk.
Comment 7 orangezilla 2011-02-01 05:37:29 PST
> Hmm.  Comment 2 has a one-month pushlog range.  Is that on purpose?  If not,
> can that please be narrowed down more?
I think that may be due to misinterpretation of the bug title- I think Vimes tested it on 4 Beta 7,8,9,10 and the latest nightly, but arvindm took that to mean it worked before that, which I don't think is confirmed.
> 
> This looks like it might need to block, if it's still happening on trunk.
Seeing as most people probably buy things from these sites by going to the main site and browsing I'd say it is a pretty big issue, & they are all among the largest retailers in those 3 countries (UK, US, France), no doubt there are problems in other country's retail sites that I haven't checked also.
Comment 8 vimes_2004 2011-02-01 06:09:47 PST
You are right I was not absolutely positive about it working or not on beta 6 and certainly not on prior builds, even though I suspected that it wasn't. I had suspicions as I did use Opera as well as FF and saved some of the reviews as bookmarks. As I used to use those saved bookmarks with FF it would work as it does with a direct link to the review. 

I was however very sure from beta 7 onwards including most of the nightly builds since then.

All that Arvindm needed to do was to read the thread linked and as I do not have any of the early build of FF 4 I can't comment on whether it did work or not.
Comment 9 Boris Zbarsky [:bz] (TPAC) 2011-02-01 08:53:30 PST
If people care, the old builds are all available at http://ftp.mozilla.org/pub/mozilla.org/firefox/

If someone is willing to take the time to help by narrowing down when the problem started (no coding skills needed, very useful thing to do!), that would be wonderful.
Comment 10 vimes_2004 2011-02-01 09:40:42 PST
Ok I downloaded every beta version of Firefox from here...

http://www.oldapps.com/firefox.php

I installed each one and tried it out ensuring that I uninstalled and removed all my previous settings etc before installing the next beta.

Argos worked perfectly all the way up to and including beta 6...

here is a direct link showing beta 6 working...

http://img4.imageshack.us/img4/8373/beta6.png

then it stopped working with beta 7...

http://img59.imageshack.us/img59/1779/beta7.png

hope that helps :)
Comment 11 Boris Zbarsky [:bz] (TPAC) 2011-02-01 09:43:28 PST
OK.  If you take a build that's broken, flip the "javascript.options.methodjit.content" preference in about:config, then try to reproduce this bug (load the relevant page, etc), is the bug present?
Comment 12 Boris Zbarsky [:bz] (TPAC) 2011-02-01 09:43:55 PST
To be clear, you want to set that preference to the boolean |false| as a test.  Then after you're done testing set it back.
Comment 13 Eddward 2011-02-01 09:47:31 PST
works: 
Mozilla/5.0 (Windows NT 6.1; rv:2.0b8pre) Gecko/20101013 Firefox/4.0b8pre

broken:
Mozilla/5.0 (Windows NT 6.1; rv:2.0b8pre) Gecko/20101014 Firefox/4.0b8pre
Comment 14 vimes_2004 2011-02-01 09:52:13 PST
Ok As I had already installed the latest nightly again I used that to test.
I changed the javascript.options.methodjit.content from "true" to "false" and restarted the browser.

However it still will not work when I then navigated back to that site and checked the reviews.

I then reset the option back to "true"
Comment 15 Boris Zbarsky [:bz] (TPAC) 2011-02-01 09:58:18 PST
Interesting.  Eddward's range doesn't match the one in comment 10...

Eddward, what are the hg.mozilla.org URIs from about:buildconfig for those two builds?
Comment 17 orangezilla 2011-02-01 10:55:37 PST
Done some more testing to try and narrow down the cause of the invisible reviews. What I did was this:

Bookmark a search for Camembert on Ocado.com
http://www.ocado.com/webshop/getSearchProducts.do?clearTabs=yes&entry=camembert

Restart FF, open new tab, load that bookmark, click a product with stars, no stars or review show

Bookmark this product
http://www.ocado.com/webshop/product/Cremiere-De-France-Camembert/58312011?from=search&tags=|20000&param=camembert&parentContainer=SEARCHcamembert_SHELFVIEW

Restart FF, open new tab, load that bookmarked product, the stars and review show 

Restart FF, open new tab, load the bookmarked search link, then load the bookmarked product, no stars or review show, so, it looks like the loading of the search page somehow breaks the reviews showing up on item pages.
Comment 18 Boris Zbarsky [:bz] (TPAC) 2011-02-01 11:08:46 PST
Er, nevermind.  Eddward's range does match; I just misread his dates.  Thank you again for narrowing that down, Eddward.

The relevant checkins: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=f6e81dd5a125&tochange=ad0a0be8be74

Blake, Andreas, this is looking like compartments...
Comment 19 Andreas Gal :gal 2011-02-01 11:12:52 PST
Lovely.
Comment 20 Andreas Gal :gal 2011-02-01 11:13:20 PST
A testcase would be great. Until then I will go with the web content.
Comment 21 Andreas Gal :gal 2011-02-01 11:18:05 PST
I can reproduce this but I don't see any security wrapper-related errors.
Comment 22 George Carstoiu 2011-02-02 02:33:50 PST
Mozilla/5.0 (Windows NT 6.1; rv:2.0b11pre) Gecko/20110201 Firefox/4.0b11pre

I was unable to reproduce issue on latest build.
Comment 23 Eddward 2011-02-02 03:42:04 PST
(In reply to comment #22)
> Mozilla/5.0 (Windows NT 6.1; rv:2.0b11pre) Gecko/20110201 Firefox/4.0b11pre
> 
> I was unable to reproduce issue on latest build.

With latest nightly I still see: Customer Reviews - Review retrieval timed out
Try this link http://www.argos.co.uk/static/Product/partNumber/9253573.htm#pdpProductReviews
Comment 24 vimes_2004 2011-02-02 03:48:32 PST
Latest Minefield build for me and it does not work just the same as everything from beta 7 and up...

http://img43.imageshack.us/img43/8589/78391521.png

you can see from the above link the red rectangle area marking where the reviews time out.
Comment 25 vimes_2004 2011-02-02 03:51:12 PST
@Eddward - using such a link on a NEW session of Firefox or Minefield and it will work. Read my bug description and you will see such a link will always seem to work. Start a new session with the browser though and then navigate to Argos and then select a product and it will not work.
Comment 26 orangezilla 2011-02-02 04:12:14 PST
Yes, as stated in comment 17, the bug only occurs when accessing the search page on the site and THEN accessing a product page, in fact, I just confirmed that even if you access the homepage of http://www.ocado.com without carrying out a search and then access a product link i.e. the one below, the same behaviour occurs i.e. reviews do not show:

http://www.ocado.com/webshop/product/Cremiere-De-France-Camembert/58312011?from=search&tags=|20000&param=camembert&parentContainer=SEARCHcamembert_SHELFVIEW
Comment 27 George Carstoiu 2011-02-02 05:55:41 PST
I've tried reproducing the issue on multiple machines with the following results:

I was able to reproduce the issue(always) on these builds following the instructions from Comment 1:
Mozilla/5.0 (X11; Linux i686; rv:2.0b11pre) Gecko/20110201 Firefox/4.0b11pre
Mozilla/5.0 (X11; Linux x86_64; rv:2.0b11pre) Gecko/20110202 Firefox/4.0b11pre
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b11pre) Gecko/20110201 Firefox/4.0b11pre

On these two other builds it seems that the problem may be random (4 out of around 10 times the user reviews were displayed):
Mozilla/5.0 (Windows NT 6.1; rv:2.0b11pre) Gecko/20110201 Firefox/4.0b11pre
Build identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b11pre) Gecko/20110201 Firefox/4.0b11pre

Steps I used to reproduce:
1. Go to www.argos.co.uk
2. Select a product
3. Scroll the page down until you reach "User reviews"
Comment 28 orangezilla 2011-02-02 10:24:33 PST
Ran the tests here on Windows 7 32 bit, 10 out of 10 tests with argos failed
Mozilla/5.0 (Windows NT 6.1; rv:2.0b11pre) Gecko/20110202 Firefox/4.0b11pre

Methodology:

Bookmark www.argos.co.uk, restart, open new tab, load argos bookmark, navigate to an item, click the review link at the top right (with stars and number of reviews), you get "review retrieval timed out" message. Note I selected a different item each time and closed and restarted firefox each time, clearing cache before closing.
Comment 29 Mounir Lamouri (:mounir) 2011-02-02 11:02:11 PST
This is actually a document.domain issue which is fixed by bug 629331.

You can check that easily:
http://www.argos.co.uk/static/Product/partNumber/5296974.htm is not working
http://argos.co.uk/static/Product/partNumber/5296974.htm is working

*** This bug has been marked as a duplicate of bug 629331 ***
Comment 30 orangezilla 2011-02-02 11:18:02 PST
Sorry to disagree here, but that first link DOES show the reviews, it appears to be page with another bug that is not showing stars-review link on the top right, but the reviews are there. I really need to state here that direct links ALWAYS work- the issue is when you access another non single product page first and then access the product page is when the reviews don't work.
Comment 31 Boris Zbarsky [:bz] (TPAC) 2011-02-02 11:21:32 PST
I think we should leave this open until bug 629331 is fixed, then retest...
Comment 32 orangezilla 2011-02-02 11:32:58 PST
Surely though, given volkmar's assertion that the first link does not show reviews seems completely erroneous, a supposed tie to that bug is likely to be misconceived?
Comment 33 vimes_2004 2011-02-02 12:47:15 PST
(In reply to comment #29)
> This is actually a document.domain issue which is fixed by bug 629331.
> 
> You can check that easily:
> http://www.argos.co.uk/static/Product/partNumber/5296974.htm is not working
> http://argos.co.uk/static/Product/partNumber/5296974.htm is working
> 
> *** This bug has been marked as a duplicate of bug 629331 ***

I am not sure if I can understand fully what you are trying to show or if I am not being clear enough in my explanation of how to reproduce this bug...

1. Start a new session of FF
2. Navigate to www.argos.co.uk
3. click on any product
4. click on the review 
note...
http://img43.imageshack.us/img43/8589/78391521.png
5. review times out.

Clicking on ANY saved or posted URL to the reviews directly will then show the review and FF will then continue to work as it should at the Argos site showing reviews in that particular session.

Close down the browser again.
Start up the browser and steps 1 to 5 will be reproduced.

The only versions of FF which work as they should are the 3.xx builds or those prior 4 beta 7, as beta 6 works fine - again screenshots provided as I installed each and every version one at a time to conclude that.
Comment 34 orangezilla 2011-02-02 13:14:19 PST
Just to clarify something Vimes, I verified in comment 17 and comment 26 that clicking a link to a specific product will not work if you first access any page of the site which is not a product page first, i.e. the homepage or a search page like the one posted in comment 17. Since most people purchase things from these sites by doing that and not arriving at a product from an external or saved link, this issue is still a major one in my opinion & work to fix it should not wait for other bug as the reason given to link these two bugs seems erroneous.
Comment 35 Mounir Lamouri (:mounir) 2011-02-02 14:49:55 PST
By any chance, can you compile Firefox with the patch in bug 629331?

(In reply to comment #32)
> Surely though, given volkmar's assertion that the first link does not show
> reviews seems completely erroneous, a supposed tie to that bug is likely to be
> misconceived?

I don't understand what "erroneous" stand for here. When I tried to load this page, i got a time out message in the "user's review" section and with the other link it was working. With the patch in bug 629331 both pages were working.
Maybe it was a coincidence, we will see.
Comment 36 orangezilla 2011-02-02 15:25:37 PST
(In reply to comment #35)
> I don't understand what "erroneous" stand for here. When I tried to load this
> page, i got a time out message in the "user's review" section and with the
> other link it was working. With the patch in bug 629331 both pages were
> working.
> Maybe it was a coincidence, we will see.

It was not a coincidence, it was entirely consistent with what I and Vimes have explained. You presumably arrived at the first link while browsing the argos site- as we have stated in our explanations, it is browsing of the site before accessing a product link that causes the reviews in product pages not to work. If you click the links above after restarting making sure there were no argos windows in session restore, you will see both links work.
Comment 37 orangezilla 2011-02-02 15:43:25 PST
OK I did a test to demonstrate:

access the digital SLR category
http://www.argos.co.uk/static/Browse/ID72/25417975/c_1/1|category_root|Photography|14419436/c_2/2|cat_14419436|Digital+SLR+cameras|25417975.htm

access this link 
http://www.argos.co.uk/static/Product/partNumber/5592829.htm
reviews do not work

access this link without restarting & in same tab
http://argos.co.uk/static/Product/partNumber/5592829.htm
reviews do not work

I can only assume you accessed the second link in comment 29 without the 'www', without having first accessed a category or homepage of argos in that session, so it worked as I would expect according to my explanations in comment 17 and comment 26
Comment 39 orangezilla 2011-02-03 13:46:57 PST
Sorry should be Kesa group, + more site, 13 extra found now

http://www.jcpenney.com/
Comment 40 [not reading bugmail] 2011-02-03 23:07:50 PST
I notice there is a bug with www.argos.co.uk reviews, that you still cannot flip between review pages in the current build, but that part works as recent as beta 10, but its not reproduceable on www.laskys.com reviews, even though they are using almost identical review code / url formats.
Comment 41 Blake Kaplan (:mrbkap) 2011-02-03 23:48:11 PST
Bug 629331 has been checked into trunk, so it's possible (likely, even) that this will be fixed in tomorrow's nightly.
Comment 42 Eddward 2011-02-04 00:27:49 PST
For me it's now fixed :)
Built from http://hg.mozilla.org/mozilla-central/rev/ed958cdc8396
Comment 43 orangezilla 2011-02-04 09:38:39 PST
Using today's nightly 2011-02-04 it is indeed fixed, thanks everyone who worked to fix this, also apologies to volkmar for doubting....
Comment 44 vimes_2004 2011-02-05 01:40:52 PST
Indeed it does seem to be resolved. Many thanks to all of those involved in helping to identify and fix this problem, most appreciated :)
Comment 45 vimes_2004 2011-02-08 02:49:59 PST
I have reopened this bug as the resolve does not completely work...

Browse the this item (any item it applies to)...

http://www.argos.co.uk/static/Product/partNumber/5296417.htm

then scroll for the reviews (227 of them)....

They will display perfectly but scroll to the last review on that page and notice that there are 36 pages of reviews. Select any one of those pages and it will not open. 

Any product behaves the same. The first page of reviews works as it should but if the item has had many more reviews which span across several pages then each subsequent page cannot be opened. This is using the latest nightly built 7th Feb 2011. Internet Explorer works as it should with each page opening.

I have zero extensions installed for this test.
Comment 46 Mounir Lamouri (:mounir) 2011-02-08 02:56:03 PST
You are describing bug 631725.
Comment 47 vimes_2004 2011-02-08 02:58:38 PST
sorry - that is of course perfectly correct. Thanks for letting meknow and glad that it has been reported.
Comment 48 Thang Dao 2015-10-04 20:34:20 PDT Comment hidden (spam)

Note You need to log in before you can comment on or make changes to this bug.