If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

ASTSerializer::leftAssociate right-associates

RESOLVED FIXED

Status

()

Core
JavaScript Engine
RESOLVED FIXED
7 years ago
5 years ago

People

(Reporter: jorendorff, Assigned: jorendorff)

Tracking

Other Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fixed-in-tracemonkey])

Attachments

(1 attachment)

(Assignee)

Description

7 years ago
I was playing with my minimizer this weekend and came across this.

Reflect.parse("a-b-c") produces a tree for "a-(b-c)".

  js> uneval(Reflect.parse("a-b-c",{loc:0})) ===
      uneval(Reflect.parse("a-(b-c)",{loc:0}))
  true

But they're two different programs.

  js> var a=3, b=2, c=1;
  js> a-b-c
  0
  js> a-(b-c)
  2
(Assignee)

Comment 1

7 years ago
Created attachment 508422 [details] [diff] [review]
v1
Assignee: general → jorendorff
Attachment #508422 - Flags: review?(dherman)
Oy, this one's embarrassing. Patch is good, thanks. r=me

Dave

Updated

7 years ago
Attachment #508422 - Flags: review?(dherman) → review+
(Assignee)

Comment 3

7 years ago
http://hg.mozilla.org/tracemonkey/rev/5c9527251fe9
Whiteboard: [fixed-in-tracemonkey]
http://hg.mozilla.org/mozilla-central/rev/5c9527251fe9
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED

Updated

5 years ago
Duplicate of this bug: 686305
You need to log in before you can comment on or make changes to this bug.